1. scottee's Avatar
    Got a new Type Cover 2 from Staples yesterday. The touchpad and backlight work but the keys don't. Not on the Surface anyway (the brightness keys work on the keyboard backlight).

    I've tried installing all updates and restarting.

    Discovered that after attaching the Type Cover, it shows up in Device Manager as an Unknown Device. It lets me update via searching the internet automatically, and then registers as a keyboard, but the keys still don't work. Then I restart the Surface and it shows up as Unknown Device again.

    This happens on both my wife's Surface and mine. Both 32gb RT's running 8.1.

    Waiting in queue for Microsoft support right now, but not optimistic. Any help would be appreciated.
    02-15-2014 03:41 PM
  2. rdubmu's Avatar
    It might sound like your have a defective product. I would reach out to stables and try to get another one or just return it.

    Do you have a Microsoft Store near where you live? I Would take your surface into the MS Store and try one of their Type covers 2.
    02-15-2014 04:38 PM
  3. azcruz's Avatar
    Do a refresh. It happened to me. By the way, trackpad works in mouse mode. Try it.


    Sent from my iPhone using Tapatalk
    02-15-2014 05:02 PM
  4. scottee's Avatar
    The online chat person actually did solve it. It took a Refresh with the Type Cover attached, and now the driver sticks. Doing the same on my wife's Surface now. It's too bad it takes such a long process to get it to work properly, and there's no instructions as such included when you buy the cover.

    But at least it's working well!
    02-15-2014 05:25 PM
  5. Racing Snake's Avatar
    It's too bad it takes such a long process to get it to work properly, and there's no instructions as such included when you buy the cover.
    This isn't normal though, I suspect there was something you installed on both of your units to cause this issue.

    I just connected it and it worked straight off, and this was on a 8 month old surface 64gb rt.
    02-16-2014 12:02 PM
  6. scottee's Avatar
    This isn't normal though, I suspect there was something you installed on both of your units to cause this issue.

    I just connected it and it worked straight off, and this was on a 8 month old surface 64gb rt.
    They were both from the refurb deal on Ebay, but both appear to be brand new. Did all the Microsoft updates, and then haven't installed much, other than a couple small apps. Nothing that would seem to make drivers not stick.

    The only thing I can think of is we've used Touch Covers on both Surfaces, so maybe the drivers for that caused the Type 2 Cover's drivers not to stick?
    02-16-2014 08:02 PM
  7. azcruz's Avatar
    They were both from the refurb deal on Ebay, but both appear to be brand new. Did all the Microsoft updates, and then haven't installed much, other than a couple small apps. Nothing that would seem to make drivers not stick.

    The only thing I can think of is we've used Touch Covers on both Surfaces, so maybe the drivers for that caused the Type 2 Cover's drivers not to stick?
    Like you, I was using a Touch Cover since day 1. Putting in the Type Cover 2 gave the same experience as you described. The refresh made it recognize both Covers.
    02-16-2014 08:48 PM
  8. scottee's Avatar
    Like you, I was using a Touch Cover since day 1. Putting in the Type Cover 2 gave the same experience as you described. The refresh made it recognize both Covers.
    It sounds like the drivers for the Touch Cover interfere with loading the updated drivers for the Type Cover 2. I'll bet a refresh isn't necessary and it just takes uninstalling the original Touch Cover drivers and then letting Windows install the drivers for the Type 2.
    02-17-2014 01:19 AM
  9. azcruz's Avatar
    It sounds like the drivers for the Touch Cover interfere with loading the updated drivers for the Type Cover 2. I'll bet a refresh isn't necessary and it just takes uninstalling the original Touch Cover drivers and then letting Windows install the drivers for the Type 2.
    Been there, done that.
    02-17-2014 02:37 AM
  10. Racing Snake's Avatar
    I too had a touch cover from Day 1!
    lol
    02-18-2014 01:09 AM
  11. azcruz's Avatar
    I too had a touch cover from Day 1!
    lol
    So, if other people had problems with it and solved it differently, it is laughable?

    LOL
    02-18-2014 02:16 AM
  12. WillysJeepMan's Avatar
    Like you, I was using a Touch Cover since day 1. Putting in the Type Cover 2 gave the same experience as you described. The refresh made it recognize both Covers.
    There was an optional update to WinRT 8.1 a few days ago that I just installed today. When it completed, my TypeCover2 no longer worked (touchpad worked, keys didn't). I had to do a refresh for it to be recognized. This is the 2nd time since Sept 2013 that an update required me to refresh.

    So then I re-check for updates and now it seems like all updates to 8.1 need to be reapplied. This is seriously ticking me off. I can understand this for full Windows, but WinRT should be more resilient. My reason for using a tablet instead of a notebook is because it is (or in my mind SHOULD BE) an appliance. It shouldn't need regular updates, patches, and housekeeping to delete old stuff and logs.
    02-18-2014 04:20 PM
  13. azcruz's Avatar
    I did a second refresh already after a patch Tuesday update months back. I posted about it in an off topic thread as a rant.

    This month's patch Tuesday seems ok though, but I have not installed an optional update. I'm not sure if it's the same one you refer to.


    Sent from my iPhone using Tapatalk
    02-18-2014 04:34 PM
  14. Aimee Rong's Avatar
    What is this refresh everyone is talking about? Is it simply a system update. I bought a Type 2 cover for my Suface RT but none of the keys are working. The backlight and the function keys are working.
    02-19-2014 08:15 PM
  15. Elvis7's Avatar
    What is this refresh everyone is talking about? Is it simply a system update. I bought a Type 2 cover for my Suface RT but none of the keys are working. The backlight and the function keys are working.
    swipe left to right from the edge of the screen, then select settings, go down to update and recovery, select refresh, itll remove settings etc but keep everything else like apps and files.
    03-19-2014 12:57 PM
  16. Will6371's Avatar
    What is this refresh everyone is talking about? Is it simply a system update. I bought a Type 2 cover for my Suface RT but none of the keys are working. The backlight and the function keys are working.
    Make sure when you do your refresh that you have your cover attached to the surface when your doing the refresh, that will get it to recognise the cover.
    03-19-2014 02:23 PM
  17. barnyr's Avatar
    I have the same issue. I used touch cover for months, then tried to use the type cover from my surface pro 2. The touchpad works, keys do not. I cannot refresh as the recovery image was deleted when I took the surface to Microsoft store to have them upgrade from 8.1 preview to 8.1rtm. I guess I need to go to the Microsoft store again and have them refresh and make sure the type cover works this time.
    03-20-2014 11:22 AM

Similar Threads

  1. Power Cover Keyboard?
    By Great deal in forum General Desktop, Laptop & Tablet Discussion
    Replies: 4
    Last Post: 02-24-2014, 06:36 PM
  2. New surface 2 rt with hd av adapter, no audio?
    By Plystre in forum Microsoft Surface 2
    Replies: 5
    Last Post: 02-17-2014, 05:36 AM
  3. Miracast connects but fails to send video - help!
    By andrewkeith5 in forum Windows 8
    Replies: 2
    Last Post: 02-16-2014, 01:00 PM
  4. my new nokia Lumia 720 crashing a lot :(
    By raj-lotus in forum Nokia Lumia 720
    Replies: 9
    Last Post: 02-16-2014, 10:47 AM
  5. new leaks confirming a lot of goodness!!!
    By trandz in forum Windows Phone 8.1
    Replies: 6
    Last Post: 02-15-2014, 02:52 PM
LINK TO POST COPIED TO CLIPBOARD