1. Jack Janik's Avatar
    Hello all! I purchased GTA: San Andreas to play on my Surface RT while bored, but I'm running into some problems. At first, it was going fine, just downloading the app, like expected. Then, the store told me I didn't have enough free space, so I went and deleted some files. Now I do have enough space, but it's just "pending" in the store. I've tried to restart, I've tried to cancel the install, I don't know what to do as this is really slowing down my tablet. :c
    03-07-2014 09:34 PM
  2. rdubmu's Avatar
    Can you cancel the request?
    Jack Janik likes this.
    03-08-2014 12:08 AM
  3. Jack Janik's Avatar
    I got it to work: I defragmented my surface, and emptied my recycle bin, and then I had enough space so I canceled the install, restarted it, then installed it. And it worked. :3
    03-08-2014 03:07 PM

Similar Threads

  1. OneDrive File Access Issue
    By MA83 in forum OneDrive
    Replies: 17
    Last Post: 03-17-2014, 10:11 AM
  2. Facebook App issue
    By createwww in forum General Desktop, Laptop & Tablet Discussion
    Replies: 10
    Last Post: 03-16-2014, 08:16 PM
  3. Dungeon Hunter Issues
    By Quin452 in forum Games
    Replies: 2
    Last Post: 03-08-2014, 12:48 PM
  4. Random other storage issue Lumia 720
    By chancooluk in forum Nokia Lumia 720
    Replies: 1
    Last Post: 03-06-2014, 11:53 PM
  5. Wp store not working. Please help
    By stalemate1 in forum Windows Phone 8
    Replies: 3
    Last Post: 03-06-2014, 09:38 AM
LINK TO POST COPIED TO CLIPBOARD