1. Editguy1900's Avatar
    So, I shut down my RT, and when I went to boot it up again the "Surface" splash screen comes up and then it goes top a symbol of a battery with a circle around it. I know my charger is good (I have two and they work on another tablet but neither make a difference on this one).When I connect the charger to the Surface, the light comes on briefly and then goes off. Any ideas? Bad battery or charging port maybe?
    03-16-2014 07:12 PM
  2. Jack Janik's Avatar
    Maybe give it time? It could just be the indication light isn't going on. Give it 10 minutes and try booting again.
    03-16-2014 07:38 PM
  3. Editguy1900's Avatar
    Thanks for the reply, but I'd already tried that. This has been going on for a few days. I guess it's time to contact MS for warranty service.
    03-17-2014 02:39 PM
  4. prlundberg's Avatar
    You probably tried this, but I had issues with mine where the light wouldn't stay on but if I flipped the charger upside down from how I normally plugged it into the Surface it worked. That only happened a couple times that I know of but I thought it was strange.
    03-17-2014 04:57 PM
  5. Editguy1900's Avatar
    Yeah, I tried that and it didn't work. That is strange. I really wish Microsoft had not used a proprietary charging connector. Anyway, thanks for trying. I'm getting a replacement from Microsoft. I hope it's been cared for as well as mine.
    03-18-2014 01:09 AM
  6. vaultsurvivor's Avatar
    I had to get mine replaced last week because of a faulty headphone jack... The one they sent through is like new (and the jack works perfectly lol!). In fact the only negative part for me was ups not delivering on weekends, so i had to redirect it to my work address... Who doesn't deliver on Saturdays!? An I have to use my day off this week to wait in for a collection between 9am and 7pm. Yeah, thanks ups...
    03-18-2014 01:18 AM
  7. Editguy1900's Avatar
    That's good to hear (not the UPS part ). I was hoping they wouldn't send out beat up units.
    03-18-2014 03:07 PM
  8. vaultsurvivor's Avatar
    Yeah, the unit is in really good condition (honestly, it youd never know if its a refurb). Just make sure that when you run the first setup you attach the touch/type cover. I got excited and forgot, then had to do a system restore because the keypad wasn't typing (though the trackpad and volume keys worked), because the surface hadn't bothered installing the drivers for the touch keypad on first setup... Hope youce got your replacement okay!
    03-20-2014 10:21 AM

Similar Threads

  1. Gmail contacts sync problem
    By awinstephen in forum Windows Central for Windows Phone - App Support
    Replies: 1
    Last Post: 03-27-2014, 10:49 AM
  2. Replies: 6
    Last Post: 03-17-2014, 10:38 PM
  3. Using Apps problem outside home
    By jfloyd256 in forum Nokia Lumia 520
    Replies: 1
    Last Post: 03-16-2014, 07:16 AM
  4. Problem with amber update
    By Jagadeesh Maroju in forum Nokia Lumia 620
    Replies: 2
    Last Post: 03-16-2014, 02:07 AM
  5. Gaming on the Surface RT.
    By Jack Janik in forum Microsoft Surface for Windows RT
    Replies: 2
    Last Post: 03-15-2014, 05:56 PM
LINK TO POST COPIED TO CLIPBOARD