1. ZombieXboxBlog's Avatar
    Hi folks,

    I got a refurbished Surface RT (1) recently and got the Touch Cover 2 to go with it on the basis that the additional sensors would be a big factor in using it for typing.

    Broadly speaking, it works fine and I don't mind it, but every now and then it becomes unresponsive.

    I first thought it was something to do with IE, as it seemed to work fine in the mail app or in office, but not when using IE (either the app or in desktop mode).

    I had two business trips in consecutive days last week so I got a chance to really leather it and see how it handled, and for nearly the whole two days it was absolutely fine in all mods, as responsive as I would like and it built my confidence enough that I could type really quick on it.

    Then, the person I was sat next to on the train had to move, so I picked up the tablet, laid it to one side, let her out, then when I sat back down with it the Touch Cover was really unresponsive again!

    To give an idea of what I'm on about, I would watch my hands as I touched the keys (to make sure it wasn't just me making mistakes) and there were points where I would have to hit a key three times before it registered on the tablet.

    So I get really fed up, pack it away and put the tablet to sleep. I then switch trains and while I'm on the short 10 minute leg to my house, I whip it back out, wake it up and give it another shot - and lo and behold it's super fast again.

    My instinct is that there is an issue with the tablet in how it is responding to the cover, and possibly it could relate to workload or even internet connectivity (I know that sounds daft, but I'm using mobile broadband and when there is no reception I know sometimes things might slow up as it tries to constantly reconnect - though this tends to be more in Xbox Live games).

    However, reading some of the threads on here I saw one person had an issue possibly relating to a wire/thread coming open/loose and it could be related to this e.g. when it's not working properly it's not sending a proper signal of what keys I'm pressing, but when it is, it works fine.

    I'm currently on the verge of buying an additional bluetooth keyboard to carry as a back-up whenever it stops working well but it makes me feel like I should have just gotten a Type Cover, which I avoided as I didn't want the feel of the keys when I flipped it back to just use the tablet on its own.

    Any thoughts appreciated!
    04-28-2014 07:24 AM
  2. onlysublime's Avatar
    are you sure it's the touch cover 2? sometimes the Surface RT is sluggish. I notice sometimes (for some unknown reason), the disk usage goes up really high (can even stay around 100%; you can check in the task manager). and during this sluggish period, typing on the keyboard becomes sluggish (you type and no text appears, and then all of a sudden, some of the keys get inputted as it got buffered).

    I assume the high disk usage is related to file indexing. Rebooting the system or pausing/disabling the indexing helped. Also, always leaving at least 3 GB of storage free helped.
    04-28-2014 10:30 AM
  3. ZombieXboxBlog's Avatar
    Yes definitely a Touch Cover 2, though I panicked when you said that and wondered if I'd accidentally bought the wrong thing! It's got backlit keys and everything. :P

    You might have a point re: space - I know it played up massively when I went under 3GB because it couldn't sync the OneDrive. Thanks for the tips.
    04-29-2014 08:20 AM
  4. cndspec's Avatar
    I have noticed sometime with our units in the house that if the touch cover doesn't quite seat properly when it snaps in it will have issues as you describe. I have always found just taking it off and then re-snapping it back on immediately solves the issues.
    04-29-2014 02:03 PM
  5. ZombieXboxBlog's Avatar
    Cool, think I've tried that but I'll bear it in mind - would make sense in that I moved it and then it stopped working properly, then closed it and tried again ten minutes later and it worked...
    04-29-2014 02:17 PM

Similar Threads

  1. Workaround for Missing GPS tags on DNG Files
    By Intrepid00 in forum Nokia Lumia 1020
    Replies: 3
    Last Post: 02-26-2015, 10:52 PM
  2. What's wrong with my back button?
    By vkstarry in forum Windows Phone 8.1 Preview for Developers
    Replies: 5
    Last Post: 04-28-2014, 10:23 AM
  3. Replies: 2
    Last Post: 04-28-2014, 10:01 AM
  4. New Nokia ad shows how its partnership with Microsoft is 'not like everybody else'
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-28-2014, 04:40 AM
  5. Minor issue with messaging post 8.1 DP
    By jfa1 in forum Nokia Lumia 920
    Replies: 1
    Last Post: 04-27-2014, 09:43 PM
LINK TO POST COPIED TO CLIPBOARD