1. Daniel Gandolfo's Avatar
    Hello,

    I have noticed that my Surface RT power LED (with magnetic strip) was not lit up when attached to the Surface. I checked the power connector and everything is in order.

    I then clicked on the power icon in lower right hand corner and it said that the battery was not present.

    I turned the Surface off and on again and the Surface logo appears then a large battery symbol with 1 bar showing.

    One of two things could have happened.

    1) The transformer has stopped working.

    2) The battery has stopped working.

    Any advice would be most appreciated.

    Nevica
    08-31-2014 12:43 PM
  2. Kellzea's Avatar
    I had a similar problem early this year. Contact Microsoft for a repair/replacement. Takes about a week.
    08-31-2014 12:46 PM
  3. Daniel Gandolfo's Avatar
    The surface is out of warranty. Its over a year old!

    What did Microsoft say was the problem with your Surface when you sent it to them?
    Last edited by Daniel Gandolfo; 08-31-2014 at 01:50 PM.
    08-31-2014 12:48 PM
  4. Kellzea's Avatar
    They just sent me a new one as I went for premium exchange. I would still contact them, they should offer a paid repair if nothing else.

    You may also get lucky and be able to take it to a repair place near you.
    09-01-2014 01:59 PM

Similar Threads

  1. Original Surface RT Locking Up!
    By infinidim in forum Microsoft Surface for Windows RT
    Replies: 4
    Last Post: 09-02-2014, 11:22 AM
  2. All about the HTC ONE (M8) for Windows
    By xandros9 in forum HTC One (M8) for Windows
    Replies: 3
    Last Post: 08-31-2014, 11:58 AM
  3. lumia 525 windows 8.1 update problem
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2014, 11:32 AM
  4. Lumia 820 complete reset? Problem with email?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2014, 11:22 AM
  5. reseting windows 8.1
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-31-2014, 11:11 AM
LINK TO POST COPIED TO CLIPBOARD