1. maczealot#WP's Avatar
    I have a Moto Q9c on Sprint. What happens is every two months, all of a sudden one day my phone starts going psycho on me. It gets crazy slow and freezes up all the time. It will literally take a minute or more for it to even register a button press and execute the command. When I type messages, I can't see what I'm typing because the words never appear and remnants of previous messages stay on screen. It freezes up constantly. I can't lock the keypad because it takes so long to register keypresses that I can't press the star key fast enough to confirm the unlock. Sometimes the Start menu disappears and there are no icons on it. It becomes completely unusable.

    It starts doing this suddenly and once it does, I can't do anything to fix it. All I can do is master reset it. Power cycling it helps a little for a few minutes.

    I've been to Sprint about this and had to master reset my phone 6 times in a year. Motorola even had me do the same thing. It's all they ever do. Sprint finally replaced it for me and now it's doing it too, right on schedule two months after I got it. I'm at wit's end. I can't keep resetting it every two months and spending a week getting it back the way it was.

    Could it be that I have too many apps on there and the phone just can't handle it? I have 17 apps I've installed, plus all the preinstalled software on top of it. I install everything to the memory card except for apps that use the hardware like for example something that's used to take a picture or the GPS navigation program. I've tried clearing out all my messages and browser cache and removed some programs I'm not using much. What else can I do?

    I have it set up so I can recover from the reset within a couple days now. It used to take a week. But now I have all the installer files lined up ready to go on my memory card so I can just start reinstalling them right away. All my contacts and calendar are on an Exchange server and they come back instantly. But each of those apps still has to be configured again, as do all my phone settings. It's still a lot of work and it's unacceptable.

    But this brings me to a new question: could it be the Exchange server is killing my phone? In the Podcast, Dieter and Malatesta mentioned that it could be something running in the background syncing with something. That would describe Active Sync. It's hard to pinpoint when the problems started with my phone, but I do think it was after I added the Exchange server. I asked the IT guys at work if they ever had a problem and three of them said no. But my supervisor said the Exchange server would make his iPhone go crazy everytime IT did an update on our servers. So that has me wondering if that could be the root of my problems. If it is, then why? And are would I have the same problem with a public Exchange server?

    Sorry this is long but there's just no way to explain it in fewer words. It's a complex problem. Even the techs at the store, when I explain the problem, look at me bewildered and give me the PR flavored version of 'your phone is screwed, let's just wipe the slate clean and start over.' Then that's what they do.

    Thanks,
    Nate Mylott
    http://www.retaggr.com/card/natemylott
    http://natemylott.myplaxo.com
    12-22-2008 08:37 PM
  2. bubbatex's Avatar
    Couple of questions - how many emails do you keep sync'ed on your Q9c? I keep one month's worth, not my entire mailbox. I also only have about 500 contacts. Exchange could be a problem if you have a large amount of data.

    Second - do you do any file cleaning maintenance? I use SKTools Lite about every week or two to clean up temp files. My business partner had a similar problem with his Q9c getting sluggish then I found that he had never cleaned up his PIE temp files that were hogging tons of memory.
    01-01-2009 09:58 PM
  3. maczealot#WP's Avatar
    I do clean out my PIE temp files every so often, but I've never run an app like you're talking about. I honestly don't really know how many emails I'm keeping. I have it synced with Exchange so I suppose it's possible all those emails are still there in my phone. I only see recent emails in my inbox. I have three imap accounts on my phone too. How would I make sure the emails aren't saving on my phone? Is there a setting in there for that?
    01-05-2009 11:24 PM
  4. cplush#WP's Avatar
    i have a verizon q9c, and was having RAM issues and the SK tools Lite have really helped. but having 4 email accounts will bog down your machine because all the emails are saved on the device. what you might also try is turning off the three imap accounts from push and then you can manually send and receive for those three when you want to. maybe this will keep the machine from checking all 4 accounts at the same time and bogging down. but do try the sktools lite and see if that helps keep your phone running smoothly
    01-06-2009 07:53 AM
  5. bubbatex's Avatar
    For the Exchange Account - on the phone open ActiveSync > Menu > Options > Highlight "E-mail" > click right soft key "Settings". The first setting controls the amount of email you keep on the device. I have mine set to "1 month".
    01-06-2009 08:45 AM
LINK TO POST COPIED TO CLIPBOARD