07-19-2015 09:50 PM
45 12
tools
  1. sunnybyday's Avatar
    That is very good speed you are getting! I have never see anything above 8mbps on my ATT Lumia 925 on Straight talk :(

    Just to confirm, you have the below settings on both - cellular and access point? I only have access point settings, deleted the internet apn under cellular.

    Internet APN
    APN: tfdata


    MMS APN
    APN: tfdata
    WAP Gateway: 66.209.11.33
    WAP Gateway Port: 80
    MMSC URL: mmsc.cingular.com
    MMSC Port: 80
    10-29-2013 08:49 AM
  2. feraask's Avatar
    That is very good speed you are getting! I have never see anything above 8mbps on my ATT Lumia 925 on Straight talk :(

    Just to confirm, you have the below settings on both - cellular and access point? I only have access point settings, deleted the internet apn under cellular.

    Internet APN
    APN: tfdata


    MMS APN
    APN: tfdata
    WAP Gateway: 66.209.11.33
    WAP Gateway Port: 80
    MMSC URL: mmsc.cingular.com
    MMSC Port: 80
    Not exactly. I first Added the following into Access Point and set it to active and restarted my phone:
    INTERNET APN

    Access Point Name: tfdata
    Username: leave blank
    Password: leave blank
    Proxy Address: leave blank
    Proxy Port: leave blank
    Network type: IPv4
    Authentication type: none



    MMS APN
    MMS Access Point Name: tfdata
    Username: leave blank
    Password: leave blank
    Proxy address: mms3.tracfone.com
    Proxy port: 80
    MMSC address: http://mms-tf.net
    Network type: IPv4
    Authentication type: none


    Then I went into the cellular settings and used the settings you mentioned:
    Internet APN
    APN: tfdata

    MMS APN
    APN: tfdata
    WAP Gateway: 66.209.11.33
    WAP Gateway Port: 80
    MMSC URL: mmsc.cingular.com
    MMSC Port: 80

    I ran another speed test today around noon and got about 10Mbps download. So the speed variations are probably just due to network congestion since I got 20+Mbps download around 2AM when I doubt there were as many people using the network.
    10-31-2013 01:07 PM
  3. Cristina2012's Avatar
    I have an unbranded unlocked Nokia Lumia 920. I have an AT&T Compatible Straight Talk Sim Card !

    When I took Straight Talk card and insert it would not give celullar option for APN

    I installed access point app from windows :
    [url=http://www.windowsphone.com/en-us/store/app/access-point/ce3895c7-01d0-4daf-a4c3-25c10463942d]access point | Windows Phone Apps+Games Store (United States)[/url]

    Once access point is installed go in Settings at the end you have Access Point.

    Inside add a new profile + at the bottom

    Straight Talk name

    Internet APN: att.mvno
    User Name: leave blank
    Password: leave blank
    Proxy server (URL): proxy.mvno.tracfone.com
    Proxy port: 80

    MMS APN: att.mvno
    User name: leave blank
    Password: leave blank
    WAP gateway (URL): 66.209.11.33
    WAP gateway port: 80

    Below you will have a choice for the IPV .

    I used IPV4V6 INSTEAD OF JUST IPV4
    Also the MMSC address as http://mmsc.cingular.com

    This should make it work .

    If your wifi is on or off you may notice differences . it is strange how you have to play with the settings but it should work.

    The setting for Straight Talk LTE SIM are different :

    Someone posted them above. I honestly believe the trick with IPV4V6 Instead of IPV4 holds the key. But you should try both.
    Last edited by Cristina2012; 11-12-2013 at 01:57 PM.
    11-12-2013 01:36 PM
  4. Ukyo's Avatar
    UPDATE 10/28/13: Confirmed sending MMS works with the settings and info I used in the 10/27/13 update below.

    UPDATE 10/27/13: Okay I seem to have got everything working including MMS (at least I am not getting any errors trying to send, I have yet to confirm they are actually being sent). I'm not sure what I changed that made it work but I first put the above settings into access point (and I had deleted my APN settings in the Windows Phone 8 cellular settings). Then restarted my 1020, then put new APN's in the cellular settings with the following info:

    Internet APN
    APN: tfdata


    MMS APN
    APN: tfdata
    WAP Gateway: 66.209.11.33
    WAP Gateway Port: 80
    MMSC URL: mmsc.cingular.com
    MMSC Port: 80


    OLD: I've tried putting these settings into Access Point on my 1020 Locked to ATT and my data works fine (I get LTE) but I can't send any MMS. I haven't tried receiving MMS yet but I just keep getting an error saying it can't send for my pictures.

    Anyone else getting MMS working with these settings?
    Neither those settings direct from ST or your proposed settings work for me. I do get LTE but still can't seem to get MMS working... I'm afraid to even call ST support...
    11-19-2013 04:09 PM
  5. Gladstoner's Avatar
    Neither those settings direct from ST or your proposed settings work for me. I do get LTE but still can't seem to get MMS working... I'm afraid to even call ST support...
    I had to put a space then 1 after the apn to get my data and mms to work. Does not seem anyone else had my problem here. my apns are tfdata 1
    11-19-2013 09:33 PM
  6. mary beth hale's Avatar
    have been using straight talk att sim with my unlocked ativ s for 4 months. for internet apn it's just tfdata. everything else blank except IP...IPv4v6. For mms settings here is a screen shot. not sure if having a samsung makes a difference. i didn't have to download an app since my phone was unlocked and it let me edit apn settings in cellular settings
    DeathDealers167 likes this.
    11-19-2013 10:11 PM
  7. Ukyo's Avatar
    I had to put a space then 1 after the apn to get my data and mms to work. Does not seem anyone else had my problem here. my apns are tfdata 1
    Tried that under internet APN and my data stopped working. Tried it on the MMS APN but still doesn't work...

    have been using straight talk att sim with my unlocked ativ s for 4 months. for internet apn it's just tfdata. everything else blank except IP...IPv4v6. For mms settings here is a screen shot. not sure if having a samsung makes a difference. i didn't have to download an app since my phone was unlocked and it let me edit apn settings in cellular settings
    My access point setting does not have WAP entries....
    11-20-2013 06:05 PM
  8. mary beth hale's Avatar
    Really sorry. You must be so frustrated.
    11-20-2013 07:51 PM
  9. Ukyo's Avatar
    Ok finally got it to work. I thought everyone was just using the access point app to make changes but saw that people were using the system > cellular > internet and mms apn settings. For those who didn't try that, it may work for you.
    11-22-2013 09:09 PM
  10. frizodanizzo's Avatar
    I tried the above settings with the mms3.tracfone.com APN with the fields left blank mostly for data. Seems to work well on the Lumia 1020 and the lumia 925.
    11-30-2013 11:50 AM
  11. sugarsmax321's Avatar
    ok, so I have tried every configuration of settings for my apn's. I just spent 2 hours with ST techs who finally informed me my phone wouldn't get MMS or Data because "it's from China, and we don't support foreign phones." well, alrighty then. I got mad and boom, I had data and mms working in 5 minutes, no problem. Here's where I started and what I did:
    I purchased an unlocked phone from GSM Nation in Sept,. a Lumia 1020. From the start had issues with mms, then data too. I purchased my sim from ST directly. This is what I did differently:
    My phone, upon delivery, had in its Settings an ATT option. I never used it, thinking i HAD to input setting apn's and proxy numbers under ST . I always created a new name of ST and input my info that way. This time, I said screw it and chose the ATT option that popped up when I opened "access point" on my phone. Here's my settings, and once I put them in and rebooted, everything worked perfectly.
    name: Alternate ST (LOL, in case it didn't work)
    Access Point Name: tfdata
    Proxy: 66.209.11.33
    Port:80
    Network:Ipv4
    MMS APN ; tfdata
    Proxy address:66.209.11.33
    Port:80
    MMSC address; mmsc.cingular.com
    network type: IPv4

    And that's what worked for me. I did a happy dance, since I've had the phone for 2 months and couldn't get it to work right. If anything changes or quits working, I'll update that too. I almost switched to Gophone over this; this has been incredibly frustrating. But I absolutely love my 1020 and it was worth it if it solved the problem
    12-04-2013 02:02 PM
  12. person of interest's Avatar
    I tried the above settings with the mms3.tracfone.com APN with the fields left blank mostly for data. Seems to work well on the Lumia 1020 and the lumia 925.
    Apparently the connection name makes the difference. These are the settings I got after talking to customer service ( I know what you all are thinking, but the receptionist actually helped me out and got my MMS working)

    Phone: Nokia Lumia 925 (RM-892 model international)

    AT&T Micro-SIM 4G LTE (due to phone model I can only get HSPA+ speeds maximum)

    Connection Name: Straight Talk

    Internet APN
    Internet Access Point Name: tfdata
    Proxy address: mms3.tracfone.com
    Port: 80
    Leave other settings alone.

    MMS APN
    MMS Access Point Name: tfdata
    Proxy address: mms3.tracfone.com
    MMSC Address: http://mms-tf.net
    Proxy port: 80
    Leave other settings alone.

    Those exact settings worked for me, hopefully it does for you all too.

    Sent from Nokia Lumia 925.
    12-06-2013 07:07 PM
  13. mary beth hale's Avatar
    Been using ST at&t sims on unlocked phones for 3+years. If you can get past the customer service issues, nothing beats the price! Have found using the Facebook page to send a "help ticket" is the way to go for problems.
    12-09-2013 09:50 AM
  14. Ukyo's Avatar
    ok, so I have tried every configuration of settings for my apn's. I just spent 2 hours with ST techs who finally informed me my phone wouldn't get MMS or Data because "it's from China, and we don't support foreign phones." well, alrighty then. I got mad and boom, I had data and mms working in 5 minutes, no problem. Here's where I started and what I did:
    I purchased an unlocked phone from GSM Nation in Sept,. a Lumia 1020. From the start had issues with mms, then data too. I purchased my sim from ST directly. This is what I did differently:
    My phone, upon delivery, had in its Settings an ATT option. I never used it, thinking i HAD to input setting apn's and proxy numbers under ST . I always created a new name of ST and input my info that way. This time, I said screw it and chose the ATT option that popped up when I opened "access point" on my phone. Here's my settings, and once I put them in and rebooted, everything worked perfectly.
    name: Alternate ST (LOL, in case it didn't work)
    Access Point Name: tfdata
    Proxy: 66.209.11.33
    Port:80
    Network:Ipv4
    MMS APN ; tfdata
    Proxy address:66.209.11.33
    Port:80
    MMSC address; mmsc.cingular.com
    network type: IPv4

    And that's what worked for me. I did a happy dance, since I've had the phone for 2 months and couldn't get it to work right. If anything changes or quits working, I'll update that too. I almost switched to Gophone over this; this has been incredibly frustrating. But I absolutely love my 1020 and it was worth it if it solved the problem
    What LTE speeds are you getting and where are you located? I don't have your APN settings but I don't want to mess w/ mine unless your speeds are much quicker as it took me forever to get everything working (mms, data, etc). Thanks!
    12-09-2013 02:52 PM
  15. mary beth hale's Avatar
    @joe920...have used 3 different phones on ST and each time it took an hour or 2 for the new apn settings to "kick in". This last time with my ativ s the mms didn't work until the next day. Once mms and data start working,though,I never have another problem.
    Joe920 likes this.
    12-16-2013 10:26 PM
  16. DeathDealers167's Avatar
    That worked for me, thanks for helping.
    03-08-2014 09:20 PM
  17. zelzs81's Avatar
    Ok, so I just bought the Unlocked Samsung ATIV SE and I am putting it on Straight Talk, but I cannot get it to download the Access Point App... Someone help please!!! Where did you download it from? Thanks!!!
    05-11-2014 08:15 AM
  18. Genesis Coupe's Avatar
    Does this still work as of 8/5/2014
    08-05-2014 02:42 PM
  19. civiccoconut's Avatar
    I have tried all the settings on this blog and they are no longer working. I am pretty sure they worked before. Does anyone have an update for the codes for the Lumia 1020 ATT phone on Straight Talk? After Windows updates, my phone will no longer send and receive photos on Straight Talk.

    Oops. Just saw that it may take a day. Will update.
    07-19-2015 09:16 PM
  20. mary beth hale's Avatar
    I have tried all the settings on this blog and they are no longer working. I am pretty sure they worked before. Does anyone have an update for the codes for the Lumia 1020 ATT phone on Straight Talk? After Windows updates, my phone will no longer send and receive photos on Straight Talk.

    Oops. Just saw that it may take a day. Will update.
    are you on 8.1 or the W10 preview? this is what I have used for years. currently using on a 930 running build 10166 of W10P. Also, did you restart your phone after adding the data and mms apns?
    07-19-2015 09:50 PM
45 12

Similar Threads

  1. Pictures / Video taken with your Lumia 625
    By Muessig in forum Nokia Lumia 625
    Replies: 11
    Last Post: 07-24-2014, 01:55 AM
  2. Lumia 920 ee uk update???
    By sjb123mk2 in forum Nokia Lumia 920
    Replies: 16
    Last Post: 09-03-2013, 07:38 AM
  3. Question for all lumia 720 user
    By Abhishek Belkar in forum Nokia Lumia 720
    Replies: 8
    Last Post: 08-22-2013, 12:37 PM
  4. Replies: 5
    Last Post: 08-20-2013, 02:55 PM
  5. Lumia 999 design concept
    By holzlondon in forum Upcoming & Rumored Phones
    Replies: 5
    Last Post: 08-19-2013, 10:34 AM
LINK TO POST COPIED TO CLIPBOARD