1. techiedude007's Avatar
    Anyone else using a Nokia 1020 with charger shell and noticing odd charging/battery indicator behavior? I placed my 1020 with charger shell on my charging stand one night before bed and woke up the next morning with the exact same battery reading (maybe a little less even). So I re-positioned it on the charger stand and left it for a few more hours, same results. I then decided to plug the phone in to charge, came back a couple of hours later and the battery indicator still hadn't moved. I thought that this behavior was really strange so I rebooted the phone and lo-n-behold: a fully charged phone. For some reason the battery indicator was not updating properly.

    Anyone else notice this on their 1020?
    08-20-2013 05:34 AM
  2. Jan Van Belle's Avatar
    I have the same thing on my Lumia 920 since I updated to Amber yesterday. Battery was at 60%, charged whole night, and was still at 60%. After rebooting, it jumped to 100%.
    Now it seems to be stuck on 100%...
    techiedude007 likes this.
    08-20-2013 08:58 AM
  3. kumarrangarajan's Avatar
    Same issue here. i charged battery to 100% . when i removed the charger, the battery indicator got reset back to 70% , been happening for the past 3 days. used battery app and also saw battery saver in settings , same hapening.
    techiedude007 likes this.
    08-20-2013 09:16 AM
  4. techiedude007's Avatar
    Sounds like it isn't specific to Lumia 1020 or even wireless charging but possibly to the Amber update? Can anyone else confirm this is happening on their phone after Amber (or even pre-Amber)?
    08-20-2013 09:55 AM
  5. NXorableWandrer's Avatar
    Unless I overlooked something, nobody has said that he wasn't wireless charging.

    I never had a problem until just now, hours after I unboxed the wireless charging cover. In my case, I had a lot of trouble with wireless charging not working. When I could get it to begin charging at all, it would charge for several seconds, stop, and maybe start and stop again. User rubin89 recommended bending out the pins on the cover, which seemed to resolve the problem, but now I have this 100% battery level problem. I wonder if arcing occurred and damaged something.

    Edit: Now, the indicator is down to 98%. I've been using the phone for 50 minutes since my last charge according to Battery Performance.

    Edit: Two hours since the last charge, things seem normal.
    Last edited by NXorableWandrer; 08-23-2013 at 08:22 AM.
    08-23-2013 07:09 AM
  6. MorrisAO's Avatar
    Yep, I've had exactly this problem with my Lumia 820 since the Amber update. Seems to ok at he moment.

    For now, it seems to fix itself on a reboot of the phone.
    08-25-2013 11:59 PM
  7. stevenpj's Avatar
    I have been experiencing this issue on my yellow 1020 over the past week. When I unplug my phone from the charger in the morning after a full night of charging, it shows either 79% - 82% charge. It only then shows a full 100% charge when I reboot the phone.
    I do NOT have a charging plate and am using only a wall charger.

    Has anyone found a fix or cause yet?
    09-25-2013 12:13 PM
  8. machina's Avatar
    Any word from Nokia / MS regarding this issue?
    09-28-2013 12:07 PM
  9. ZuLuuuuuu's Avatar
    I have the same problem with my Lumia 820. I am not using wireless charging. It frequently gets stuck at some point and only rebooting the device solves the problem. But It occurs again after a while. This started happening after the Amber update.
    09-30-2013 10:03 AM
  10. Dalali's Avatar
    I have the same problem. Did anyone found a fix for it?
    10-07-2013 10:36 AM
  11. CelsoP's Avatar
    I have the same problem here, it looks like it is a software problem...
    12-07-2013 05:54 AM
  12. Vincent Krisna's Avatar
    I had the same problem, but a bit different.
    What's not updating is lockscreen battery indicator.
    If I slide up to unlock my phone, I can see the battery indicator is correct inside.
    And when I lock it again, the lockscreen battery indicator will update itself.
    Not so annoying but need to be fix.
    12-08-2013 10:00 PM

Similar Threads

  1. Replies: 21
    Last Post: 07-30-2014, 12:36 AM
  2. After Amber update, wifi is permanently disconnecting
    By BigTcz in forum Nokia Lumia 820
    Replies: 7
    Last Post: 08-25-2013, 07:53 AM
  3. Amber update trends - who gets it last
    By vidhunprakashmk in forum Windows Phone 8
    Replies: 4
    Last Post: 08-21-2013, 06:58 AM
  4. WP 8.5/9.0 update?
    By jms_209 in forum Nokia Lumia 521
    Replies: 6
    Last Post: 08-20-2013, 08:47 PM
  5. Amber Update available for Nokia lumia 820 in india....!!
    By Shishir Girjapurkar in forum Nokia Lumia 520
    Replies: 1
    Last Post: 08-19-2013, 11:57 PM
LINK TO POST COPIED TO CLIPBOARD