1. SteggyDad's Avatar
    So on my Lumia 1020 the live tiles for the weather never update for any of the weather apps I have tried. (Amazing Weather, Weather Flow, etc). The only background apps I have running is the one for the weather app I am currently trying to use. I have sent logs to Amazing Weather and Weather Flow and from what they see the background task is running and not getting any errors, but still no updating.

    As anyone else ever seen anything like this? Any suggestions?

    TIA
    09-09-2013 11:42 AM
  2. DBDev's Avatar
    It could be some problem with your push notifications, read this thread: http://forums.windowscentral.com/win...might-not.html
    09-09-2013 11:47 AM
  3. madbiologist's Avatar
    I've had this issue for months now on my 920. I've un/reinstalled several times but it appears that this may be one of a handful of bugs in the live tile functionality in wp8, and for me it is only the weather apps that get hit by this bug. Some threads seem to suggest this stems from an issue with the periodicTask or resourceIntensiveTask implementation and has been mentioned several times on this and other forums before. Microsoft does seem to be aware of it, but I was hoping GDR2 would fix this issue, and since it's popping up on a 1020 it looks like it is still an issue.

    You can try some of the following, but they haven't worked for me, but seem to have had previous success with others:
    1. Unpin, uninstall, clear other storage and internet history/temp files, reinstall and repin
    2. Standard shut down and reboot
    3. Soft reset (hold power + volume down)

    I haven't tried this yet, but its next on my list of tests:
    4. Try uninstalling all apps that are in your background tasks list. Reinstall the one you are having trouble with and see if it updates after a power down cycle. Then add the rest back in one by one to see which is killing your apps tile.

    I have not tried this, since you'll have to setup your phone from scratch again (contacts, apps, start screen, etc)
    5. Hard reset - settings > factory reset

    Take a look at these links, they may be helpful for you or at least detail the issue
    http://social.msdn.microsoft.com/For...net-connection
    http://forums.windowscentral.com/win...le-issues.html

    I'll post back if I can get my tiles working again, but maybe GDR3 will fix this...
    tgr42 likes this.
    09-09-2013 12:24 PM
  4. madbiologist's Avatar
    Also, before doing a #4, you should possibly try turning off background tasks for each app from within the app directly. Apparently that has worked for some folks too.
    09-09-2013 12:32 PM
  5. Jazmac's Avatar
    You are looking at a factory reset. Live tiles are unpredictable and unstable. Too many conditions cause it to fail. If a reset doesn't resolve it, a hard reset almost always does.
    09-09-2013 12:32 PM
  6. SteggyDad's Avatar
    Th eonly thing I haven't tried yet is a hard reset, really trying to avoid doing that if I can.
    09-09-2013 12:46 PM
  7. tgr42's Avatar
    I wouldn't bother with the hard reset. You might brick your phone, and it's hardly a long-term solution to the problem. Whatever circumstances led it to end up busted on your phone are likely to recur in time, unless you get lucky and/or substantially change your usage patterns. Don't count on Microsoft ever fixing it either. Their actions show that they are just not interested.
    09-09-2013 01:47 PM
  8. madbiologist's Avatar
    So, to report back. I ended up going through all the background tasks and manually adjusting the settings in the apps, turning off any live tile/background setting in apps I don't have pinned. I uninstalled a number of them that I haven't used in a while (e.g. Evernote, instance (now use 6tag), etc), dropped below the limit for background tasks and repinned amazing weather (which shows a timestamp on the tile).

    After a helping of humble pie, that seems to have fixed the issue. I don't know which app it is, or whether it was installing one that I couldn't turn off background tasks manually had pushed me over, but it does appear to work again. Try being aggressive with your background tasks, and see if it doesn't work. I did power down once as well. I wish it was a bit more straightforward than this, but hopefully that will fix your issue too. And like the other poster said, I would avoid the factory reset unless nothing else works.
    09-09-2013 05:58 PM

Similar Threads

  1. Gapless playback music app?
    By CaptainChunk41 in forum Applications
    Replies: 9
    Last Post: 10-18-2013, 08:16 PM
  2. Xbox Music. Why iPhone and Android?
    By RyanAck15 in forum Groove Music
    Replies: 15
    Last Post: 09-23-2013, 06:42 AM
  3. Replies: 5
    Last Post: 09-10-2013, 06:41 PM
  4. Nokia Pro Cam Stuck and Screen Orientation Locked
    By amrut_m in forum Nokia Lumia 920
    Replies: 1
    Last Post: 09-10-2013, 12:12 AM
  5. NYTimes App
    By lewiedude in forum Applications
    Replies: 3
    Last Post: 09-09-2013, 04:25 PM
LINK TO POST COPIED TO CLIPBOARD