04-18-2015 07:48 AM
78 1234
tools
  1. tweedie's Avatar
    So if you used this trick to flash your 1020 to a different carrier's firmware (while staying in the product code), could us AT&T 1020 users flash a Rogers firmware on there using this method? The product codes are the same. I am going to give this a shot after work today.
    I am led to believe that as long as you are in the same product family it should be ok to flash. but someone above [kable_mk] said that AT&T are unflashable. I am not sure what product code rogers nor AT&T is - and I think that might be the problem?

    I guess the best thing to do first, is work out what type+product code is for both AT&T and Roger 1020 phones. The only way I know is by installing the suite (you gonna have to do that anyway), connect your phone, then it should come up with the type and product code (and share it here I guess). Then hopefully a 1020 Rogers user can also tell you what their product code is.

    Then once you know what product code 1020 Rogers is, then you might be able to download it providing that its available to download from nokia servers.

    BTW, does both AT&T and Rogers use the same bands? Are they both compatible?
    10-24-2013 10:50 AM
  2. kabel_mk's Avatar
    I am led to believe that as long as you are in the same product family it should be ok to flash. but someone above [kable_mk] said that AT&T are unflashable. I am not sure what product code rogers nor AT&T is - and I think that might be the problem?

    I guess the best thing to do first, is work out what type+product code is for both AT&T and Roger 1020 phones. The only way I know is by installing the suite (you gonna have to do that anyway), connect your phone, then it should come up with the type and product code (and share it here I guess). Then hopefully a 1020 Rogers user can also tell you what their product code is.

    Then once you know what product code 1020 Rogers is, then you might be able to download it providing that its available to download from nokia servers.

    BTW, does both AT&T and Rogers use the same bands? Are they both compatible?
    I believe that ATT version lacks UMTS 1700 (1700_2100), so Rogers version is truly penta-band UMTS model. I'm not an expert, but my opinion is that the firmwares on ATT's and Rogers should be compatible, that is why i've tried to flash it.
    10-24-2013 11:19 AM
  3. 6029KingStephen's Avatar
    Many thanks, that worked for me and my Lumia is now unbranded - much appreciated!
    10-24-2013 11:41 AM
  4. jaytee0401's Avatar
    Many thanks, that worked for me and my Lumia is now unbranded - much appreciated!
    Could you provide more details please? You have an ATT 1020 flashed with Roger's firmware? Also, what features do you have now vs ATT firmware? Data Sense? Wifi Calling?
    10-24-2013 02:30 PM
  5. kabel_mk's Avatar
    Could you provide more details please? You have an ATT 1020 flashed with Roger's firmware? Also, what features do you have now vs ATT firmware? Data Sense? Wifi Calling?
    Judging from the screenshots that he's posted (the sections where it says USB1:RM-875; this is where NCS recognized the phone as RM-875 based on drivers-NCS connection), i do not think that he has ATT L1020. ATT L1020 is RM-877 (Rogers too). From the product code 059T4N3, i believe he is trying to flash (well, he said he did successfully) country variant of GB (Great Britain). His phone might be from GB too.
    10-24-2013 02:52 PM
  6. 6029KingStephen's Avatar
    Yes, sorry, the AT&T thing was not me, I was unbranding a Three-UK phone, partly as I use it on a different carrier and partly so I'm not tied to any carrier for updates.

    But I can confirm that the process that Buxz777 posted does work fine for flashing a new firmware to the phone.
    10-24-2013 04:39 PM
  7. iliramove's Avatar
    I just followed the thread and got my Lumia 1020 on GDR 3 preview, debranded to a GB CV ROM, back to GDR2. From there, I downloaded Preview for Dev and installed back to GDR3. It works!

    Sent from my mobile Tapatalk
    10-25-2013 06:57 AM
  8. StreekG's Avatar
    Done! Now unbranded Lumia 1020 yay :) Now i have to go back to GDR3
    10-25-2013 07:59 AM
  9. buxz777's Avatar
    hello peeps , just wanted to say glad its helped a few people and again i will type up the 1st post a bit neater when i get a chance been so busy with work its unreal , not even a chance to get out and take photos with my 1020 :-/ sucks :-/

    anyways glad it helped and enjoy :-)

    ps
    dont forget the thanks button if you found this little guide helpfull ;-)
    6029KingStephen likes this.
    10-25-2013 09:52 AM
  10. montsa007's Avatar
    Is it possible to de-brand an AT&T L1020? (Black Color)
    Yes, I need help LOL.
    10-25-2013 09:55 AM
  11. buxz777's Avatar
    Is it possible to de-brand an AT&T L1020? (Black Color)
    Yes, I need help LOL.
    hi mate from what people have posted i dont think it is so far :-/ :-/ i am from the uk so cant help with this to much but other users have posted it is not possible :-/ sorry mate
    montsa007 likes this.
    10-25-2013 12:51 PM
  12. montsa007's Avatar
    hi mate from what people have posted i dont think it is so far :-/ :-/ i am from the uk so cant help with this to much but other users have posted it is not possible :-/ sorry mate
    Ok mate, lol.
    10-25-2013 11:11 PM
  13. edwardob's Avatar
    i'm afraid i keep getting this during flash
    "Could not load file or assembly 'Nokia.Murzim.Uefi.FlashApp.Core.dll' or one of its dependencies. The specified module could not be found."
    10-26-2013 12:16 PM
  14. Ali akbar Dehghani's Avatar
    Hi,All
    please see this screenshut,What is wrong?
    Who can send me link dl?with Email or share a link ?
    my 1020 is ((059S9T1 RM-877 VAR NAM US ATT SL BLACK)) ((Software Version 3045.0000.1325.0001)) .
    i want update to : ((059T3M3 RM-877 LIGHT SWAP ENGINE GLOBAL))
    changing product code.059S9T1 TO 059T3M3.
    I do want to take the risk anyway.
    What do you think? Is it possible?
    if you could send it(firmware product code:059T3M3) to me, I'll do it., And I announced the result.
    Thanks to all.


    lumia-1020.png
    10-27-2013 08:13 AM
  15. montsa007's Avatar
    Are you connected using a USB 3 or USB Hub? DOn't do that, thats all I know.
    10-27-2013 08:20 AM
  16. Ali akbar Dehghani's Avatar
    Are you connected using a USB 3 or USB Hub? DOn't do that, thats all I know.
    Neither. With USB 2. it important?
    If the phone is not connected to a computer, download to be done.
    I've connected to the PC. Using PC USB which is the back case.
    whay don't do that ? are you tested ?
    montsa007 likes this.
    10-27-2013 11:21 AM
  17. montsa007's Avatar
    Neither. With USB 2. it important?
    If the phone is not connected to a computer, download to be done.
    I've connected to the PC. Using PC USB which is the back case.
    whay don't do that ? are you tested ?
    USB 2 and direct connection, that is what you should do, this is all I know because I don't have my 1020 (yet) and I read the flasing thread somewhere yesterday, but that soul was flashing a UK variant and not AT&T variant.

    LOL @ "Are you tested", made me laugh.
    Am sorry about that, I don't wish to be tested, I've never done any nasty things in life :p
    Ali akbar Dehghani likes this.
    10-27-2013 11:23 AM
  18. Ali akbar Dehghani's Avatar

    LOL @ "Are you tested", made me laugh.
    Am sorry about that, I don't wish to be tested, I've never done any nasty things in life :p
    I apologize.Take it easy.I mean, it was tried.
    Me Too lol :D
    10-27-2013 11:48 AM
  19. montsa007's Avatar
    I apologize.Take it easy.I mean, it was tried.
    Me Too lol :D
    Its okay mate, its good to have a little laugh after a tired boring day :).
    Ali akbar Dehghani likes this.
    10-27-2013 11:52 AM
  20. edwardob's Avatar
    still getting Nokia.Murzim.Uefi.FlashApp.Core.dll problem
    any suggestions pleaseeeeeeeeeeeeeeeeeeeeeeeeeeee
    10-27-2013 12:22 PM
  21. buxz777's Avatar
    still getting Nokia.Murzim.Uefi.FlashApp.Core.dll problem
    any suggestions pleaseeeeeeeeeeeeeeeeeeeeeeeeeeee
    sounds like the care suite is having problems mate , did you move the file to the c drive as stated in the instructions? are you using a windows pc? maybe google the error report and see what comes up
    10-28-2013 02:21 AM
  22. montsa007's Avatar
    sounds like the care suite is having problems mate , did you move the file to the c drive as stated in the instructions? are you using a windows pc? maybe google the error report and see what comes up
    Congrats on your 100 posts ;)
    buxz777 likes this.
    10-28-2013 03:20 AM
  23. buxz777's Avatar
    Congrats on your 100 posts ;)
    thanks mate much appreciated ;-) was an avid user of Nokia Users you can see from my profile and the thanks i got that i put a bit of time in there helping users etc View Profile: buxz777 - Nokia Users but a lot of members went their own ways over the years and the forum has got quite quiet now , i joined this one a little while ago when i got a 920 on uk launch and enjoyed the forum , i think part of owning a good smartphone is a nice community behind it and this forum defo has a nice community so it is a pleasure to be able to put a bit back into it wether it be little guides like this or photos from my phone or just a reply in a discussion ;-)
    montsa007 likes this.
    10-28-2013 04:48 AM
  24. montsa007's Avatar
    thanks mate much appreciated ;-) was an avid user of Nokia Users you can see from my profile and the thanks i got that i put a bit of time in there helping users etc View Profile: buxz777 - Nokia Users but a lot of members went their own ways over the years and the forum has got quite quiet now , i joined this one a little while ago when i got a 920 on uk launch and enjoyed the forum , i think part of owning a good smartphone is a nice community behind it and this forum defo has a nice community so it is a pleasure to be able to put a bit back into it wether it be little guides like this or photos from my phone or just a reply in a discussion ;-)
    1 thing I do know, wpc (this forum) is going places and not being quiet, with every rival device launch, we get louder.
    I wish you all the best for your 1,000th and 10,000th post achievement :)
    buxz777 likes this.
    10-28-2013 04:53 AM
  25. Harshal Gunde's Avatar
    I have been trying to get this to work with all the steps, but when I am trying to flash the Rogers ROM on an ATT device it always gives me an error: Platform ID is different from the Device Platform ID. Can anyone tell me how to overcome this error. Need this desparately as I am in Canada and want to get AWS spectrum to work.
    10-28-2013 10:13 AM
78 1234

Similar Threads

  1. Nokia DT 601 Wireless Charger - When?!
    By Pat010 in forum Cases & Accessories
    Replies: 7
    Last Post: 11-07-2013, 06:06 PM
  2. Going back to the 1020....questions!
    By husslord in forum Nokia Lumia 1020
    Replies: 2
    Last Post: 10-24-2013, 09:33 AM
  3. nokia care suite for lumia 1020
    By mzoslater in forum Nokia Lumia 1020
    Replies: 4
    Last Post: 10-23-2013, 05:39 PM
  4. Will Lumia 1020 get Asphalt8: Airborne and FIFA14?
    By Japie Fourie in forum Nokia Lumia 1020
    Replies: 2
    Last Post: 10-23-2013, 12:28 PM
LINK TO POST COPIED TO CLIPBOARD