05-07-2014 05:38 AM
34 12
tools
  1. the_dread's Avatar
    Hi All - Happy New Year when it comes.
    Like many of you, I live outside the USA. I have a new Nokia Lumia 1020 RM-875. It was advertised on Amazon.com as "ATT Unlocked" but when I got it I found that it is an RM-875 not an RM-877 and the original FW is for a carrier in Australia. I hoped that would be OK since the RM-875 is the "international version". However, I have a problem - my 1020 RM-875 won't pick up HSPA/HSPA+ from my local carrier. My local carrier uses the same frequencies as AT&T, and provide all mobile data services except LTE. My local carrier provides HSPA+ (HSDPA+) but my 1020 will only connect with EDGE (GPRS 2G) - it shows E beside the signal strength indicator.

    Corrupted Firmware?
    The carrier suggested that there could be a problem in the firmware - perhaps caused by the unlocking process used by the vendor. I was unable to access the Nokia Care Suite (NCS) v4 from posts by Buxz777 so used NaviFirm+ to download the FW files. The Buxz777 posts were then very useful. I was able to use NCS v5 to flash my phone in recovery mode. THANKS Buxz777!!!

    Checked SIM:
    My carrier has confirmed that my SIM is configured for 3G/4G services. If I put my SIM in another phone and that phone is able to access 3G - so that confirms that my SIM is OK.

    Tried Different FWs:
    I have used NCS 5 to flash my 1020 with the newest CV FW for Australia/New Zealand (059T4B1) and with the newest CV FW for UK (059T1V6). Both show the Nokia Amber version of the FW. But, no change - still only EDGE connection!!

    Confirmed with Carrier that all phone settings correct:
    My carrier reconfigured my account then check all the settings in my phone - Mobile Network & Access Point, but still only EDGE connection.

    Please Help!!
    Has anyone else had a similar problem?
    Has anyone found a solution?
    How may I test my 1020 to see if the Radio is faulty?

    Otherwise, I really love my 1020 (it is a real step up from my HTC HD7 in every way!!!) and don't want to have to return it to Amazon.

    Thanks for your help.
    12-27-2013 10:45 AM
  2. Flaurehn's Avatar
    I had the same problem, what you need to do is dial ##3282# to access the field test app, and there you should change the network type in settings to force 3G (with this you will have HSPA+, LTE is unavailable because of the hardware on the RM-875).

    Now, it seemed my network operator (Telcel Mexico) didn't allow access to the field test app, so if that is your case you should follow these steps after Getting Update 3 on your developer phone and then with Windows Phone Power Tools install the Native Toast Launcher in your phone. Once you have donde that, launch the Native Toast Launcher and type this in the target uri box: app://2377fe1b-c10f-47da-92f3-fc517345a3c0/_default#/Launcher;component/MainPage.xaml?DialString=3282
    Nirajan Sharma1 likes this.
    12-27-2013 12:30 PM
  3. Victor Tribal's Avatar
    I had the same problem, what you need to do is dial ##3282# to access the field test app, and there you should change the network type in settings to force 3G (with this you will have HSPA+, LTE is unavailable because of the hardware on the RM-875).

    Now, it seemed my network operator (Telcel Mexico) didn't allow access to the field test app, so if that is your case you should follow these steps after Getting Update 3 on your developer phone and then with Windows Phone Power Tools install the Native Toast Launcher in your phone. Once you have donde that, launch the Native Toast Launcher and type this in the target uri box: app://2377fe1b-c10f-47da-92f3-fc517345a3c0/_default#/Launcher;component/MainPage.xaml?DialString=3282
    I also have RM875 international version that reads Australia/New Zealand when checked in system.This is what mine does:it will get H,H+ in certain areas with a H,H+ tower,if not it goes on EDGE showing E
    12-28-2013 09:58 AM
  4. the_dread's Avatar
    Hi Flaurehn - Thanks so much for your response and suggested solution. You have given me hope. However, I am not a developer so I have to read your instructions and the related links very carefully before I try to execute them.

    Will my phone work in the normal way after I do the "developer unlock" and install WIndows Phone Power Tools, etc?

    Step 1: I can't access the field test app as you have indicated. I guess my local carrier does not allow it either. However, I have a meeting with a Nokia Tech Rep. on Monday a.m. I am hoping that he will be able to use the field test app to change the network type as you suggest.
    12-29-2013 10:52 PM
  5. the_dread's Avatar
    Thanks Victor Tribal - Unfortunately, my phone never goes to H or H+, even though everyone I know on the same carrier that I use is able to get 3G/4G on their phones (iphone, Samsung G2/3, Blackberry, etc.). It also only identifies my carrier as "2G" in the Settings/Mobile Network options.
    Last edited by the_dread; 12-29-2013 at 11:13 PM.
    12-29-2013 10:59 PM
  6. the_dread's Avatar
    Any other solutions or comments on Flaurehn's suggestions? Thanks in advance.
    12-29-2013 11:15 PM
  7. Flaurehn's Avatar
    Don't worry, if you follow correctly the instructions you will have 0 problems with your phone, I think most of us here have done those steps in order to have GDR3 in our phones :D

    And to your question in the other thread, I tried flashing an AT&T rom but no luck, which is weird because other roms have no problem :/
    12-29-2013 11:20 PM
  8. the_dread's Avatar
    Thanks for your continued help. Speaking with my carrier now. They are suggesting the the they can try to update the "config file". However, I would nee to give them my phone for at least 1 day. Is that basically the same as the procedure you have suggested, or is this some different approach?

    Using your procedure, do I need to install the beta updates (part of the procedure in 1 of your links), or can I just stay with my current FW version and still complete your procedure? I really just want to connect to 3G.
    12-30-2013 10:23 AM
  9. the_dread's Avatar
    My carrier is trying to persuade me that the best option is for me to return my 1020 and buy one from them when they make it available in a few weeks.

    Will now try Flaurehn's "developer unlock" procedure. Wish me luck. May I skip the "upgrade software" step. I'm willing to stay on Nokia Amber until the general release of Black. Just want to be able to connect to 3G.
    12-30-2013 11:23 AM
  10. the_dread's Avatar
    My desktop runs Windows 7. The Win Phone SDK in your link requires a Win 8 computer. Is there a Wn 7 version of the Win Phone SDK that I can use?
    12-30-2013 12:47 PM
  11. the_dread's Avatar
    Found a close friend who will allow me to use his Win8.1 tablet. Trying your solution now. :-)
    12-30-2013 02:46 PM
  12. Flaurehn's Avatar
    Cool, and btw, yes you need only get to the part where your phone is developer unlocked to use the Power Tools. Good luck!
    12-30-2013 05:34 PM
  13. the_dread's Avatar
    HELP Please!!! I completed the process you suggested (without downloading any firmware updates) - set the phone to "3G only". Now the phone has no network connection. The phone is not recognising any mobile network. No voice/no data. I set it back to "automatic" but same result - no recognized.

    Please help. Thanks.
    12-30-2013 06:04 PM
  14. Flaurehn's Avatar
    Can you change the channel? Also, mine has the Toggle ENS set on
    12-30-2013 06:27 PM
  15. the_dread's Avatar
    Which channel? How do I change the channel?

    I will check all the toggles - I believe that they were all on. They were all off when I had the problem. Meanwhile, I have run "Software update" hoping that would help. The update just finished - still no network found.
    12-30-2013 06:34 PM
  16. Flaurehn's Avatar
    Mine is set like this, try putting the UMTS band to channel two, wait like 30 seconds and then go to automatic

    Last edited by Flaurehn; 12-30-2013 at 08:22 PM.
    Nirajan Sharma1 likes this.
    12-30-2013 06:43 PM
  17. the_dread's Avatar
    Hi Flaurehn - Success!!!! I toggled ENS on, as you indicated, and VIOLA!!! I now see an intermittent "H" beside the signal strength bar graph. I understand that the signal from my carrier is weak in this area. I expect that the 3G signal will be more consistent as I move around.

    Thanks so much for your help!!!!
    12-30-2013 07:09 PM
  18. Flaurehn's Avatar
    Glad you made it! A note though, the first times it reseted itself to 2G again, I did the same metod twice again, and then it began working perfectly
    12-30-2013 07:22 PM
  19. the_dread's Avatar
    I'll certainly look out for that. How long did it take to revert to 2G? However, going well so far. My phone shows "H" at my home - using it to write this post.

    Thanks again for taking the time to respond and provide all the guidance I needed!!
    12-30-2013 08:27 PM
  20. Nirajan Sharma1's Avatar
    Wow, got field test on my L520. A big thanks to you. I will refer to this info on my fb.
    01-12-2014 11:27 PM
  21. Fabio Bustamante Salama's Avatar
    hi..i have exactly the same nokia...and i have read your post...i have a little diferent problem....my phone is working on GSM mode and works fine with thise carrier but.. when i want to change of carrier that works with WCDMA band (becouse is the best and the other its a crap)...my nokia 1020 holds the signal for 10 minutes and then drops to "emergency only" and then goes up again...and repets the cycle...i have been told that if i can change the band it may solve the problem... can you help me please!!! :(
    01-22-2014 10:05 PM
  22. Hector Cantu's Avatar
    hola, me puedes ayudar a realizar este proceso. Quiero forzar 3G en mi celular ya que solo puedo usar 2G
    01-23-2014 09:06 AM
  23. the_dread's Avatar
    Hopefully Flaurehn can help you - he's the expert. :-)
    01-25-2014 01:32 AM
  24. the_dread's Avatar
    Hi Flaurehn - Just a quick update to let you know that my 1020 has been working perfectly. Thanks again for your help.
    01-25-2014 01:35 AM
  25. Rasahi's Avatar
    Will this works with lumia 1520? I am facing the same problem and till now can't get to field test.
    01-26-2014 02:48 AM
34 12

Similar Threads

  1. Processor speed & gaming.
    By KrisJoeEll in forum Games
    Replies: 15
    Last Post: 01-11-2014, 01:49 PM
  2. New Windows Phone's at CES?
    By AlexanderJJJ in forum Upcoming & Rumored Phones
    Replies: 25
    Last Post: 01-09-2014, 01:55 AM
  3. pls help to download my app "KidsPartyPlanner" :smile:
    By birdygirly in forum App Spotlight
    Replies: 2
    Last Post: 01-02-2014, 02:13 AM
  4. WiFi Issue : Just at home
    By MikesChevelle in forum Nokia Lumia 920
    Replies: 3
    Last Post: 12-27-2013, 11:29 AM
  5. Tried almost everything, still cant connect my Phone to PC
    By Hisham Mubarak1 in forum Nokia Lumia 520
    Replies: 1
    Last Post: 12-27-2013, 06:04 AM
LINK TO POST COPIED TO CLIPBOARD