1. Gikero's Avatar
    Till this started happening a few weeks ago. I've tried searching for answers and haven't yielded any meaningful results. When my 1020 is connected to my Nokia Battery/Camera Grip, the 1020 cannot charge. When I connect just the Battery/Camera Grip, it cannot charge. If I press the battery level button, I get 6 LED flashes. Does anyone have any ideas or know a good place to look?
    02-04-2014 10:45 AM
  2. troylytle's Avatar
    Had to search to find this again. Lol. Try holding the button until it does a second set of flashes. Like 30 full seconds. Then plug it in and leave it for 30.
    Gikero likes this.
    02-04-2014 11:43 AM
  3. Gikero's Avatar
    Thanks, I will try tonight.
    02-21-2014 03:40 PM
  4. ngc891's Avatar
    Any luck? Same issue here too...
    02-21-2014 04:45 PM
  5. GPendolino's Avatar
    I actually had the yellow grip and it stopped charging so I just replaced it with a black one. I think these grips are far more delicate than the phone itself.
    Cache likes this.
    02-21-2014 06:47 PM
  6. Cache's Avatar
    I've had 4 imaging grips fail. Time to go back to the microsoft store yet again.
    02-27-2014 09:38 AM

Similar Threads

  1. Surface RT message "wireless network security key is not correct" but it is
    By jonohana in forum Microsoft Surface for Windows RT
    Replies: 2
    Last Post: 02-04-2014, 08:34 PM
  2. Gmail not syncing
    By absst16 in forum Nokia Lumia 822
    Replies: 1
    Last Post: 02-04-2014, 02:21 PM
  3. here maps not working
    By zeeshan alvi1 in forum Nokia Lumia 625
    Replies: 1
    Last Post: 02-04-2014, 08:43 AM
LINK TO POST COPIED TO CLIPBOARD