1. MikesChevelle's Avatar
    I loaded all my accounts and all my contacts are there but when someone calls the caller id doesnt match to my contacts and just shows the number, if I go to save that call to a contact, the number is already there........

    Any one have that issue, the numbers are all saved in the correct format and all
    02-17-2014 06:56 PM
  2. MikesChevelle's Avatar
    one thing I notice is that all my contacts are saved w/o the (1) country code and when the phone rings, it has the (1) country code, Im in the US still shouldnt my phone be able to match that up
    02-17-2014 07:02 PM
  3. roastbeefalo's Avatar
    I am also having this problem. I have the number plugged into the contact, but only the number comes up when someone calls, not the name. I did save one number that called to my contact as mobile 2 (same as mobile 1) and now that person works. However, I don't want to have to do this for every contact for obvious reasons. I can't pinpoint when it happened. Anyone else?
    02-26-2014 12:03 PM
  4. MikesChevelle's Avatar
    I deleted the accounts (live&gmail) and restarted the phone are put the accounts back on and it fixed it for me
    laurel1957 likes this.
    02-26-2014 01:38 PM
  5. laurel1957's Avatar
    Wow MikesChevelle. Anyone have a more reasonable fix? It does seem this happened with an update after the first of the year. TIA
    03-04-2014 07:06 PM

Similar Threads

  1. Xbox One games are about to get cheaper, Ryse going on sale tomorrow
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 02-21-2014, 06:38 PM
  2. Its not time switch. But rather; Its time to come home!
    By k0de in forum Microsoft News & Rumors
    Replies: 20
    Last Post: 02-19-2014, 08:29 PM
  3. Best way to back up messages after hard reset
    By Roni996 in forum Microsoft News & Rumors
    Replies: 1
    Last Post: 02-18-2014, 06:00 AM
  4. Nexus 5 & Nexus 7 Trade for Lumia 1020 or 1520
    By pirarre in forum Marketplace Archive
    Replies: 5
    Last Post: 02-17-2014, 07:03 PM
  5. Has to be the worst OS I've ever used...
    By Miffywiffy in forum Windows Phone 8
    Replies: 2
    Last Post: 02-17-2014, 06:31 PM
LINK TO POST COPIED TO CLIPBOARD