1. DeZombre's Avatar
    Hi All!

    I recently came over to the Windows Phone from iOS. Was super excited, as my old iPhone4 had a busted home button for the last year and was looking forward to the awesome camera that the Lumia 1020 boasted.

    My carrier has been AIO Wireless, and I was happy with them on the iPhone 4. Online tech support is rough, but price is right and never had any service issues. I heard that AT&T locked devices work fine on AIO, so I went and got a 1020 from the local AT&T store. I was prepared to buy one outright for about $600, but found out they had a lightly-used display model available for $199. Looked pristine, warranty still good, great price so I went with the display model.

    So far I love almost everything about the Lumia 1020. I love the way the WP8 OS works. I love love love the camera. My one main issue, however, is the text messaging.

    I am not getting my texts. I send them and they are delivered fine. But I dont receive them correctly. They sit and then I get them all at once after 3 or 4 days. Occasionally it seems like maybe one makes it through as it should, but it is not the norm.

    I called AIO and they confirmed my settings, and had me wait offline while they fixed stuff on their end. They called back, and confirmed things were working by sending me a text. Looked good at first from their test text, but I still dont get texts from people.

    My observations regarding the problem:

    Sending texts works fine. Only problem is with receiving

    My texts from friends and such are getting held up, BUT, I always seem to be able to get texts from AIO. When I change my service plan or payments online I get a confirmation text immediately. Theirs always work.

    I get texts fine on my iPhone. If I take the SIM out of the Lumia and pop it into the old iPhone texting works fine. As soon as the phone fires up all texts that are stuck download and are viewable.

    So Im wondering if perhaps there is some setting in my phone I might need to adjust and just havent found it yet? Ive been looking and tweaking without luck. OR, might there be something with the SIM card? I was assuming that the card I got from AIO for my iPhone could just be popped into the Lumia and everything would workis this not the case?

    Any ideas, suggestions, or insights would be appreciated!
    03-21-2014 09:45 AM
  2. Alienhead95's Avatar
    This issue is caused by imessage. I was never able to solve that by logging back into the apple account disabling imessage, so I asked my friends to change their setting to " send as text if imessage fails".
    03-21-2014 09:57 AM
  3. DeZombre's Avatar
    This issue is caused by imessage. I was never able to solve that by logging back into the apple account disabling imessage, so I asked my friends to change their setting to " send as text if imessage fails".
    Thanks for the response!

    My problem seems to be with texts from Android phones as well. So this may be part of the problem, but I would think it has to be something additional as well. Thank you for the heads-up regarding this, I will go and shut this off in my account too.
    03-21-2014 10:07 AM
  4. Alienhead95's Avatar
    Androids too? Did you check your APN settings? is it a group conversation or just text, cause group conversation is received as MMS.
    03-21-2014 12:37 PM
  5. DeZombre's Avatar
    Yeah, Androids and iPhone texts both go missing. They are just individual texts. I don't know any other WP users so haven't checked that. I generated some text messages at various online 'generate a test text' sites and those all get stuck too. AIO's texts come through fine. All the texts that build up all download as soon as I slip the SIM into the iPhone.

    I think I'll have some buds try to send some MMS messages and see how those fare.
    03-21-2014 01:34 PM
  6. Alienhead95's Avatar
    That is really weird. I am using my 1520 on ST (previously used 1020, 920,520) never had any issues receiving text.
    03-21-2014 02:36 PM
  7. Matt Bee's Avatar
    DeZombre> I had the same problem coming from iOS to Windows Phone. I ending up calling Apple Care, and explained to them my problem. I was told by Apple Care they would remove my cell phone number for the iMessage server, and after 24-hours everything was working normally. Actually I started receiving messages from iPhone users much sooner than the 24-hours I was told wait!

    Good Luck !
    03-22-2014 07:06 AM
  8. Tony_Offends_U's Avatar
    What's the verdict on this situation? Same thing started happening to me but I've never had an iPhone. My texts come through immediately on the AIO branded Lumia 620 but 2-3 days late on a BYOD Lumia 920. I think they messed something up on the BYOD end of things.
    03-25-2014 08:15 AM
  9. vw1610's Avatar
    I'm having the exact same issue and have suspected imessage for a while. I effing hate imessage.


    Sent from my iPhone using WPCentral Forums
    03-28-2014 10:32 PM
  10. vw1610's Avatar
    I'm still having issues missing random texts. Some make it through and some don't. Maybe I need to unlock this 1520.
    Attached Thumbnails accesspointsettings.jpg   cellularsettings.jpg  
    Last edited by vw1610; 04-02-2014 at 05:59 PM.
    03-31-2014 08:44 PM

Similar Threads

  1. Nokia Lumia 2520 now available for pre-order at Carphone Warehouse
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-21-2014, 09:27 AM
  2. Internet sharing program on my nokia Lumia 620
    By ajaya p in forum Nokia Lumia 620
    Replies: 2
    Last Post: 03-21-2014, 07:20 AM
  3. Replies: 0
    Last Post: 03-21-2014, 02:53 AM
LINK TO POST COPIED TO CLIPBOARD