1. ssjmec's Avatar
    Anyone of you experiencing slow internet connection through wifi, on your 1020 only? I have an LTE set up on a ZTE mobile hotspot. While my laptop, and my brothers Nexus 4 and Nexus 5 (basically any gadget we have) easily gets 15-20Mbps download with 15 ping. My 1020 only gets 1-3Mbps and atleast triple the ping (50+).

    I am not sure whether I already have this issue before, but I only noticed it now because I used to put my LTE sim on my 1020. When using the LTE on phone, I can easily reach the normal speeds.

    I also have DP WP8.1 installed if it matters..

    Thanks in advance!

    edit
    PS: Using speedtest by ookla on all devices tested, using same servers
    PSS: Already tried soft and hard reset. Still the same :/
    05-16-2014 03:11 AM
  2. coolibop's Avatar
    Yes I have the exact same issue... My 1020 on DP8.1 only gets about 2-4Mbps using windows network speed test app. On my laptop I get well over 20. Not sure what the issue is...
    07-20-2014 03:16 PM

Similar Threads

  1. Lumia 521 not turning on
    By aceoferasing in forum Nokia Lumia 521
    Replies: 4
    Last Post: 01-03-2017, 09:10 AM
  2. Change FB profile pic in Windows phone 8.1
    By Donel_282 in forum Windows Phone 8.1 Preview for Developers
    Replies: 7
    Last Post: 10-26-2016, 03:25 PM
  3. Texts not restored after a hard reset on a dev preview!!
    By EpicIncognitO in forum Windows Phone 8.1 Preview for Developers
    Replies: 30
    Last Post: 08-01-2014, 02:34 AM
  4. Pictures distortion/warped on top. People look like aliens.
    By mrhappi79 in forum Nokia Lumia Icon
    Replies: 7
    Last Post: 05-17-2014, 02:49 AM
  5. Replies: 1
    Last Post: 05-16-2014, 11:46 AM
LINK TO POST COPIED TO CLIPBOARD