1. jansuklje's Avatar
    Hi,

    So I have the following problem. I am using Lumia 1020 for the past 6 months (give or take) and unfortunately my job ended today, so I had to return the SIM card I got from them, but was able to keep the phone.

    I already have a new postpaid SIM, but this time from a different carrier. The SIM is not yet active (it usually take around 1-2 days). I put the card in the phone and start it up. A demo mode is enabled and it seems I can't get rid of it, there is also no "Reset phone" under "About" in Settings.

    I have never experienced something like this, what exactly happened? Do I need to reflash my phone?

    Any advice is greatly appreciated.
    06-26-2014 12:41 PM
  2. Himanshu Chowdhary's Avatar
    Hey lets begin with a soft reset by holding volume down + lock button at the same time until your phone vibrates and reboot itself(ignore the black screen to power off the phone ).
    palandri likes this.
    06-26-2014 12:48 PM
  3. stickyshocker's Avatar
    Hi,

    So I have the following problem. I am using Lumia 1020 for the past 6 months (give or take) and unfortunately my job ended today, so I had to return the SIM card I got from them, but was able to keep the phone.

    I already have a new postpaid SIM, but this time from a different carrier. The SIM is not yet active (it usually take around 1-2 days). I put the card in the phone and start it up. A demo mode is enabled and it seems I can't get rid of it, there is also no "Reset phone" under "About" in Settings.

    I have never experienced something like this, what exactly happened? Do I need to reflash my phone?

    Any advice is greatly appreciated.
    As far as I know demo phones have a different os system on them, a bloke in an orange shop told me once. (they had loads of display phones being stolen but said it wasn't much of a problem as they wont be able to use them anyways. if it was a demo phone not sure as to why it would now start showing that, not even sure a reflash would be any good as the imei number surely would be no good?
    06-26-2014 12:53 PM
  4. jansuklje's Avatar
    I can only guess that this was related to inactive SIM card. My carrier provisioned my SIM today and the soft reset helped. The phone is fully operational :)

    Thanks for the help.

    Regards
    Himanshu Chowdhary likes this.
    06-27-2014 05:37 AM
  5. Himanshu Chowdhary's Avatar
    I can only guess that this was related to inactive SIM card. My carrier provisioned my SIM today and the soft reset helped. The phone is fully operational :)

    Thanks for the help.

    Regards
    Thanks for keeping us updated , Hope you are enjoying your windows phone Lumia 1020
    06-27-2014 06:37 AM

Similar Threads

  1. Audio popping with headphones when switching audio-enabled apps
    By wynand32 in forum Microsoft Surface Pro 3
    Replies: 9
    Last Post: 07-06-2014, 10:36 AM
  2. How to enable only MMS (without paying for mobile data connection)
    By nyolc8 in forum Windows Phone 8 How-to Guides
    Replies: 4
    Last Post: 06-25-2014, 08:16 PM
  3. Enable Living Images with latest Nokia Camera
    By diego9016 in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 06-25-2014, 12:30 PM
  4. Replies: 3
    Last Post: 06-25-2014, 10:49 AM
  5. How to enable Cortana?
    By Rafa Rios in forum Ask a Question
    Replies: 2
    Last Post: 06-24-2014, 09:44 AM
LINK TO POST COPIED TO CLIPBOARD