1. GPendolino's Avatar
    I did the 8.1 OFFICIAL update as it came in yesterday via the AT&T network.

    Now I have the features you're expected to have in 8.1.

    Problem is, Gmail doesn't appear to sync when I'm on 4G, only when I'm on WIFI and even then it's painfully slow.

    While I was on a two hour almost pointless phone call with Nokia support, I decided to add my Gmail account to my wife's phone (also a Nokia Lumia 1020 with the 8.1 official update).

    Via WIFI or 4G, hers synced immediately.

    Also, my phone only gives me the following sync options: 15 minutes, 30 minutes, hourly, every 2 hours or manually. My wife's gave me those as well as the "as items arrive".

    Other difference is my cellular data icon in the upper left says LTE whereas hers says 4G.

    So I am admitting defeat at this point as I'm entirely baffled. How can two identical phones (make/model/software versions) behave so differently as they're sitting next to each other.

    The advice I was given was to flash it and I have the following two links provided by Nokia support:

    Nokia Software Updater for Retail now available as the ultimate bricked phone rescuer | WMPoweruser

    FAQ - How can I recover/reset/restore my phone software? - Nokia - USA

    Before I go down that rabbit hole is there anyone here that wants to give it a shot and see if there's something I may have missed?
    08-15-2014 07:18 PM
  2. Rodrigo Pereira Teixeira's Avatar
    The Gmail APP for WP is ****, man. Even before 8.1 it took forever to load. Arg. Run away from it.

    Get MetroMail: fast, magnificent buffer and good layout.
    08-15-2014 07:29 PM
  3. GPendolino's Avatar
    Looking at that as an option now. I guess I'm a bit leery of using third party apps for something like my email.
    I just feel like I'm giving my username and password out to a stranger at that point.
    I wasn't exactly using a "gmail app" when I was in 8.0. I was just setting up the email via the settings (like I did in under a minute on my wife's phone so successfully). I just want it to work as well as it did BEFORE 8.1 and as well as it works on my wife's phone AFTER 8.1.
    08-15-2014 07:40 PM
  4. Compiux's Avatar
    I had issues with the gmail native app from the phone, wasn't receiving mails.
    I turned off and on the phone and that solved the issue.
    Still, I've heard good comments on the MetroMail app. I guess I'll check it
    08-16-2014 01:04 PM
  5. Rodrigo Pereira Teixeira's Avatar
    I hear that, man, but the Gmail app is bullocks... Like, i tried to refresh my app for new e-mails and it took nearly (and I'm dead serious about this) 5 minutes to fetch an email. MetroMail will do that for you instantly, and it's also free (with ads). Try that, man.
    Compiux likes this.
    08-16-2014 03:02 PM
  6. JaimitoFrog's Avatar
    Been using the native mail application with push since last yr. still works after the 8.1 update. I noticed you can't do that on the newer phones anymore, like the Icon.
    08-17-2014 12:47 AM
  7. stonedauwg's Avatar
    Got the update today. Now the native app is sending gmail but not receiving. Never had a problem with it pre-update. What a joke. Maybe they changed what protocols or servers they use for gmail on 8.1.
    08-18-2014 08:08 PM
  8. chmun77's Avatar
    No problem on my 1020 with Gmail. Receiving new emails as they arrived. Using the built-in email app. Don't like 3rd party email apps. In fact, my Nexus 7 received emails later by few mins as compared to my 1020 when both of them are connected to WIFI.
    08-18-2014 08:18 PM
  9. trwrt's Avatar
    The "as items arrive" option only appears after the first successful sync, I think.

    I didn't have many problems with the native mail but I use MetroMail too, for the ease of archiving/deleting and also being able to choose which alias to use when sending mail which is critical as I funnel a bunch of addresses through GMail. If you try it you'll see that it takes you to a Google page to enter your login credentials, so the app itself never actually has your password.
    08-18-2014 08:20 PM
  10. chmun77's Avatar
    The "as items arrive" option only appears after the first successful sync, I think.

    I didn't have many problems with the native mail but I use MetroMail too, for the ease of archiving/deleting and also being able to choose which alias to use when sending mail which is critical as I funnel a bunch of addresses through GMail. If you try it you'll see that it takes you to a Google page to enter your login credentials, so the app itself never actually has your password.
    Does Metro Mail allow attaching of different files from the composing email itself? One thing I hate about the native WP email client is the lack of attaching files other than photos. And even if I share a word doc from Office hub, I cannot add another one when composing the email.... So much for being an enterprise phone.
    08-18-2014 08:25 PM
  11. trwrt's Avatar
    Does Metro Mail allow attaching of different files from the composing email itself? One thing I hate about the native WP email client is the lack of attaching files other than photos. And even if I share a word doc from Office hub, I cannot add another one when composing the email.... So much for being an enterprise phone.
    It looks like it can. I don't have any Office documents on my phone at the moment to try it but it does let you browse the documents/downloads/music/etc folders and select multiple files. The program is free (with ads) so you can try out your own particular use cases before shelling out the $1.99.
    chmun77 likes this.
    08-18-2014 09:34 PM
  12. stonedauwg's Avatar
    Just a quick update, I removed the Google account from the phone, then re-added it and now it's syncing fine.
    08-18-2014 09:54 PM
  13. leMecZTech's Avatar
    Had the same issue after the 8.1 upgrade, but was only able to get it work with WIFI off. In fact, I did a full reset of the phone with the Nokia Software updater. After that, I could not even add back the Google Mail account. The only way was to turn off WIFI. Now, the only time I can get emails is when WIFI is off. (I've reset my router, modem, etc. Every other device works OK, just the two Lumias that got the update are not working with Google Mail.)

    We would happily downgrade to 8.0 to have back our reliable performance.
    08-26-2014 10:20 AM

Similar Threads

  1. Nokia Lumia 1020 windows 8.1 update?
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 08-16-2014, 06:11 PM
  2. NFLRUSH brings fantasy football and prizes to kids on Windows Phone and Windows 8.1
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-15-2014, 07:11 PM
  3. HERE Maps, Local Scout etc not working on my Lumia 720
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-15-2014, 07:05 PM
  4. AT&T Warranty... How strict on "no damage"?
    By pkvillager in forum Carrier Discussion Lounge
    Replies: 2
    Last Post: 08-15-2014, 06:52 PM
  5. Replies: 3
    Last Post: 08-15-2014, 04:07 PM
LINK TO POST COPIED TO CLIPBOARD