1. humanhowever's Avatar
    Hey All,

    Hope you're well.

    I got a new Lumia 1020 at Christmas, which was ordered online by the buyer (here). Though the phone is unlocked and okay, it has a German CV. There are 2 issues with the phone:

    - The signal on the phone drops every few seconds, changes to "no signal" and then picks up again up to 3 bars sometimes. Other times it is constantly in a "no signal" state and to so doesn't deliver text messages / connect to the net. To get it out of this state, I have to call someone, and somehow that forces the connection.
    this is really annoying as the signal drops out ALL the time, even in the middle of calls. Could the reason for this be that it has a German CV? I know how to flash a GB CV onto it, but wanted to know whether that would actually fix the issue. I don't want to flash it, only to find out the problem persists and requires further attention. I can take it to a Nokia Care Point on the 2nd Jan.

    - The backlight for the navigation buttons doesn't work. I've never seen the lights turn on at all. Someone informed me, by connecting it to the Lumia Recovery Software, resetting it, would make them work. I don't mind giving it a try, but I'd rather avoid the hassle of having to do the updates, set up apps etc etc.

    Any help / advice would be very much appreciated.

    Hope you're having a lovely weekend.

    N.
    12-27-2014 05:40 PM
  2. Ed Boland's Avatar
    I'd start with the carrier, or whoever you're using for cellular service on this phone first. Once you've determined it's not them or the SIM card, then I'd look into taking it to that Nokia care center.

    I'm not sure about any software or flash fix for the lights for the navigation buttons, but I'd look into what kind of warranty is available through the place in which it was purchased. If not, the manufacturers warranty and the Nokia Care center might be your best bet.
    Laura Knotek likes this.
    12-27-2014 07:32 PM
  3. rbar3154's Avatar
    Try to fix the network carrier. Do not put in automatic. This resolve some issues with my phone.
    Hope it helps.
    Rubn
    12-28-2014 05:07 AM
  4. humanhowever's Avatar
    I'd start with the carrier, or whoever you're using for cellular service on this phone first. Once you've determined it's not them or the SIM card, then I'd look into taking it to that Nokia care center.

    I'm not sure about any software or flash fix for the lights for the navigation buttons, but I'd look into what kind of warranty is available through the place in which it was purchased. If not, the manufacturers warranty and the Nokia Care center might be your best bet.
    Thanks for your reply!
    I tried my sim card in my Lumia 920 and it works perfectly, without any signal dropping.

    I shall take it to a Nokia Care point.
    12-28-2014 05:15 AM
  5. humanhowever's Avatar
    Try to fix the network carrier. Do not put in automatic. This resolve some issues with my phone.
    Hope it helps.
    Rubn
    Hey,
    I will give that a go! Thanks
    12-28-2014 05:16 AM
  6. jfmul's Avatar
    I know it's been a while, but did you resolve the issue at all? I have same problem with a 1020 bought in Germany.
    04-02-2015 03:59 PM

Similar Threads

  1. Airplay app on WP8.1?
    By AndreStudart in forum Windows Phone 8.1
    Replies: 2
    Last Post: 12-28-2014, 01:17 AM
  2. [Answered] Is possible increase the ram memory on my lumia 520?
    By Windows Central Question in forum Ask a Question
    Replies: 7
    Last Post: 12-27-2014, 08:44 PM
  3. Replies: 1
    Last Post: 12-27-2014, 05:05 PM
  4. Lumia 1020 Network+ settings
    By mudgeeraba in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 12-27-2014, 04:42 PM
  5. Why do deleted emails reappear on my phone?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 12-27-2014, 04:31 PM
LINK TO POST COPIED TO CLIPBOARD