1. MassDeduction's Avatar
    Starting just in recent days, whenever I try to connect to a WiFi network I get the message "Can't Connect. The WiFi network <network name> didn't respond. Try again later."

    Other devices, including other Windows Phones, are connecting to these networks no problems. Is my phone just dying of old age? Any thoughts appreciated.
    04-22-2015 12:08 PM
  2. Tanay Bhattacharjee's Avatar
    I think your phone needs to repair in the part of Wi-Fi....... But how many years are you using it? Have you updated it recently?
    gpobernardo likes this.
    04-22-2015 12:30 PM
  3. gpobernardo's Avatar
    Starting just in recent days, whenever I try to connect to a WiFi network I get the message "Can't Connect. The WiFi network <network name> didn't respond. Try again later."

    Other devices, including other Windows Phones, are connecting to these networks no problems. Is my phone just dying of old age? Any thoughts appreciated.
    Have you tried restarting your L1020 or performing a soft reset on it? Restart = power off then power on; soft reset = press and hold volume down button and power button until your phone restarts

    Have you tried restarting your Wi-Fi router (if you can)?

    I think your phone needs to repair in the part of Wi-Fi....... But how many years are you using it? Have you updated it recently?
    Welcome to Windows Central, Tanay!
    04-22-2015 01:09 PM
  4. MassDeduction's Avatar
    I have tried a couple of soft resets to no avail. I have not recently updated it, that I recall. I've been using it since the L1020 came out, so it's no spring chicken. I was hoping it was a software issue, but alas I fear it may be hardware.
    gpobernardo likes this.
    04-22-2015 02:13 PM
  5. zei20t's Avatar
    I have problems with both my wife's 1020 and my 925. Both cant connect to my 5GHz WiFi networks, but connect fine to the 2.4GHz.

    I thought it was a thing with my Netgear routers (have had 2 different ones) but it might be the phones older wireless hardware?
    04-22-2015 08:15 PM
  6. MassDeduction's Avatar
    I have problems with both my wife's 1020 and my 925. Both cant connect to my 5GHz WiFi networks, but connect fine to the 2.4GHz.

    I thought it was a thing with my Netgear routers (have had 2 different ones) but it might be the phones older wireless hardware?
    Interesting theory. However, other Lumia 1020s connect fine to these networks, and this one did until very recently. Maybe the WiFi software in the OS has become corrupted. Maybe trying Windows 10 Preview on it will help. :)
    04-22-2015 08:27 PM
  7. zei20t's Avatar
    I have TP10 on my 925 and it DOES connect to my 5GHz networks
    04-22-2015 09:35 PM

Similar Threads

  1. Why can I not connect my FB games on my nokia 635??
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 04-22-2015, 10:31 AM
  2. Why can't my 520 or my 640 see my 5ghz wifi?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 1
    Last Post: 04-22-2015, 09:17 AM
  3. Lumia 1020 won't power on once powered off
    By Glen Gordon in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 04-21-2015, 08:49 AM
  4. Data Connection Option in my Microsoft Lumia disabled... ?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-21-2015, 07:33 AM
LINK TO POST COPIED TO CLIPBOARD