1. metalinjection's Avatar
    why is my lumia 1320 get a multi colored paint like sreen after a hard reset.,?i flashed it many times but still the display is distorted.,what should i do?is it a hardware issue?my phone haven't fell at all...can u help me with this,i need my phone so bad....thank u very much.
    12-03-2014 06:54 AM
  2. SSgt Bruskowiz's Avatar
    Can you add a screenshot or picture from your screen?
    a5cent and Guytronic like this.
    12-05-2014 07:25 PM
  3. hprvez's Avatar
    It could be a corrupted rom, resets won't fix it, you would need to reflash it with one of the Nokia tools
    12-07-2014 08:01 PM
  4. metalinjection's Avatar
    i tried to took an screen shot and connect it to my pc and the pix displays the phone menu.,but the phone itself won't display such.,the screen has multi colored paint-like.
    12-09-2014 06:30 AM
  5. palmujukka's Avatar
    i tried to took an screen shot and connect it to my pc and the pix displays the phone menu.,but the phone itself won't display such.,the screen has multi colored paint-like.
    Have you tried reflashing your phone's ROM with the instructions from the above post? Otherwise, it sounds like a hardware problem. You should try to get your phone repaired/replaced at a Microsoft store.
    12-09-2014 06:44 AM
  6. metalinjection's Avatar
    how could this be a hardwae issue?the problem just occured after a hard reset
    12-09-2014 11:31 AM
  7. SSgt Bruskowiz's Avatar
    Just take a picture ( with a other phone or camera ) from your device and upload it here.
    I wont give you any advice before i know with wat i am dealing with otherwise i mite point you in to the wrong direction ;)
    12-09-2014 11:38 AM
  8. metalinjection's Avatar
    it's like this.......
    n.jpg
    12-09-2014 11:15 PM
  9. SSgt Bruskowiz's Avatar
    Brace your self.
    Its your chip on the mainboard.( hope driver issue ).
    If a hard reset doesnt work anymore
    Than you need a compleet reflash with the nokia tools.
    12-10-2014 05:05 AM
  10. metalinjection's Avatar
    i've flashed it many times with nokia care suite
    12-10-2014 12:34 PM
  11. SSgt Bruskowiz's Avatar
    Then i am afraid that it is your chipset...
    Go look for your warranty papers and send it in for repair.
    12-10-2014 03:08 PM
  12. Xabier Granja's Avatar
    That's happened to me a bunch of times on my 920. Solutions I've found, that have been mentioned in this thread:

    1) Hard reset with PWR+VOL DOWN (or is it up? I never remember).
    2) If the previous doesn't work, flash with Nokia Recovery Tools.
    3) If the previous 2 don't work, I'm out. Send it for repair...

    Good luck!
    12-18-2014 09:18 AM
  13. Thalitz's Avatar
    My Lenovo S820 has this same issue. Service center told me to change the motherboard of my phone
    11-10-2016 06:59 PM

Similar Threads

  1. Replies: 7
    Last Post: 12-19-2014, 11:55 PM
  2. Why on screen buttons instead of physical buttons ?
    By Mayank Kothari1 in forum Ask a Question
    Replies: 6
    Last Post: 12-07-2014, 09:42 AM
  3. Does the time reset when you take the battery out?
    By Abhishek Gupta1689 in forum Windows Phone 8.1
    Replies: 3
    Last Post: 12-05-2014, 01:29 PM
  4. Replies: 6
    Last Post: 12-03-2014, 05:30 AM
  5. Replies: 0
    Last Post: 12-03-2014, 03:44 AM
LINK TO POST COPIED TO CLIPBOARD