12-01-2017 10:14 PM
797 ... 7891011 ...
tools
  1. nthknd's Avatar
    Well I sent my phone in for repair and Nokia replaced it stating it was a factory defect.. so maybe stop waiting for a fix and send your phones in under warranty. I don't know if the phones any better but I'll be selling this one and sticking to android. Love the note 3

    Sent from my SAMSUNG-SM-N900A using Tapatalk
    01-23-2014 12:46 PM
  2. amr osman's Avatar
    Changed 2 Lumia 1520 for SD problem and still the same Nokia can't find a solution but replacing defected phone with another defected one until I'm fed up the worst customer service ever

    Sent from my RM-937_im_mea3_932 using Tapatalk
    01-24-2014 12:13 AM
  3. Dave Blake's Avatar
    Changed 2 Lumia 1520 for SD problem and still the same Nokia can't find a solution but replacing defected phone with another defected one until I'm fed up the worst customer service ever

    Sent from my RM-937_im_mea3_932 using Tapatalk

    what issue are you having with the SD card ?
    01-24-2014 05:55 AM
  4. Kashan Osama's Avatar
    What are you doing nokia,where is the awesome quality control :| i mean seriously I am not a troll,just a frusterated nokia fan,bought a 620,had a wierd screen fuzziness
    01-24-2014 06:53 AM
  5. Ivan-Baraban's Avatar
    Hello to all

    My wife will receive her Lumia 1520 after a couple of days. This will be our first WP phone. So, is there any test or guide about Lumia 1520 initial chech & test? Or would you like as to be so kindly as to list main points/aspects which have to be checked during receiving the device? For example, my HTC One X has built-in app for initial testing, which shows different features for user & asks him about the result.
    01-24-2014 02:57 PM
  6. daredevil1315's Avatar
    hey guys please i have my 1520 about 2 weeks ago and the screen when i apply pressure it looks weird
    01-24-2014 06:13 PM
  7. daredevil1315's Avatar
    can any one answer me please
    01-24-2014 06:26 PM
  8. Ben Hanchett's Avatar
    A 1520 owner for about 2 weeks. I have the random freeze and reboot every day. Someone mentioned about the phone not recognizing being plugged in. I have had this as well. I almost threw away a perfectly good cable because the phone didn't recognize it. Even when it does recognize being plugged in, It seems to take about 5 - 10 seconds which is excessive. I performed a hard reset about an hour ago, because I'm having the other storage problem. I don't have a sd card yet. My memory was under 200 MB. Every time I wanted to take a picture the phone would say memory full. I kept juggling stuff to delete. I checked phone storage today. I had 667.2 MB in temporary. Tried to delete 3 times, but got nothing. Oh, I also have the connection issue( showing I have signal when I really don't).

    One more thing...The speakerphone is load when talking or playing music, but for some reason when I watch web videos it's low. I have to turn volume to 30 just be able to hear. I've had a Focus,Titan, and 920 and don't remember having to do this.
    Last edited by Ben Hanchett; 01-25-2014 at 12:44 AM.
    01-24-2014 09:12 PM
  9. techsilver13's Avatar
    After three weeks my phone just started randomly opening the Bing search. Its extremely annoying. I did a hard reset and did not restore any data and it still does it. It seems to do it more with a case on the phone. I am extremely annoyed. Looks like I may be selling the phone.

    Sent from my RM-940_nam_att_200 using Tapatalk
    01-25-2014 04:28 PM
  10. techsilver13's Avatar
    Does anyone know if Nokia will fix or replace a 1520 that has any of the issues in the op? My phone has taken a complete nose dive with this Bing search junk. I can barely use the phone now.

    Sent from my RM-940_nam_att_200 using Tapatalk
    01-26-2014 02:28 AM
  11. gremlingswe's Avatar
    My 1520 has random reboots...
    01-27-2014 02:55 PM
  12. boo516's Avatar
    My 1520 deletes song information off the sd card. Every couple days a song's album or artist tag will be deleted. My 1520 has also deleted playlists and album art. 5 weeks in and my entire music library is getting closer and closer to having unknown artist and unknown album.
    01-27-2014 05:53 PM
  13. puchongjoe's Avatar
    Cant lower video volume during playback using side physical button.
    01-29-2014 03:16 AM
  14. Will6371's Avatar
    My phone doesn't load music from the micro SD card anymore. It just shows the music as "other" under the memory breakdown. I synced the card with WMP after reformatting the SD card because artists started getting deleted even though all of their songs were still in my library. The music+videos app is so buggy they really really need to fix it with 8.1, if they have to they should rewrite the whole app since I don't know anyone that doesn't have a problem with it.
    How did you format the card? I had similar problems with my Xperia Z1 even after formating the card in my laptop but stopped after I formatted it in my phone. It was a 64gb card if that matters.
    01-29-2014 04:10 AM
  15. mozman68's Avatar
    Not sure if this is really a bug or not, but it has popped up in the past week. When I plug my phone into a power source, it can take upwards of 20-30 seconds before the phone recognizes it and makes the "I'm being powered" sound.

    Used to be fairly quick...like within a couple of seconds.

    Anyone else ever experience this?
    01-29-2014 07:23 AM
  16. rambocs's Avatar
    Not sure if this is really a bug or not, but it has popped up in the past week. When I plug my phone into a power source, it can take upwards of 20-30 seconds before the phone recognizes it and makes the "I'm being powered" sound.

    Used to be fairly quick...like within a couple of seconds.

    Anyone else ever experience this?
    Yeah, I experienced this as well. As long as it charged properly and does not affect battery life then no biggie otherwise going for warranty
    01-29-2014 07:39 AM
  17. Dave Blake's Avatar
    Not sure if this is really a bug or not, but it has popped up in the past week. When I plug my phone into a power source, it can take upwards of 20-30 seconds before the phone recognizes it and makes the "I'm being powered" sound.

    Used to be fairly quick...like within a couple of seconds.

    Anyone else ever experience this?

    This happens on all Windows Phones don't worry about it its normal behavior.
    01-29-2014 07:48 AM
  18. mozman68's Avatar
    This happens on all Windows Phones don't worry about it its normal behavior.
    Hah...wasn't too worried about it. Did a restart and it went back to normal...just plugged it in and it took just a little longer. As long as it is charging, I guess I shouldn't care too much.
    01-29-2014 12:04 PM
  19. Genuine-Boy's Avatar
    Hi
    This is the first time I post here and I have some questions to ask.
    First , How long does it take to become fully charge?
    Next , What should I do for first time battery charging to get the best battery life?
    And finally , plz give me some advices to check the phone for the first time to get sure it`s running normally
    Tnx a million
    01-30-2014 05:22 AM
  20. Pavel_Y's Avatar
    Not sure if this is really a bug or not, but it has popped up in the past week. When I plug my phone into a power source, it can take upwards of 20-30 seconds before the phone recognizes it and makes the "I'm being powered" sound.

    Used to be fairly quick...like within a couple of seconds.

    Anyone else ever experience this?
    I had similar issue. It's gone when I uninstalled third party battery app and restarted my phone.
    01-30-2014 06:43 AM
  21. harmon rabb's Avatar
    My 1520 deletes song information off the sd card. Every couple days a song's album or artist tag will be deleted. My 1520 has also deleted playlists and album art. 5 weeks in and my entire music library is getting closer and closer to having unknown artist and unknown album.

    have you guys with SD card problems tried using a class 6 SD card instead? I'm putting money on you using class 10 or newer. You'll have to order a class 6 online, they're an older standard.

    9 times out of 10 this fixes any SD card issue with any device.
    01-30-2014 06:45 AM
  22. AndyCalling's Avatar
    Or just use a Samsung class 10 card. They seem to work flawlessly in Lumias, as I've never seen someone state otherwise. Mine works perfectly.
    01-30-2014 06:48 AM
  23. Nikito27's Avatar
    Hi guys, my lumia's speaker makes a strange sound. Let me explain: when the speaker is supposed to make any tipe of sound after it has made the sound it stays turned on for a wile and makes a buzz like sound until after a few seconds it pops and goes silent again. It makes the same tipe of sound also when i use earphones, when i have them on and i'm not playing any music it buzzez. Its really strange also becuse when i'm actually playing music it sounds normall! Has anyone had the same problem?
    01-30-2014 04:39 PM
  24. Indivestor's Avatar
    Problem is with the ASIC. Hardware issue. Exchange your phone.
    01-30-2014 06:31 PM
  25. unease's Avatar
    Got a weird issue. Did a phone reset. Restored back my usual settings and now, Nokia Storyteller app does not want to install. Gives the error that it is not available for my phone (1520)
    01-30-2014 10:41 PM
797 ... 7891011 ...

Similar Threads

  1. Unlocked Lumia 640 on Walmart Family Mobile Data Issues
    By cmfooballcoach in forum Microsoft Lumia 640
    Replies: 12
    Last Post: 03-10-2016, 03:35 PM
  2. Replies: 7
    Last Post: 03-05-2016, 07:20 AM
  3. HD LTE for Lumia 640XL
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-04-2016, 08:40 PM
  4. Anyone know a good source for Lumia 950 screens?
    By Joseph Calamita in forum Microsoft Lumia 950
    Replies: 0
    Last Post: 03-04-2016, 07:30 PM
  5. Lumia 640 lte not connecting to secure wifi network
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-04-2016, 06:35 PM
LINK TO POST COPIED TO CLIPBOARD