1. immortalmatt's Avatar
    Hi, i put mine on charge last night at 10pm and got up with my alarm as normal and noticed the battery was only on 85% and the charging icon wasn't there. I tried a few times unplugging the charger and putting it back in. Sometimes it made the noise and showed the icon straight away, sometimes it took 10 seconds or more to show its charging and sometimes it didn't at all. What do you think is the problem? Ive tried the lead and pkug on a different phone which charges everytime instantly.
    01-15-2014 05:09 AM
  2. N_LaRUE's Avatar
    Try plugging it into another device (laptop/computer) and use a different USB cable to ensure it's the phone and not the cable/plug.

    If it's the phone you have really three options.

    1) Soft reset - Hold volume down and power button until phone vibrates
    2) Hard reset - Settings -> About -> Reset your phone
    3) Return it and get a new one.
    01-15-2014 05:13 AM
  3. immortalmatt's Avatar
    To update, it was my socket extender, turned out it was faulty. Bought a new one and worked perfectly from then on.
    03-19-2014 04:22 PM

Similar Threads

  1. Replies: 2
    Last Post: 02-25-2014, 09:42 AM
  2. Contacts issue, help!
    By Stephen Burysek in forum Nokia Lumia 1520
    Replies: 2
    Last Post: 01-15-2014, 06:50 PM
  3. Battery failure?
    By wasapasserby in forum Nokia Lumia 925
    Replies: 2
    Last Post: 01-15-2014, 12:57 PM
  4. Issue: Page cannot be displayed in Metro
    By realwarder in forum Windows 8
    Replies: 1
    Last Post: 01-14-2014, 09:08 PM
  5. Firmware updates available for original Surface Pro - fixes Touch and Type Cover issues
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-14-2014, 04:40 PM
LINK TO POST COPIED TO CLIPBOARD