1. Shredcow's Avatar
    Hi people
    I've noticed that my 1520 tends to reboot when it has difficulty connecting to Wi-Fi; does this happen to anyone too?

    My workplace has Wi-Fi but in-between floors, walking down stairs or taking the lift, the phone will lose the Wi-Fi signal and attempt to reconnect. That's when the rebooting happens.

    If I switched off the Wi-Fi and relied on cellular data, no reboots happen.

    Anyone else suffers from this issue? Any suggested fix?
    01-20-2014 01:07 AM
  2. Jazmac's Avatar
    Take it back.
    01-20-2014 03:00 AM
  3. LeLoT3's Avatar
    You tried Soft reset.... or even Hard Reset???
    01-20-2014 07:41 AM
  4. Shredcow's Avatar
    I've already done a hard reset when I first got the phone.

    And I'm in Singapore - we don't have an exchange policy. I'll have to consider sending the phone in for repairs...
    01-20-2014 08:50 AM
  5. barbequtioner's Avatar
    Just ordered from Singapore to Canada, you are making me worried I'm going to have the rotten luck of a bricked device BNIB lol
    01-21-2014 02:47 AM
  6. maclancer's Avatar
    I have the AT&T version and never had any issues with the wifi. You may have a defective one. Send the device to Nokia for repair or replace.
    GrayW0lf likes this.
    01-21-2014 02:52 AM
  7. Shredcow's Avatar
    Or it could be some improperly coded application or something...

    It's working okay today, not one reboot. Strange. I did uninstall the Folders app though...

    Or maybe it's just one of those Windows Phone things like the sudden battery drain.
    01-21-2014 04:15 AM
  8. mozman68's Avatar
    Mine did it last night...and all I was doing was texting back and forth with someone. I read their last text and was trying to respond but the cursor was frozen in the typing pane. A minute later after unsuccesfully trying to get out of the app, it did a restart. When I went back into the app, the last message sent to me wasn't there. I responded anyway since I read it before it restarted, but if I never noticed it, I may have missed the message. Weird.
    01-21-2014 07:43 AM
  9. CrackFachry's Avatar
    Mine has difficulty connecting to Wifi sometimes. A manual reboot will solve the problem every time. Not sure whether it's defective or just software bugs.
    Bought my Lumia 1520 from Malaysia
    01-22-2014 01:54 AM
  10. Ben Hanchett's Avatar
    Never had that happen, but my phone has restarted at least once a day since I got it( Jan 3). My phone has less than 200 Mb of free space. I thought that might have been the reason. Love the phone, but this a pain the ***. Will get a SD card to test out. This is the first phone I've ever used to have this many problems running on low storage. I get the message constantly.
    01-22-2014 09:51 AM
  11. neelagopi's Avatar
    in a span of 30min mine restarted 3 times... just now turned off wifi and on cellular data... now its fine!
    01-22-2014 05:17 PM
  12. GrayW0lf's Avatar
    I will consider myself lucky: My AT&T 1520 has not displayed this behavior, so far! I definitely agree with maclancer's comment on this topic.
    01-22-2014 06:09 PM
  13. Shredcow's Avatar
    in a span of 30min mine restarted 3 times... just now turned off wifi and on cellular data... now its fine!
    ah, same problem.

    Are you going to send your phone in?
    01-22-2014 11:22 PM

Similar Threads

  1. Replies: 15
    Last Post: 01-23-2014, 08:06 PM
  2. Unable to send emails to gmail account
    By lumia720_user in forum Windows Phone 8
    Replies: 2
    Last Post: 01-20-2014, 09:43 PM
  3. Replies: 1
    Last Post: 01-20-2014, 12:21 AM
  4. Replies: 3
    Last Post: 01-19-2014, 10:55 PM
LINK TO POST COPIED TO CLIPBOARD