1. harishm92's Avatar
    After the latest firmware update for lumia 1520, the glance screen does not work properly. sometimes when on call , the phone screen is on through the call i.e. the proximity sensor doesn't seem to work properly. and also when unlocking the phone the screen does not unlock immediately but flickers for a few seconds before unlocking. is anyone else facing the same problem? and is it a software glich or do i need to get my phone checked?
    02-19-2014 08:09 AM
  2. Planet X's Avatar
    Make sure the proximity sensor is not covered bij a screenprotector or dirt. I had a lot of problems with it on my 920 but not yet on my 1520.
    02-19-2014 12:35 PM
  3. harishm92's Avatar
    i have screen protector... i guess i will remove it and try. but the problem started after the latest firmware update, whereas i had the screen protector on for a couple of weeks by then.
    02-19-2014 01:06 PM
  4. webnoi's Avatar
    I updated my phone and I'm having the same problem. If Ir reboot the phone the problem is gone, but return after some time.
    childoftheworld likes this.
    03-22-2014 12:11 AM
  5. Shodan_HR's Avatar
    I updated my phone and I'm having the same problem. If Ir reboot the phone the problem is gone, but return after some time.
    hi, i am having this problem too... so, is this a software issue or hardware?
    childoftheworld likes this.
    04-03-2014 03:36 AM
  6. LuvMeSomeWP's Avatar
    I just got my 1520 yesterday, and today the glance screen is exhibiting the same problem. Glance does not trigger via the proximity after a while. Rebooting "fixes" the problem for a short while. Glance screen is only displayed briefly after the display turns off (I have it set to Peek).
    04-04-2014 04:26 PM
  7. JasonKruys's Avatar
    I just got my 1520 yesterday, and today the glance screen is exhibiting the same problem. Glance does not trigger via the proximity after a while. Rebooting "fixes" the problem for a short while. Glance screen is only displayed briefly after the display turns off (I have it set to Peek).
    I have this problem after every update, until a few days later when an 'Extras and Info' update always follows. After this update, it all works. Perhaos use sysapp pusher (or alternative) to see if there is an Extras and Info update you don't have?
    LuvMeSomeWP likes this.
    04-05-2014 06:15 AM
  8. LuvMeSomeWP's Avatar
    Thanks. I'm not noticing the issue any more. I do have to hover over the screen for a bit, but it does work!

    I have this problem after every update, until a few days later when an 'Extras and Info' update always follows. After this update, it all works. Perhaos use sysapp pusher (or alternative) to see if there is an Extras and Info update you don't have?
    childoftheworld likes this.
    04-08-2014 03:37 PM
  9. childoftheworld's Avatar
    I have this problem after every update, until a few days later when an 'Extras and Info' update always follows. After this update, it all works. Perhaos use sysapp pusher (or alternative) to see if there is an Extras and Info update you don't have?
    In essence then, you are saying that this "Extras + Info" update ultimately fixed a problem, or the problem? I've noticed this on one of my Lumia 1520s as well and it is intermittent. I reboot many times and then the problem goes away... don't really know if this is software or hardware related but right now, it seems to be software related...

    But why only to one of my 3 Lumia 1520s. The other 2 are okay. So what is wrong here??

    This is the unit I sent back to Nokia Care to have the lens focus issue fixed. It came back to me with this problem. At first, I thought it could have been a faulty proximity sensor or a loose connection but it does not seem to be so.

    Any good answers?

    Thanks
    03-10-2015 08:43 PM
  10. Charlie Red1's Avatar
    I think I notice this problem with cyan too, I don't think it's from denim upgrade..... Any solution, I'm considering back up the phone and try rebooting hopefully it will go away, I'll keep you posted also if any one knows how to take glance screen app, cause I'm thinking about re install this app any suggestion?
    03-13-2015 05:45 PM
  11. childoftheworld's Avatar
    I removed Glance Screen and re-installed it. Same problem. I am not sure how to pinpoint the issue. But I am more and more convinced this is a software issue, not hardware.
    03-13-2015 08:00 PM
  12. childoftheworld's Avatar
    I think I notice this problem with cyan too, I don't think it's from denim upgrade..... Any solution, I'm considering back up the phone and try rebooting hopefully it will go away, I'll keep you posted also if any one knows how to take glance screen app, cause I'm thinking about re install this app any suggestion?
    Maybe we are focusing on this as a 1520 problem. I am reading some other reports, but on other Lumia Models...

    Just search Lumia Proximity Sensor...

    Does not seem to be dust/dirt problem because I cleaned my sensors...

    Mine works now but once it a while it does resurface and I have not quite figured out what makes it come back and what makes it go away... been trying different configurations.

    I have 3 units of the 1520, same model/variant... so why is it only happening to one unit and not the other 2?
    03-13-2015 08:07 PM
  13. Charlie Red1's Avatar
    I'm happy to report it that after putting the 1520 through system recovery via computer, there was no more issues with the glance screen and it's working fine, buy you have to have a good patient and be prepared for some little surprises at the end of the day I think it's worth it.
    03-15-2015 07:57 AM
  14. farhanmariz's Avatar
    I'm happy to report it that after putting the 1520 through system recovery via computer, there was no more issues with the glance screen and it's working fine, buy you have to have a good patient and be prepared for some little surprises at the end of the day I think it's worth it.
    I've been having this issue and sadly running the Lumia Software Recovery Tool to reset my phone doesn't fix the issue. Hopefully there will be a Glance update to fix this.
    Hesham Fouad likes this.
    03-18-2015 12:58 PM
  15. Hesham Fouad's Avatar
    Here is why and how to fix it , the proximity sensor is glued with a double stick tape to the front frame over time this glue lose its sticky and the sensor move back, causing black screen during a call and glance not engaged ,to test this is your issue just press hard over the proximity sensor with your finger during a call black screen or glance, other test stick the proximity sensor to a very hi lamp like 120 watt during a black screen call or glance if it work then here is the permanent fix, open the back cover get a strong double tape like 3M and replace the original, another easier way use a small tiny drop of super glue to stick sensor to front frame , if anyone need pic I can upload it later thanks
    LuvMeSomeWP and Andrew Gordon like this.
    05-19-2015 12:36 AM
  16. Thang Ho's Avatar
    Hi, please upload your instruction pictures. Thanks so much!
    08-16-2015 04:48 AM
  17. Edwin Kurniawan Lunggito's Avatar
    Do you have pic for fix the proximity sensor problem? thank before for your help
    10-25-2015 10:21 AM
  18. Edwin Kurniawan Lunggito's Avatar
    Here is why and how to fix it , the proximity sensor is glued with a double stick tape to the front frame over time this glue lose its sticky and the sensor move back, causing black screen during a call and glance not engaged ,to test this is your issue just press hard over the proximity sensor with your finger during a call black screen or glance, other test stick the proximity sensor to a very hi lamp like 120 watt during a black screen call or glance if it work then here is the permanent fix, open the back cover get a strong double tape like 3M and replace the original, another easier way use a small tiny drop of super glue to stick sensor to front frame , if anyone need pic I can upload it later thanks
    Can you upload the pic please? I have same problem.
    10-26-2015 07:33 PM

Similar Threads

  1. Live tile problems post Black update
    By fierovin in forum Nokia Lumia 928
    Replies: 3
    Last Post: 02-28-2014, 08:48 AM
  2. Get 1520 or wait to see whats released at MWC?
    By kwill in forum Nokia Lumia 1520
    Replies: 20
    Last Post: 02-25-2014, 11:01 AM
  3. Nokias giving away a Lumia Icon and a trip to an iconic location (US only)
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 02-21-2014, 07:54 PM
  4. Lumia Black Apps- Beamer and Storyteller
    By rcazador in forum Nokia Lumia 822
    Replies: 5
    Last Post: 02-20-2014, 10:18 AM
  5. Nokia lumia Black update here on O2 Uk
    By Michael Bull2 in forum Nokia Lumia 520
    Replies: 2
    Last Post: 02-19-2014, 05:58 PM
LINK TO POST COPIED TO CLIPBOARD