1. abuhurairah13's Avatar
    Im sorry if this has been posted anywhere, but i seem to not be able to locate any solution to it so far.

    Lumia 1520 is unable to connect to my home 5GHz WiFi. It can connect to 2.4GHz signal without any problem though. The phone does not even able to see the signal let alone connect to it. Is there any workaround this problem?

    I've tried tweaking a few settings on my router (signal frequency etc) but to no avail so far. And all my older devices are connecting to that same signal without any problem at all (blackberry z30, Sony Xperia Z1)

    my phone: Lumia 1520 RM-937
    my router: Asus RT-N56U
    03-04-2014 06:49 AM
  2. AndyCalling's Avatar
    Hmm, very odd. Assuming your phone model has 5GHz capability (do check the spec), you might find that simply rebooting your router may do the trick. If not, give your phone a soft reset as well.
    03-04-2014 06:54 AM
  3. Morpheus Phreak's Avatar
    Hmm, very odd. Assuming your phone model has 5GHz capability (do check the spec), you might find that simply rebooting your router may do the trick. If not, give your phone a soft reset as well.
    All 1520's support 5GHz networks and up to Wireless AC.

    Just to check abuhurairah13, do you have the router setup to broadcast the SSID for the network? I ask this because I know a lot of folks who after setting up their devices turn off the SSID broadcast since it is no longer needed to establish a connection once it is made the first time (except under odd circumstances) and this leads to them forgetting about it when purchasing another device...especially on 5GHz devices since the support there is still small compared to 2.4GHz devices.
    03-04-2014 07:50 AM
  4. abuhurairah13's Avatar
    My SSID are both broadcasted under a different name. Asus 2.4ghz and Asus 5ghz (yes, I know I'm lame in naming things). But thank you for the response anyway.

    cheers
    bbennett40 likes this.
    03-04-2014 09:06 AM
  5. Citizen X's Avatar
    This is a link to a thread about ac wifi issues with the Lumia 1520. Not sure if it is related or will in any way help.

    Lumia 1520 - poor 5GHz Wi-Fi performance - Nokia Support Discussions
    03-04-2014 09:10 AM
  6. abuhurairah13's Avatar
    The last post in that thread was mine. No luck there too
    03-04-2014 09:12 AM
  7. Citizen X's Avatar
    The last post in that thread was mine. No luck there too
    Lol. Sorry. Didn't even notice. I'm concerned because I want to get an ac wifi router to cover a large space and I am going to be really unhappy if I drop $200 and the thing doesn't work with Lumia 1520s. In a few weeks I will try my at&t 32 GB 1520 with the Asus ac wifi router and report back.
    03-04-2014 09:24 AM
  8. abuhurairah13's Avatar
    That's really funny as this beast does support WiFi a/b/g/n and ac too. I think it may be the device driver or something. Or it might be that I'm the only one suffering this problem. In any case, its just a small gripe, u shouldn't stop urself from buying one as this thing is a beast!. I'm diehard blackberry fan (I even declared my blackberry Z30 the best smartphone ever!). But this thing does eclipses that device, and other devices that I've ever owned too (ios and flagship android included)
    03-04-2014 09:38 AM
  9. Michael Cueva's Avatar
    Hey, I am not sure if you ever got this fixed. If not, then I would recommend the following steps to see if you can connect:

    Change security from WPA2 (default now a days) to WPA/WPA2. Allow for WPA first if your router does not have an option for both

    Change the Channel for the network to auto.

    Don't change the name or password.

    Save settings and reboot router. Phone should now be on the 5GHz band. If not, there may be an issue with your phone. You could always disable the security on the 5GHz band to see if the phone connects......
    11-05-2014 08:25 PM

Similar Threads

  1. Mobile Network Issues
    By colinkiama in forum Windows Phone 8
    Replies: 5
    Last Post: 03-04-2014, 07:12 PM
  2. Lumia 1520 switched off and wifi issues
    By Hasoumi in forum Nokia Lumia 1520
    Replies: 0
    Last Post: 03-04-2014, 03:52 AM
  3. Smartglass issue!
    By Gadsden1405 in forum Windows Phone 8
    Replies: 0
    Last Post: 03-03-2014, 11:35 PM
  4. Wifi config editor
    By gaurav_pec in forum Nokia Lumia 928
    Replies: 2
    Last Post: 03-03-2014, 05:57 PM
  5. This background image issue
    By meddyrainzo in forum Windows Phone 8
    Replies: 0
    Last Post: 03-03-2014, 12:33 PM
LINK TO POST COPIED TO CLIPBOARD