03-04-2015 11:11 AM
1,509 ... 2122232425 ...
tools
  1. mister2d's Avatar
    I don't see it when searching. It still shows up using the direct link to the product but it shows out of stock. B&H shows the black one available for shipping in 7-10 days but I don't know if that's the same model.
    Mine is from B&H. Looks like stock is drying up everywhere.
    05-01-2014 07:53 PM
  2. AlexFirth91's Avatar
    Ouch that sucks, although I'm in a similar predicament. My 1520.3 I ordered from Negri the 27th was the white backordered, but now its processing. I hope it arrives before June.
    05-01-2014 08:03 PM
  3. hasasimo's Avatar
    I never seem to get more than 2-3 bars of anything while on T-Mobile, whether it's LTE or HSPA. And I haven't tried the device with any other carrier. Is this normal?
    05-01-2014 08:51 PM
  4. mister2d's Avatar
    I never seem to get more than 2-3 bars of anything while on T-Mobile, whether it's LTE or HSPA. And I haven't tried the device with any other carrier. Is this normal?
    Interesting. I don't know. I get my usual spotty coverage in the house with T-Mobile (1-2 bars lte).

    Can you post some speed test numbers?
    05-01-2014 09:10 PM
  5. drbanks's Avatar
    I notice that the phone gets consistently fewer bars than did my 925. Doesn't seem to affect its ability to make calls or get data, but it is sort of unnerving.
    05-01-2014 09:22 PM
  6. Humhead's Avatar
    38.33 Mbps down speed with only 3 bars showing. No dropped calls. It seems that 3 bars are the new 5 bars.
    05-01-2014 09:42 PM
  7. hasasimo's Avatar
    Glad I'm not the only one. I guess it isn't an indication of signal strength after all if all the phones have this? Perhaps the signal indicator on the phone is on a different scale. I noticed the battery indicator on the top right is on a different scale than my 920. Even if the battery is at 99%, the battery icon won't show as fully charged like it does when the battery is at 100%.

    Just ran two speed tests. First one with 2 bars of LTE, second with 3 bars.

    Test 1: 14.07 up, 10.48 down, 101 ping
    Test 2: 21.1 up, 8.17 down, 98 ping

    *Edit: Walked around a bit around my building and it did hit 4 bars for a sec. So at least I know it's capable of displaying it lol.
    05-01-2014 10:03 PM
  8. firepromaster's Avatar
    I've had the phone about a week now. Got it, updated to 8.1. Reset phone to do a backup. Phone works great, except I only get H or H+ on ATT. I used to get LTE on my 920. Do I need to call or chat with ATT to get settings changed. I'm not having any bugs happen. Only thing that happened on the second day was ATT canceled my data plan. They threw me on some pay as I go plan, so I called the store I got my nano sim from. They told me my data had somehow got reset, so they flipped it back on.
    05-01-2014 10:49 PM
  9. mister2d's Avatar
    I've had the phone about a week now. Got it, updated to 8.1. Reset phone to do a backup. Phone works great, except I only get H or H+ on ATT. I used to get LTE on my 920. Do I need to call or chat with ATT to get settings changed. I'm not having any bugs happen. Only thing that happened on the second day was ATT canceled my data plan. They threw me on some pay as I go plan, so I called the store I got my nano sim from. They told me my data had somehow got reset, so they flipped it back on.
    Likely it's the IMEI number. AT&T isn't recognizing it as a LTE device. Your 920 was. This is hindsight, but next time use a nanosim cutter and throw that into your new phone. That way, no messing around with AT&T multiple times to get your LTE back.
    05-01-2014 11:13 PM
  10. mister2d's Avatar
    Glad I'm not the only one. I guess it isn't an indication of signal strength after all if all the phones have this? Perhaps the signal indicator on the phone is on a different scale. I noticed the battery indicator on the top right is on a different scale than my 920. Even if the battery is at 99%, the battery icon won't show as fully charged like it does when the battery is at 100%.

    Just ran two speed tests. First one with 2 bars of LTE, second with 3 bars.

    Test 1: 14.07 up, 10.48 down, 101 ping
    Test 2: 21.1 up, 8.17 down, 98 ping

    *Edit: Walked around a bit around my building and it did hit 4 bars for a sec. So at least I know it's capable of displaying it lol.
    That's actually not bad speeds and pings for 2 bars. Also anything around 100ms or less is good enough for VOIP calls. One thing T-mobile is good for is low latency on their network. I typically get around 80ms ping and I think that's great.
    05-01-2014 11:29 PM
  11. hasasimo's Avatar
    That's actually not bad speeds and pings for 2 bars. Also anything around 100ms or less is good enough for VOIP calls. One thing T-mobile is good for is low latency on their network. I typically get around 80ms ping and I think that's great.
    Definitely a lot faster than I was getting on MVNOs. Do think these phones are a little weak on the reception side though?

    drbanks, I'm curious what speeds you were getting on your 925 in comparison to your 1520, considering you had a better signal.
    05-01-2014 11:49 PM
  12. rdubmu's Avatar
    I never seem to get more than 2-3 bars of anything while on T-Mobile, whether it's LTE or HSPA. And I haven't tried the device with any other carrier. Is this normal?
    I am experiencing the same thing with my iPhone 5s. On my unlocked Lumia 920 I get 1-5 bars. I have never seen 5 !bars on my iPhone with tmobile


    Sent from my iPhone using Tapatalk
    05-02-2014 12:58 AM
  13. hasasimo's Avatar
    I am experiencing the same thing with my iPhone 5s. On my unlocked Lumia 920 I get 1-5 bars. I have never seen 5 !bars on my iPhone with tmobile


    Sent from my iPhone using Tapatalk
    Interesting. Do you think the devices are the culprits, or is it a T-Mobile thing? Wish I had a nano AT&T sim to test. But your observation puts me at east a bit... could just be T-Mobile in our areas. Then again, your unlocked 920 would get full signal at times. Was that full HSPA or Edge?
    05-02-2014 01:02 AM
  14. daniel187's Avatar
    Yellows in stock again at negri! They just emailed me about shipping.
    05-02-2014 02:31 PM
  15. mister2d's Avatar
    Yellows in stock again at negri! They just emailed me about shipping.
    ....and backordered! The Black is now "discontinued". Wow.
    05-02-2014 03:40 PM
  16. fecat17's Avatar
    Would you mind telling me which version (RM...) of the 1520 you bought, where you bought it from and how much?
    I've been sleeping on this device for months. Time to wake up :o)
    05-02-2014 06:20 PM
  17. dclaryjr's Avatar
    ....and backordered! The Black is now "discontinued". Wow.
    Damn. It's starting to look like this is reverting to unicorn status. I wish I could turn back the clock. I passed when they were available because I was waiting on the BillMeLater folks to fix my account so I could pay over 12 months instead of 6. I'd gladly go with 6 now if one was available.


    Dave Clary/Corpus Christi, TX
    05-02-2014 06:49 PM
  18. kwill's Avatar
    Yellows in stock again at negri! They just emailed me about shipping.
    No way! I've had an order in since before it said back ordered (just had green add to cart) at least two weeks ago now. Even talked to Negri today and the guy said he didn't even want to try and estimate when they'd have more in stock.
    Can you tell me when you ordered? Thanks!
    05-02-2014 10:39 PM
  19. daniel187's Avatar
    No way! I've had an order in since before it said back ordered (just had green add to cart) at least two weeks ago now. Even talked to Negri today and the guy said he didn't even want to try and estimate when they'd have more in stock.
    Can you tell me when you ordered? Thanks!
    April 14, and ya same thing was in stock the time i ordered and then wwnt on backorder a few days later. Got this today
    "
    At this time we're contacting in regards to your order. Your order has been processed and is set to ship out later today. Upon your approval we will proceed with this shipment. Please review and advise how you would like to proceed. We look forward to hearing from you. Have a great day.
    ".
    Replied back kinda late though so probably not till monday now.
    05-02-2014 11:51 PM
  20. kwill's Avatar
    April 14, and ya same thing was in stock the time i ordered and then wwnt on backorder a few days later. Got this today
    "
    At this time we're contacting in regards to your order. Your order has been processed and is set to ship out later today. Upon your approval we will proceed with this shipment. Please review and advise how you would like to proceed. We look forward to hearing from you. Have a great day.
    ".
    Replied back kinda late though so probably not till monday now.
    Nice! Yeah, just checked and my order was placed on April 18th. Good thing you're at least getting a hold of one. Definitely keep us updated on progress.
    05-03-2014 12:23 AM
  21. dclaryjr's Avatar
    I'm getting desperate -- I have a friend who lives in Nicaragua checking local stores. :-)


    Dave Clary/Corpus Christi, TX
    05-03-2014 12:34 AM
  22. hasasimo's Avatar
    This thing has taken everything I can throw at it today. About 30 mins of video streaming (via carrier network, not Wifi), 60 minutes of calls on speaker phone, about 30 minutes of web browsing, texts, WhatsApp, plenty of social media use intermittently all day long (mostly People Hub). Took it off my wireless charging stand at 9 a.m., it's now half passed midnight and I still have 47% left . I would have had to fully charge my 920 somewhere in between at least once to get this much out of it, and I consider it to have pretty decent battery life.
    TheBadGuy_88 likes this.
    05-03-2014 12:35 AM
  23. daniel187's Avatar
    Nice! Yeah, just checked and my order was placed on April 18th. Good thing you're at least getting a hold of one. Definitely keep us updated on progress.
    And just got tracking email from FedEx, estimated delivery on the 8th =)
    05-03-2014 01:26 AM
  24. christenmartin's Avatar
    This thing has taken everything I can throw at it today. About 30 mins of video streaming (via carrier network, not Wifi), 60 minutes of calls on speaker phone, about 30 minutes of web browsing, texts, WhatsApp, plenty of social media use intermittently all day long (mostly People Hub). Took it off my wireless charging stand at 9 a.m., it's now half passed midnight and I still have 47% left . I would have had to fully charge my 920 somewhere in between at least once to get this much out of it, and I consider it to have pretty decent battery life.
    Ya my 1520 was a bit erratic for about a week end a half. Now everything has settled and works like a charm. Battery life is awesome. I can go a solid 2 days . It holds up really well to video games. Games would kick my 920s ***. With this big bright screen I thought the battery would be suspect. Not the case.
    05-03-2014 10:08 AM
  25. dclaryjr's Avatar
    Checking Negri once an hour. Don't want any stock sneaking by me.


    Dave Clary/Corpus Christi, TX
    05-03-2014 11:52 AM
1,509 ... 2122232425 ...

Similar Threads

  1. Black update for Rogers Nokia Lumia 520 due March 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 07:18 PM
  2. CamScanner and Car Dash pick up new features and more in latest updates
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 07:18 PM
  3. Nokia Lumia 625 heading to Three in Ireland later this month
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 07:18 PM
  4. Lumia 521 deal?
    By shaskell724 in forum Nokia Lumia 521
    Replies: 2
    Last Post: 03-08-2014, 11:49 AM
  5. Replies: 2
    Last Post: 03-07-2014, 06:42 AM
LINK TO POST COPIED TO CLIPBOARD