03-04-2015 11:11 AM
1,509 ... 3940414243 ...
tools
  1. weatheryoko's Avatar
    Funny! I am not worried though.

    So, what is hands down the best case for this bad boy?
    I ended up getting 2 (not sure which one I'll use yet):

    Case #1: http://www.amazon.com/gp/product/B00...pUvbUpU2576234

    Seems like a really good case; however, the JKase's silicone was a little too firm for my liking (I wanted a soft silicone inner shell to max drop protection, so I ordered a second case (which hasn't arrived yet).

    Case #2: Amzer Double Layer Hybrid Case with Kickstand - Black/ Black

    I'll test drive both and see which I like best... I also purchased a Qi Wireless charger for my car. I haven't test that yet either (my phone should arrive sometime today), but I'll post my thoughts on that as well. Trying to find a car mount that supports a 1520 + case has been a little challenging.

    Cheers,
    Justin
    Booston likes this.
    06-05-2014 10:32 AM
  2. dclaryjr's Avatar
    I also purchased a Qi Wireless charger for my car.
    Which? Where?


    Dave Clary/Corpus Christi, TX
    06-05-2014 11:05 AM
  3. weatheryoko's Avatar
    From Amazon.com

    This one:
    Amazon.com: YIPIN C1-Vehicular QI Standard Wireless Charger Transmitter: Cell Phones & Accessories

    Again, I haven't tested it yet so YMMV.

    Cheers,
    Justin
    06-05-2014 11:08 AM
  4. dclaryjr's Avatar
    Thanks. This looks like an interesting model in the same price range.

    http://www.amazon.com/UPGRADED-Wirel...pUvbUpU2576331

    I got my charging pad from them, and it works fine with with my Nexus 7.


    Dave Clary/Corpus Christi, TX
    06-05-2014 11:29 AM
  5. weatheryoko's Avatar
    I looked at that one, but from what I remember of my research, that holder wasn't wide enough for the 1520 with a case. If you buy it and it works, please let me know.

    Cheers,
    Justin
    06-05-2014 11:49 AM
  6. dclaryjr's Avatar
    I fired off an email to the seller to see if I can get a width on it. I'll post the reply.


    Dave Clary/Corpus Christi, TX
    06-05-2014 11:55 AM
  7. TechoGeek's Avatar
    Well, eight days after placing my order for 2nd day air service, it's out for delivery. NewEgg, you need to have a conversation with Jeff Bezos about delivery.


    Dave Clary/Corpus Christi, TX
    Newegg is one of those companies I order from when I need something in a hurry because their stages of processing and shipping orders are usually like clockwork. I'm surprised they couldn't handle the rush of orders for this baby. At least you'll get it in time for a fun weekend.

    It was a slow night at work so I managed to put some hours on the phone. Physically the phone arrived pristine, no dead pixels, light bleed, sensitivity issues or loose buttons. The only problem I ran into was entering my wifi password. I believe there is a time limit for entering your password. My passkey is 61 characters long so every time I would get to about 75% completion it would try to connect. I'm on AT&T unlimited data and internet sharing is working, the keyboard hack was the very first thing I did after initial setup. I was surprised when I opened internet explorer to be greeted by the news about the Microsoft store credit, I had totally forgotten about that.

    Sent from my Nexus 7 using Tapatalk
    06-05-2014 12:14 PM
  8. Bruce Carroll's Avatar
    I have a better story.

    Was supposed to be delivered Tuesday night via UPS. I had to leave house for 15 minutes. Supposedly they attempted delivery then, but I saw NO evidence that they were there (no sticker on door).

    Wed morning, I work remotely because they will try again today. At like 10:30 I see there is a UPS error and that it won't be delivered today. Who knows. Apparently it didn't make it on the truck for some reason.

    I call UPS and ask if I can go pick it up. You can pick it up after 9PM because that's what then truck will get back. But .. but .. its not on the truck. They check. You're right. You can pick it up anytime.

    I drive to UPS around 2:30PM. They look for my package and they tell me that it is in some "retainer box" and that they don't have staff on hand to go find it for me. Huh? They just told me it was available. He says that corporate doesn't always know what is happening at the local offices. How the hell did it get some "retainer box" to start with?

    I go home, call UPS again. They have someone locally call me back and tell me that they have the package in their office and that the guys up front didn't even check. Now, I am really getting pissed. I drive back to UPS, this time getting closer to rush hour traffic. I finally get my phone which it takes them 15 minutes or so to find.

    Man. My opinion of UPS has dropped a lot.

    I went to the AT&T store, got a new nano-SIM. Phone worked immediately. I tried to get tethering working while there since I am on the 10GB shared plan. They couldnt. They said it was because it was not an AT&T phone. I was like, huh? What does that matter, its an AT&T SIM. Thats all that should matter.

    Bummer. Went home and did the Spanish keyboard trick. Easy cheesy, I can tether.

    PS - Nokia 900 QI charger I bought off EBay arrived. Works like a charm.
    06-05-2014 12:32 PM
  9. dclaryjr's Avatar
    -I've used them in the past without problem--I don't know what happened this time around.

    -I'm on T-Moblile with unlimited data as well. I'm on my iPad at work all day and I use the hotspot on my Note II for that, so getting the sharing to work is important to me. Keyboard hack is priority!! :-)

    -61 characters??!! Wow. Sounds like you'll be pretty safe from hacking.

    -I have one kid guarding the door, and I ain't going anywhere once I get home. No missed delivery for me!
    06-05-2014 12:46 PM
  10. flameinthefire's Avatar
    Does anyone else has this ?
    Bug: Navigating through native videos, causes loud noise from speaker.
    06-05-2014 01:21 PM
  11. sketchy9's Avatar
    Well, I put my order in on 6/2 for the yellow one on Newegg. First they said it would be delivered by the end of this week. Then they contacted me and said it was delayed one week. They just sent me an email saying that they're out of stock and that they'll be refunding my money :-( Oh well, after the 3D touch announcement maybe I'll just wait until winter and get one of those.
    06-05-2014 04:53 PM
  12. ezeuzo1's Avatar
    Does anyone else has this ?
    Bug: Navigating through native videos, causes loud noise from speaker.
    What do you mean by navigating through native video? Just watching a native video? Trying to skip ahead in said video?
    06-05-2014 05:08 PM
  13. dclaryjr's Avatar
    The Unicorn has landed!


    Dave Clary/Corpus Christi, TX
    JTDraper and DAWgEAR like this.
    06-05-2014 07:30 PM
  14. theefman's Avatar
    Does anyone else has this ?
    Bug: Navigating through native videos, causes loud noise from speaker.
    Yes, have this on mine using the video app to watch a purchased movie.
    06-05-2014 07:31 PM
  15. JTDraper's Avatar
    I'm having the exact same problem, also on AT&T. Curious: Did you cut your previous SIM or did you get a new nano SIM? I bought a cutter but couldn't wait, so I went to an AT&T store and asked for a nano SIM with the IMEI from my Lumia 920. She was happy to oblige.

    However, with that SIM, I had to use the keyboard trick to get wireless tethering. I should get it; I pay for it. I called AT&T and they tried to enable it remotely, but no-go. So I had to use Nokia Recovery software to flash 8.0 back onto the phone, do the trick, then re-upgrade. Obviously, this set-up precludes ever doing a complete reset. Any ideas on this?

    I'm thinking about calling AT&T and asking them to re-activate my previous SIM that's still in my 920. Can they do that? If so, I'll cut the SIM, put it in the 1520 and see if that affects these 3 bugs:

    1) No tethering without the 'keyboard trick,' even when you pay for tethering.

    2) Date reverts to 5/21/2014 whenever you do a hard reset or use the 'Automatic' date setting.

    3) No LTE, when activated on an AT&T nano-SIM, using the phone's actual IMEI.

    -- JTD
    06-05-2014 07:36 PM
  16. ezeuzo1's Avatar
    The Unicorn has landed!


    Dave Clary/Corpus Christi, TX
    Congrats
    06-05-2014 07:49 PM
  17. infinitelurker's Avatar
    Here is a weird thing: I'm on AT&T with an grandfathered unlimited plan, and have never been able to use tethering before. It hasn't been a huge need for me previously, so I wasn't thinking to try the keyboard trick before upgrading to 8.1. Well, just for giggles I tried tethering on my 1520.3 without trying any tricks, and it just worked. Odd.
    06-05-2014 07:53 PM
  18. flameinthefire's Avatar
    Yes, have this on mine using the video app to watch a purchased movie.
    Glad i'm not the only one. Hopefully this is resolved soon because its very annoying
    06-05-2014 07:55 PM
  19. JTDraper's Avatar
    Here is a weird thing: I'm on AT&T with an grandfathered unlimited plan, and have never been able to use tethering before. It hasn't been a huge need for me previously, so I wasn't thinking to try the keyboard trick before upgrading to 8.1. Well, just for giggles I tried tethering on my 1520.3 without trying any tricks, and it just worked. Odd.
    Did you get a new nano-SIM card from AT&T, or just cut the old one?

    -- JTD
    06-05-2014 08:29 PM
  20. infinitelurker's Avatar
    I went to an AT&T store and got a new nano-SIM.
    06-05-2014 09:01 PM
  21. dclaryjr's Avatar
    Ok, need a little help folks. I'm on T-Mobile and when I turn on internet sharing, it says I don't have it on my plan (but I do). I went to settings and the Spanish keyboard is already installed. Do I need to remove it and then reinstall to get the sharing working?
    BTW, I ran a speed test on WiFi. Even though I have 50mbps download from my provider, my Note II never showed over 30. This thing pegged at 50! I don't get great reception at the house but I still managed a 10mbps download. Need to go down the road later and check out LTE speeds.

    DUH! The Mexico keyboard is installed..downloading Spain now. :-)
    Last edited by dclaryjr; 06-05-2014 at 09:24 PM.
    06-05-2014 09:13 PM
  22. dclaryjr's Avatar
    Internet sharing engaged....it's Cortana time! Here goes...
    TechoGeek likes this.
    06-05-2014 09:59 PM
  23. dclaryjr's Avatar
    Hmmm. When I run Preview for Developers, it tells me I must be a registered developer and then closes. What's the trick to this??
    06-05-2014 10:29 PM
  24. WanderingTraveler's Avatar
    Hmmm. When I run Preview for Developers, it tells me I must be a registered developer and then closes. What's the trick to this??
    Reinstall, then make sure you're registered at the Windows Phone App Studio.
    dclaryjr likes this.
    06-05-2014 10:45 PM
  25. dclaryjr's Avatar
    Reinstall, then make sure you're registered at the Windows Phone App Studio.
    Thanks...it's downloading now.


    Dave Clary/Corpus Christi, TX
    06-05-2014 11:48 PM
1,509 ... 3940414243 ...

Similar Threads

  1. Black update for Rogers Nokia Lumia 520 due March 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 07:18 PM
  2. CamScanner and Car Dash pick up new features and more in latest updates
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 07:18 PM
  3. Nokia Lumia 625 heading to Three in Ireland later this month
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 07:18 PM
  4. Lumia 521 deal?
    By shaskell724 in forum Nokia Lumia 521
    Replies: 2
    Last Post: 03-08-2014, 11:49 AM
  5. Replies: 2
    Last Post: 03-07-2014, 06:42 AM
LINK TO POST COPIED TO CLIPBOARD