11-16-2017 02:27 AM
27 12
tools
  1. enigmasi's Avatar
    if someone still needs answer or others also may consider my answer. I use 1520 and it didn't connect as AC, but when I gave different SSID for AC and N then I was able to connect AC.
    04-27-2016 07:09 AM
  2. kendrion's Avatar
    A Google search brought me to this thread because I too have been having issues connecting my 1520 to the 5GHz band on my new 11ac capable router - a Fritz!Box 7490.

    Even connecting to the 2.4GHZ was unreliable - failed connection attempts outnumbered the successful by a ratio of around 5:1. Even the successful connections would often drop out after mere seconds.

    I tried the various suggestions presented in this thread - all but one with a rather frustrating lack of success. Grrrrrr....

    The final thing I attempted was to do as dravik suggested in his post of 04-20-2015; and that was to configure the router to use lower channels. Although he was speaking of the 5GHz band, I applied the change to both the 2.4GHz and 5GHz bands.

    Lo and Behold!!! All my problems were solved. It has been a week since I made that simplest of changes on my router and the 1520 is now connecting, and re-connecting automatically, absolutely, perfectly, reliably to the 5GHz band every time it comes into range.
    11-16-2017 02:27 AM
27 12

Similar Threads

  1. Replies: 2
    Last Post: 04-01-2014, 12:44 AM
  2. Fix for wake issue not working
    By Marc_With_a_C in forum Microsoft Surface 2
    Replies: 12
    Last Post: 03-21-2014, 08:50 AM
  3. Nokia Lumia 720 with gdr3 black
    By Aashish13 in forum Nokia Lumia 720
    Replies: 5
    Last Post: 03-14-2014, 07:20 AM
  4. Lumia 520 won't sync with Gmail
    By lathamc in forum Windows Phone 8
    Replies: 0
    Last Post: 03-13-2014, 03:34 PM
  5. Lumia Black now available for the Lumia 620 in India
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-13-2014, 03:15 PM
LINK TO POST COPIED TO CLIPBOARD