10-09-2014 02:54 PM
27 12
tools
  1. Exoma's Avatar
    So, I bought an RM-937 1520. I live in Canada so Fido (my provider) allows me 2600 Mhz LTE on my phone. I'm just wondering if 4G means LTE on this phone?

    The phone's signal goes in this order from what Ive noticed.

    E (Edge?)
    3G
    H+ (HSPA+?)
    4G (LTE?)

    Am I getting LTE?
    04-26-2014 06:49 PM
  2. GabrielStorm's Avatar
    So, I bought an RM-937 1520. I live in Canada so Fido (my provider) allows me 2600 Mhz LTE on my phone. I'm just wondering if 4G means LTE on this phone?

    The phone's signal goes in this order from what Ive noticed.

    E (Edge?)
    3G
    H+ (HSPA+?)
    4G (LTE?)

    Am I getting LTE?
    doubt it. I believe 4G means just that and LTE means LTE.
    unlike the US where at&t can call their HSDPA 4G when it's really just 3.5-3.7G
    04-26-2014 07:09 PM
  3. JamesJinSC's Avatar
    Mine says LTE when I am on LTE
    04-26-2014 07:52 PM
  4. Exoma's Avatar
    You have an RM-937?

    Posted via Windows Phone Central App
    04-26-2014 08:10 PM
  5. multo's Avatar
    the international version doesn't show the icon LTE on the status bar. for us users of RM-937 the 4G icon is the equivalent of the LTE icon
    rdubmu likes this.
    04-26-2014 08:45 PM
  6. rdubmu's Avatar
    What speeds are u seeing?


    Sent from my iPhone using Tapatalk
    04-26-2014 08:46 PM
  7. hasasimo's Avatar
    the international version doesn't show the icon LTE on the status bar. for us users of RM-937 the 4G icon is the equivalent of the LTE icon
    Interesting. Does the RM-938 do the same thing?
    04-26-2014 09:27 PM
  8. taphius's Avatar
    My 938 shows lte
    hasasimo likes this.
    04-26-2014 09:32 PM
  9. multo's Avatar
    Interesting. Does the RM-938 do the same thing?
    Don't have an rm-938 to test. Sorry. Perhaps the owners could chime in
    hasasimo likes this.
    04-26-2014 09:50 PM
  10. Exoma's Avatar
    Yeah, that's what I thought...

    Makes sense considering there is also a H+ logo for HSPA +

    Posted via Windows Phone Central App
    04-26-2014 09:53 PM
  11. Geddeeee's Avatar
    4G is the same thing as LTE... It's usually called 4G in Europe.
    04-30-2014 06:33 AM
  12. foxbat121's Avatar
    4G is a term that is most confusing. It largely depends which country you are in and which carrier you are using.

    Install my app: Battery Stats | Windows Phone Apps+Games Store (United States) and it will tell you exactly what network you are currently on.
    04-30-2014 08:11 AM
  13. oditius's Avatar
    doubt it. I believe 4G means just that and LTE means LTE.
    unlike the US where at&t can call their HSDPA 4G when it's really just 3.5-3.7G
    I live in Chicagoland should have LTE, but all I see is 4G.... I never saw LTE...
    04-30-2014 08:12 AM
  14. foxbat121's Avatar
    If you are on AT&T and using an AT&T branded phone, you should see 4G when you are on HSPA+. And LTE (or 4G LTE on some phones) when you are on LTE. Please note that currently there is no voice over LTE yet. So, anytime you are on a call, your network will drop back to HSPA+.
    oditius likes this.
    04-30-2014 08:15 AM
  15. oditius's Avatar
    Now the question is, Is it AT&T or my phone? That I must figure out. I could call AT&T, and see what they say...
    04-30-2014 08:23 AM
  16. foxbat121's Avatar
    Now the question is, Is it AT&T or my phone? That I must figure out. I could call AT&T, and see what they say...
    Did your old phones before 1520 ever get LTE service? The reason I'm asking is that your data plan on your account must be marked as LTE in order to get LTE service from AT&T. You only need do that once. If you have never gotten any LTE phones before, you need ask AT&T to make sure your data plan is properly provisioned for LTE.
    04-30-2014 09:03 AM
  17. xandros9's Avatar
    By the looks of it, I think OP is getting LTE.

    I have an AT&T Lumia 920 which has LTE capabilities. However, it has a French ROM onboard.

    It goes like this
    E or 2G (I can't remember)
    H
    H+
    4G (which Insider confirmed as LTE)

    In the US, H+ is technically 3/3.5G and was marketed as 4G in the US. Hence the iPhone 4S's amusing "upgrade" to 4G in one iOS update.

    But I confirmed my 920 was getting LTE when it said 4G. I'm assuming the LTE specific indicator is something US specific.
    Last edited by xandros9; 04-30-2014 at 10:55 AM.
    04-30-2014 10:44 AM
  18. oditius's Avatar
    Did your old phones before 1520 ever get LTE service? The reason I'm asking is that your data plan on your account must be marked as LTE in order to get LTE service from AT&T. You only need do that once. If you have never gotten any LTE phones before, you need ask AT&T to make sure your data plan is properly provisioned for LTE.
    I did a chat with AT&T, I had used a dumbphone with my account for a couple months to save for a new phone. I cut it down to fit. They said my Sim isn't provisioned for LTE and they are going to send me a new one Priority Mail.

    UPDATE: I got the card today, now my phone says LTE... Doesn't really seem faster, but it at least says LTE.. LoL
    Last edited by oditius; 05-01-2014 at 07:31 PM. Reason: Update
    04-30-2014 10:46 AM
  19. mofoliar's Avatar
    Does any versions confirmed to work on verizon lte?
    05-01-2014 07:02 PM
  20. teranceo's Avatar
    Don't have an rm-938 to test. Sorry. Perhaps the owners could chime in
    My RM-938 says LTE. I'm on T-Mobile in the US.
    05-01-2014 07:14 PM
  21. drbanks's Avatar
    Confusing, isn't it? For HSPA+, my 940 says 4G, but my 938 says H+. But both say LTE for LTE.
    05-01-2014 08:46 PM
  22. francis85's Avatar
    I have a 1520.3 (RM-938) and I get ~85 Mbps Down, 14 Mbps Up with Fido in downtown Montreal.
    05-01-2014 09:21 PM
  23. foxbat121's Avatar
    Does any versions confirmed to work on verizon lte?
    Unless your phone has Verizon names on it, it won't work. Verizon never lets any non-Verizon phone on its network.
    05-02-2014 07:11 AM
  24. mofoliar's Avatar
    Damn Verizon... i loved my 1520 i had on Att now on verizon...
    05-02-2014 10:45 AM
  25. phelme's Avatar
    Ran across this thread. I'm on T-Mobile (U.S.), 1520.3 (RM-938) on the latest Dev Preview, whatever it is this week. ;)

    I've noticed under "Highest Speed Settings " in the SIM options, the highest I can select is 4G, LTE isn't even available. Any thoughts on why that might be? SIM (it is ancient) not provisioned for that service maybe?
    10-08-2014 02:49 PM
27 12

Similar Threads

  1. "Other" storage on Lumia 925?
    By wpcentralacc in forum Nokia Lumia 925
    Replies: 12
    Last Post: 04-28-2014, 07:17 PM
  2. Purple Light/Tint on Lumia 925 Front Camera
    By wpcentralacc in forum Nokia Lumia 925
    Replies: 2
    Last Post: 04-27-2014, 09:58 AM
  3. How many apps are submitted on the WP Store per day?
    By bionicgt in forum Applications
    Replies: 2
    Last Post: 04-26-2014, 11:01 PM
  4. Its high time Windowsphone OS gets an updated whatsapp app
    By Desmond Okoye in forum Applications
    Replies: 1
    Last Post: 04-26-2014, 08:48 PM
  5. How to get rid of this battery saver bug?
    By RobinPaul in forum Windows Phone 8.1 Preview for Developers
    Replies: 5
    Last Post: 04-26-2014, 06:51 PM
LINK TO POST COPIED TO CLIPBOARD