1. zakariaaladaway's Avatar
    How can i force my network to 3G only because I am in business trip to Sudan the 2G network is stronger so my device ( Lumia 1520 ) always catch it but it is`t working with viper,Skype, Facebook and etc.
    04-29-2014 04:14 AM
  2. N_LaRUE's Avatar
    There's no way to force a 3G connection as far as I know. You can only set a 'highest connection speed'.

    I think the reason for this is so if you go into a slower area you'll still have a connection regardless.
    04-29-2014 04:38 AM
  3. Rasahi's Avatar
    If you are still on WP8.0 follow below link. If you already upgrade to WP 8.1 please ignore it.
    http://forums.windowscentral.com/win...-64bit-os.html

    Sent from my Lumia 1520 using Tapatalk
    04-29-2014 04:47 AM
  4. crav4speed's Avatar
    Try ##3282# from the dialer > settings > network type > 3G only

    This is field test mode and it works on my AT&T 1520. It should work on the international version but I'm not sure.
    Sparkythedog93 likes this.
    04-30-2014 08:57 AM
  5. Rasahi's Avatar
    Try ##3282# from the dialer > settings > network type > 3G only

    This is field test mode and it works on my AT&T 1520. It should work on the international version but I'm not sure.



    It doesn't works with International version.





    Sent from my Lumia 1520 using Tapatalk
    05-01-2014 03:34 PM

Similar Threads

  1. Network+ update issue
    By i_Neel in forum Nokia Lumia 1320
    Replies: 2
    Last Post: 05-05-2014, 02:03 AM
  2. ANYCHANGES to other storage attachment, separate network and pdf attachment in wp 8.1
    By lum5 in forum Windows Phone 8.1 Preview for Developers
    Replies: 11
    Last Post: 04-27-2014, 01:13 PM
  3. Internet explorer not working via mobile network on lumia 520 (winodws phone 8.1 dev preview)
    By Collins_sang in forum Windows Phone 8.1 Preview for Developers
    Replies: 14
    Last Post: 04-26-2014, 11:52 PM
  4. Replies: 1
    Last Post: 04-25-2014, 04:44 AM
LINK TO POST COPIED TO CLIPBOARD