1. linking1990's Avatar
    Hello,
    I am finding a new issue on my Lumia 1520 after the 8.1 update of some of the heavy games (Modern Combat, N.O.V.A 3, etc..) having frame drops and lagging while playing.

    The thing is when I do a soft reset, and run any of those games it gets back to normal, but then when I run them some other times I don't know what happens, they lag, and I can't figure out what is causing this!

    BTW I never have anything running in the background, I close every app I use, and I limited the apps running in the background to the ones I need only.

    Any thoughts on this?
    Himanshu Chowdhary likes this.
    05-05-2014 05:42 AM
  2. Himanshu Chowdhary's Avatar
    I dont play games but I have noticed lag while playing asphalt 8 on my Lumia 920(wp8.1 dev preview ). I managed to solve it by disabling nfc,Bluetooth,WiFi and data connection.
    Guytronic likes this.
    05-05-2014 05:48 AM
  3. KrisJoeEll's Avatar
    Asphalt 8 & Nova 3 runs fine on my device even with data connection on. So is there any chance you might have installed your games in a slower SD card? (Below class 10)
    05-05-2014 05:52 AM
  4. linking1990's Avatar
    Asphalt 8 & Nova 3 runs fine on my device even with data connection on. So is there any chance you might have installed your games in a slower SD card? (Below class 10)
    I don't use an SD card at all, and I don't even have Cortana enabled.
    05-05-2014 05:58 AM
  5. linking1990's Avatar
    I dont play games but I have noticed lag while playing asphalt 8 on my Lumia 920(wp8.1 dev preview ). I managed to solve it by disabling nfc,Bluetooth,WiFi and data connection.
    I tried putting my phone to airplane mode, and I even turned the battery saver on, still lagging, now if I do a soft reset it will get back to normal. This is just killing me!
    05-05-2014 06:22 AM
  6. linking1990's Avatar
    Anyone else with any thoughts?
    05-05-2014 03:33 PM
  7. linking1990's Avatar
    Still no one? :(
    05-06-2014 12:15 PM
  8. unknow91's Avatar
    You're not alone dude! First I thought it was the SD Card (Sandisk Class 10) but Asphalt 8 was installed on the device and not the card! My bet? Firmware or some weird thing happening in the OS
    05-06-2014 04:52 PM
  9. linking1990's Avatar
    You're not alone dude! First I thought it was the SD Card (Sandisk Class 10) but Asphalt 8 was installed on the device and not the card! My bet? Firmware or some weird thing happening in the OS
    Well, it's good to know that I am not alone, though it isn't good by any means. I was afraid that I had a hardware failure of some kind.

    Is there anyone else with similar issues ?
    05-08-2014 04:06 AM
  10. Ichigo's Avatar
    I got the same issue. hates it.
    05-09-2014 09:53 AM
  11. Himanshu Chowdhary's Avatar
    so I was playing asphalt 8 today during class time , I locked my phone after 10-25 min I unlocked my phone and the game was having frame drop issues , I tried it with other games and YES I have this issue :sad:
    05-09-2014 10:21 AM
  12. linking1990's Avatar
    so I was playing asphalt 8 today during class time , I locked my phone after 10-25 min I unlocked my phone and the game was having frame drop issues , I tried it with other games and YES I have this issue :sad:
    You never know when it's gonna happen or why, I am hoping that someone up there acknowledged the existence of this issue, or we are screwd.
    05-10-2014 11:42 AM
  13. Ahmed El Hefnawy's Avatar
    Same here ... Some times I reset my phone the times a day! 😒
    05-10-2014 06:51 PM
  14. Lloydbm4's Avatar
    Hello,
    I am finding a new issue on my Lumia 1520 after the 8.1 update of some of the heavy games (Modern Combat, N.O.V.A 3, etc..) having frame drops and lagging while playing.

    The thing is when I do a soft reset, and run any of those games it gets back to normal, but then when I run them some other times I don't know what happens, they lag, and I can't figure out what is causing this!

    BTW I never have anything running in the background, I close every app I use, and I limited the apps running in the background to the ones I need only.

    Any thoughts on this?
    You are running a Beta update, you know? Kernel and firmware will be updated again before carriers roll out their updates. You'll have to make do until then. And yes, I'm running 8.1 and have the same issues (and I use a Moga Power Pro controller connected via BT to play Asphalt 8.)
    05-11-2014 01:44 AM
  15. linking1990's Avatar
    You are running a Beta update, you know? Kernel and firmware will be updated again before carriers roll out their updates. You'll have to make do until then. And yes, I'm running 8.1 and have the same issues (and I use a Moga Power Pro controller connected via BT to play Asphalt 8.)
    Yes, I understand we aren't running a final version of the software, but such things need to be documented, as the final version of software could ship without this being fixed. So I guess it's important to report these issues so they can fix them.
    Ahmed El Hefnawy likes this.
    05-11-2014 06:31 AM
  16. Lloydbm4's Avatar
    Yes, I understand we aren't running a final version of the software, but such things need to be documented, as the final version of software could ship without this being fixed. So I guess it's important to report these issues so they can fix them.
    Gameloft may also be the culprit. They only recently got the 8.1 SDK, so they may be able to clear up some of the issues as well from their end.
    05-11-2014 12:06 PM
  17. linking1990's Avatar
    Gameloft may also be the culprit. They only recently got the 8.1 SDK, so they may be able to clear up some of the issues as well from their end.
    No it's not Gameloft, as this happens in multiple games too, like Angry Birds Go for instance. Also, it happens outside of games as well: (try this when your games are lagging) go to your start screen, pull down the notifications hub and keep holding the colored end of it, now while holding it swipe up and down fast for 10 secs, it should appear lagging as well. Of course this only happens when my games start to lag, not always.
    05-11-2014 01:16 PM
  18. Ahmed El Hefnawy's Avatar
    I think I found the main cause for this problem.

    I turned off background tasks for my battery apps like Battery and Battery performance two days ago (Yes I was using both of them at the same time).

    I didn't face the frame dropping problem anymore.
    05-12-2014 03:28 PM
  19. Ahmad Barakji's Avatar
    I made a thread about this a while back.
    http://forums.windowscentral.com/win...p-wp8-1-a.html

    The drivers need updating for the Snapdragon 800 chipset.
    Wait for the Lumia Cyan update in June.
    05-14-2014 06:45 AM

Similar Threads

  1. How many fans in SP2
    By Gwenddoleu in forum Microsoft Surface Pro 2
    Replies: 4
    Last Post: 05-06-2014, 10:02 PM
  2. Which game is it??
    By instantk in forum Windows Phone Games
    Replies: 2
    Last Post: 05-05-2014, 09:25 AM
  3. Nokia invests $100 million to further advance connected technologies in automobiles
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-05-2014, 04:11 AM
  4. Pawn Stars The Game
    By SatanWantYou in forum Windows Phone Games
    Replies: 3
    Last Post: 05-05-2014, 03:13 AM
LINK TO POST COPIED TO CLIPBOARD