1. Glenn Jenkins's Avatar
    I know that there have been several posts about the white dots on the 1520, but I wanted to get some advice/opinions about my particular situation.

    I bought the 1520 from Amazon and everything was great. Had been using the phone since the end of March with absolutely zero issues. Unfortunately on April 27, the 1520 jumped from my hand and landed on the concrete driveway at my home. Needless to say, the screen cracked in the lower right corner with a longer crack across the entire screen. However, everything still worked great. No other damage. I contacted Nokia and they advised to send it to Palco for repair. The phone was received at Palco on May 1st and I received it back on May 9th. Only 8 days, not too bad. Used a Lumia 520 in the meantime.

    I opened the package from Palco and the new screen looked perfect! Palco did a great job. However, upon powering it up, the AT&T logo appeared and there they were. The infamous two bright white spots on the screen. These had not been there before and were not even there after the drop. Based on what I have read, there is a good chance that these can appear when pressure is put on the screen. They may be caused by the internal vibrator or the way the phone is designed. However, what frustrates me is that these were not there before the repair. My guess is that the pressure/repair process created the issue.

    Now, here is the question for you guys, do I send it back to Palco? Palco has said that they will investigate and if the problem is related to their repair, they will correct it for no charge. If they determine that it is not repair related, then they will give me an estimate and I can pay or decide not to repair and only pay a $15 diagnostic fee. Ideally, they will correct it for no charge, but I have a feeling they are going to say that they repaired it correctly or that it was fine when they shipped it to me. I already spent $200 on the screen replacement and $600 on the phone originally. So I really don't want to spend more on this phone.

    Regardless of the repair in the first place, it seems that these white spots are a common problem with the 1520 so maybe I should just live with it? I could also sell it and just by another new one? I could send it to Palco and hope for the best? Any other suggestions?

    Thanks.
    05-15-2014 11:04 AM
  2. Himanshu Chowdhary's Avatar
    Hey welcome to WPCentral forums
    You should send your device back to Palco service centre , just inform /remind them that I was not having such issues with my previous display. They must have applied pressure which created these white spots.
    Guytronic likes this.
    05-15-2014 11:34 AM
  3. hasasimo's Avatar
    Well that sucks. I'd send it back to Palco and just take it from there. Don't worry too much about contingencies thereafter yet. Hopefully they repair it.

    I didn't know the vibration motor can cause this too. Do you think it may be safer to keep haptic feedback turned off to help avoid this issue appearing in the future?
    05-15-2014 12:32 PM
  4. Glenn Jenkins's Avatar
    Thanks for the comments. I think that I will pack it up and send it back to Palco. They have been very responsive via e-mail already. I even sent them some screen shots of the device. Since they are Nokia's authorized service center, I'm sure that they are aware of this issue with the 1520.

    I don't know about turning off haptic feedback. I would like to think that this would not be an issue. However, I can say that the dots/spots have to go! They are so bright and catch my eyes constantly.
    Himanshu Chowdhary likes this.
    05-15-2014 12:46 PM

Similar Threads

  1. ATIV S and boy do I need help
    By Travelled1 in forum Samsung ATIV S
    Replies: 16
    Last Post: 05-19-2014, 05:54 PM
  2. Microsoft hopes BYOD will help bolster Windows Phone in enterprise
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-15-2014, 11:00 AM
  3. Microsoft Research has a Windows Phone 'Urban Air' app to help monitor smog level in China
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-15-2014, 10:11 AM
  4. HELP!! issues after recent update of wp 8.1 dev preview
    By abhishek singh21 in forum Windows Phone 8.1
    Replies: 6
    Last Post: 05-15-2014, 05:15 AM
  5. help with app deployment
    By abdullah abu alasal in forum Nokia Lumia 520
    Replies: 1
    Last Post: 05-15-2014, 04:31 AM
LINK TO POST COPIED TO CLIPBOARD