1. RAP66's Avatar
    Hi there,

    I just completed the Qi charge mod to my 1520. The charge mod does work, however the charger does drop off... Also I've noticed that the charge mod does not work through cases. Is anyone experiencing this? Is it possible I messed up?

    I followed the 9 page Qi thread

    Thanks

    Rich
    Deadbluesky666 likes this.
    06-05-2014 02:03 PM
  2. Deadbluesky666's Avatar
    Well i got the same problem my case is too big i have a Amzer hybrid case for my 1520 (RM-938) and when i put my phone on the wireless charger the DT-900 the phone detect it but it drain my battery completely instead of charging, its happen 2 time i get late to work because of this, i need to get the phone out of the case, and the charge is not the same if i charge my phone with the wire, wirelessly it do not stay charged longer !!! With my Lumia 920 everything work fine, so i dont think it is the DT-900 the problem but the phone maybe the battery is too big !!!
    07-04-2014 11:43 AM
  3. soul347's Avatar
    I am using the RM937 with built in QI charging, and even when my phone has a thick flip case on, the phone still charges consistently.
    07-04-2014 01:57 PM
  4. NoRomBasic's Avatar
    In general I've had no problems with DT-900 chargers. I had a Maxell dual QI pad that simply would not link up under any circumstances (even though it will charge an 822 and a 1020 with no issues) so I let my Wife take it to work for her 1020.

    Placement on a DT-900 is a little fussy, but not exceptionally so. Once it is fully charged it will cycle on/off periodically on it's own (MS would have my undying gratitude if I could silence "just" the charger notification sound while leaving everything else on, and that is not just for the 1520, but for all the QI-enabled Lumias) but spontaneous drop-offs are very, very rare and usually always the result of not being placed quite-right on the DT-900.

    The cases I've been using have generally caused no interference, but they are pretty thin.
    07-04-2014 04:23 PM
  5. Deadbluesky666's Avatar
    Well i figure it out, the Qi on my 920 is on the center of the back cover and on my 1520 is at the bottom, now it work good !!! Thanks NoRomBasic
    07-15-2014 06:24 PM
  6. NoRomBasic's Avatar
    Glad it's working for you.

    I actually ended up placing the coil a bit higher/more centered on my 1520 for that very reason, but even then it is a bit of a trade-off as the while its a bit easier to rest on the DT-900,it won't "quite" line up with the DT-910 stand. However since all my chargers table-top/flat it's been a bit nicer to have it more centered.
    07-16-2014 09:29 AM

Similar Threads

  1. Replies: 16
    Last Post: 10-04-2014, 10:42 AM
  2. New 1520, orientation change not working in map software only
    By flapadlr_Nok900 in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 06-07-2014, 07:29 AM
  3. Web Video's stopped working 1520 - Still on 8.0
    By jssmarathon in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 06-06-2014, 07:15 AM
  4. 1520 AT&T QI charging
    By spyderzWPC in forum Nokia Lumia 1520
    Replies: 2
    Last Post: 06-05-2014, 11:42 AM
  5. matte yellow 1520 with black TPU Case?
    By jodeltje in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 06-05-2014, 09:31 AM
LINK TO POST COPIED TO CLIPBOARD