• 00Days
  • 00Hours
  • 00Mins
  • 00Secs
Check out the best deals!
  1. pdampier's Avatar
    nokia.png

    I get this error on a regular 32GB RM-940, AT&T branded (I've unlocked it) with SIM present or removed (same with MicroSD).

    Tried the full Nokia Care Suite as well but when I put RM-940 in to search for a ROM it also errors out searching.

    Anyone else seen this?
    07-27-2014 02:59 PM
  2. maclancer's Avatar
    I have the same phone and I used the Nokia software updater for Retail and works like a charm.
    07-27-2014 03:08 PM
  3. pdampier's Avatar
    Same product code? 059V4W9? Can't figure out what is wrong here....
    07-27-2014 03:12 PM
  4. maclancer's Avatar
    Same product code... The Nokia Software Updater for Retail version 4.2.1 will downgrade your phone to version 8.0 stray forward. Then you will be able to upgrade to Cyan.
    07-27-2014 03:25 PM
  5. pdampier's Avatar
    Nokia Software Updater for Retail version 4.2.1? What is the URL for that? I seem to have 1.4.3 from a link on WPCENTRAL, not 4.2.1....
    07-27-2014 03:30 PM
  6. maclancer's Avatar
    07-27-2014 03:36 PM
  7. pdampier's Avatar
    Thanks - ok downloading that. I'll uninstall all the other Nokia stuff, reboot and install that, reboot and then try again shortly... Thx!!
    07-27-2014 03:46 PM
  8. maclancer's Avatar
    Yes, make sure all your current Nokia software are uninstalled. And when you install this one that I sent you. Make sure you run the setup with Admin rights.
    07-27-2014 03:52 PM
  9. pdampier's Avatar
    Same issue... I uninstalled all Nokia software (including Fuse drivers, USB drivers, Nokia apps etc etc), rebooted, installed NSU retail, rebooted, launched NSU Retail, attached phone.... Nothing banged out in device manager:

    nokiaretail.png
    07-27-2014 05:10 PM
  10. maclancer's Avatar
    Something is going on with your phone and is not even under warranty. Your MEID maybe bad as well.
    07-27-2014 06:14 PM
  11. pdampier's Avatar
    How do I find out what the MEID is and if it is bad?

    When I got the phone (from a colleague at work) I contacted AT&T to unlock it and was given an unlock code which worked - I don't think they'd have done that if it was a bad MEID would they?

    And the other odd thing is even with the full Nokia Care Package when I enter RM-940 no packages are found to download for that product. (Phone not even connected then)
    Last edited by pdampier; 07-27-2014 at 07:25 PM.
    07-27-2014 07:09 PM
  12. maclancer's Avatar
    You maybe able to find a solution in this thread about your issue with NSU: http://forums.windowscentral.com/win...l-problem.html
    Last edited by maclancer; 07-29-2014 at 08:57 AM.
    07-27-2014 07:29 PM
  13. MDK22's Avatar
    How do I find out what the MEID is and if it is bad?

    When I got the phone (from a colleague at work) I contacted AT&T to unlock it and was given an unlock code which worked - I don't think they'd have done that if it was a bad MEID would they?

    And the other odd thing is even with the full Nokia Care Package when I enter RM-940 no packages are found to download for that product. (Phone not even connected then)
    FUNNY - I just looked under SETTINGS >> About ...
    my MEID is blank on an AT&T Nokia Lumia 1520.2 (RM-940).
    07-27-2014 07:30 PM
  14. pdampier's Avatar
    Yes same here - MEID is blank under "Settings, About, More"....
    07-27-2014 07:32 PM
  15. MDK22's Avatar
    Just looked up MEID, it's tangent for CDMA networks, not GSM.
    07-27-2014 07:41 PM
  16. pdampier's Avatar
    Tried the tool in post #12 above but same issue (its the 1.4.3 tool I was using before).....
    07-27-2014 07:48 PM
  17. maclancer's Avatar
    FUNNY - I just looked under SETTINGS >> About ...
    my MEID is blank on an AT&T Nokia Lumia 1520.2 (RM-940).
    I have the same phone and yes, noticed that as well... Weird.
    07-28-2014 01:18 AM
  18. pdampier's Avatar
    No one else hitting this problem?
    07-28-2014 09:56 PM
  19. broughshane's Avatar
    Have you tried resetting your phone, before using the Nokia software recovery . my old Lumia 800 had to be reset a few times to get updates.
    07-29-2014 07:10 AM
  20. egold70's Avatar
    The reason for this may be newer firmware on your phone that the one available on the servers
    NSU and recovery tool both show the same with my Lumia 925 since Cyan was installed
    07-29-2014 08:10 AM
  21. pdampier's Avatar
    Firmware is listed as Nokia Black so that shouldn't be newer?
    07-29-2014 11:28 AM
  22. Vinod satre's Avatar
    In india.....same issue with my lumia 920....
    but we can flash with latest firmware.....

    1. download "navifirmplus_3.2" & install
    2. download "NokiaCareSuite5.0.60.1409" & install
    3. open navifirm.....
    4. put your 8 digit product code in top left corner of navifirm window...press enter
    5. download all files of the firmware that matches with your device (eg. RM-920 US)
    please confirm, cyan is launched in your carrier and you should download the latest,
    check on global site of nokia. (For Lumia 920, i've downloaded 1.54 GB)
    6. Copy the downloaded files of firmware from navifirm folder to the safe location first.
    7. copy these files to....
    "C:\ProgramData\Nokia\Packages\Products\RM-821"
    in your case, last folder should be "RM-940"
    you've to create folders of "Products" and "RM-940" manually in the "packages" folder
    it should be same as above path.
    8. Now open the "NokiaCareSuite"
    9. click on "Nokia support tool for store".......prompted for sign in....just click on sign in with option "caresuite external"
    10. go to "File" - "Open product", choose your "RM-940"
    11. It'll detect the firmware you've located. Follow the instruction.
    12. you've to reboot device by pressing "lock key" and "Volume down key"....press long until device shutdown and vibrate....
    13. now click on start.....
    14. do not touch anything until complete installation and your device asked for region.....

    This work for me....on my Lumia 920......
    I was on WP8.1 DP.......Black firmware
    Now I've Cyan firmware....and again i put my device in DP......

    I dont have much time to log in here and explain in briefly,
    but i can understand.....people suffers this thing a lot.....so just want to help you..
    let me know.....
    08-24-2014 11:25 AM

Similar Threads

  1. Viewing websites on Nokia 930 in desktop mode?
    By Unregistered in forum Ask a Question
    Replies: 10
    Last Post: 07-29-2014, 06:45 PM
  2. Problem with lock screen - Nokia Lumia 820
    By rejhan_f in forum Nokia Lumia 820
    Replies: 1
    Last Post: 07-28-2014, 12:21 AM
  3. Need a forum to discuss WPCentral itself
    By Sean David in forum Site Feedback & Help
    Replies: 9
    Last Post: 07-27-2014, 08:05 PM
  4. Update to 8.1
    By DimitrisGrc in forum Ask a Question
    Replies: 2
    Last Post: 07-27-2014, 01:42 PM
LINK TO POST COPIED TO CLIPBOARD