The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
07-31-2016 01:12 PM
98 1234
tools
  1. weisman87's Avatar
    Well my phone is heading back to the Nokia Repair centre today so we'll see what I get back once they have repaired it.
    Let us know how it goes. I clean flashed mine with Cyan and it still fails. Doesn't matter, though, Nokia won't do anything for an RM-938 in the US.
    09-11-2014 09:15 AM
  2. 1st_Raven's Avatar
    Well, Nokia are meant to be sending the phone back to me so no idea if it works but their repair log shows the following :


    10/09/2014 16:58:51 Job Precooked
    10/09/2014 16:58:51 Pre-Booked online
    10/09/2014 16:58:51 Note
    After upgrading to the cyan firmware, my phone is stuck in airplane mode. I have tried resetting it but this does not help.
    10/09/2014 17:17:13 Pre-Booked into GRS
    12/09/2014 20:53:10 Booked In
    12/09/2014 20:53:10 Booked In Requires Repair Only
    16/09/2014 03:10:04 Allocated
    16/09/2014 06:55:26 On Workbench
    16/09/2014 07:10:45 BER'd
    BER Non-Tech
    16/09/2014 07:10:46 Note
    liquid damage- next to the memory card connector both printers dont work missing screws
    16/09/2014 07:51:26 QA BER
    16/09/2014 10:25:23 Dispatched

    I'll be interested in what I get back as the phone has never got wet and the only people who have taken it apart would have been Nokia tech support.
    09-16-2014 06:33 AM
  3. weisman87's Avatar
    Well, Nokia are meant to be sending the phone back to me so no idea if it works but their repair log shows the following :


    10/09/2014 16:58:51 Job Precooked
    10/09/2014 16:58:51 Pre-Booked online
    10/09/2014 16:58:51 Note
    After upgrading to the cyan firmware, my phone is stuck in airplane mode. I have tried resetting it but this does not help.
    10/09/2014 17:17:13 Pre-Booked into GRS
    12/09/2014 20:53:10 Booked In
    12/09/2014 20:53:10 Booked In Requires Repair Only
    16/09/2014 03:10:04 Allocated
    16/09/2014 06:55:26 On Workbench
    16/09/2014 07:10:45 BER'd
    BER Non-Tech
    16/09/2014 07:10:46 Note
    liquid damage- next to the memory card connector both printers dont work missing screws
    16/09/2014 07:51:26 QA BER
    16/09/2014 10:25:23 Dispatched

    I'll be interested in what I get back as the phone has never got wet and the only people who have taken it apart would have been Nokia tech support.
    Interesting...the water damage thing doesn't sound very promising, though. I finally got back in touch with them and their final troubleshooting steps were to flash the phone (which I've done) and pull the SIM and try to disable airplane mode and put it back in. Needless to say, I've done both of these and neither worked, so now I have to fight with them about an RM-938 replacement in the US, something they say they can't do. Keep us updated.
    09-16-2014 09:34 AM
  4. 1st_Raven's Avatar
    as expected, my phone has been returned in a non working state and Nokia are not much help when I called them either. Basically they are saying that there is damage to the pcb in the corner near the microsd card and that was caused by liquid.

    Since my phone has been getting very warm there, I am wondering if there is a fault on the pcb which has caused this sim issue to show up. not sure of my next step, as I dont fancy spending a further 500 on a new phone less than a year after getting this one.
    09-17-2014 06:16 AM
  5. weisman87's Avatar
    as expected, my phone has been returned in a non working state and Nokia are not much help when I called them either. Basically they are saying that there is damage to the pcb in the corner near the microsd card and that was caused by liquid.

    Since my phone has been getting very warm there, I am wondering if there is a fault on the pcb which has caused this sim issue to show up. not sure of my next step, as I dont fancy spending a further 500 on a new phone less than a year after getting this one.
    Sorry to hear that. It seems like Nokia is trying it's best not to support the 1520.3 in the US. I understand that it's not a US phone, but when their own warranty site says it is covered, I feel they have some kind of obligation to provide better support. I would keep arguing with them and insist that the water damage thing is BS. I have no idea where they'd get the idea that there's water damage when water has never touched your phone. Keep at it and be insisting but polite. Keep providing updates if you don't mind.
    09-17-2014 09:27 AM
  6. 1st_Raven's Avatar
    Sorry to hear that. It seems like Nokia is trying it's best not to support the 1520.3 in the US. I understand that it's not a US phone, but when their own warranty site says it is covered, I feel they have some kind of obligation to provide better support. I would keep arguing with them and insist that the water damage thing is BS. I have no idea where they'd get the idea that there's water damage when water has never touched your phone. Keep at it and be insisting but polite. Keep providing updates if you don't mind.
    I'm based in the UK so its not just the US. I've spoken to Nokia again but my device has now been logged with water damage and the warranty is classed as void so its a little difficult to get anywhere with them. Luckily I still have the 8.0 firmware on my laptop so I have just flashed the device back to that and it is working again. Still think it is a firmware issue but tempted to just wait until the 1530 comes out now.
    09-17-2014 11:00 AM
  7. weisman87's Avatar
    I'm based in the UK so its not just the US. I've spoken to Nokia again but my device has now been logged with water damage and the warranty is classed as void so its a little difficult to get anywhere with them. Luckily I still have the 8.0 firmware on my laptop so I have just flashed the device back to that and it is working again. Still think it is a firmware issue but tempted to just wait until the 1530 comes out now.
    This is no doubt a firmware problem, it only happens with Cyan. My desperate hope is that Denim comes out and this problem goes away...but that will be a while. Nokia has thrown in the towel on my case, since the clean flash and removing/re-adding the SIM didn't fix it, they closed my case. Now I'm stuck fighting them about getting a replacement RM-938, which seems to be impossible.
    09-17-2014 11:09 AM
  8. weisman87's Avatar
    I got off the phone with Nokia Support a few minutes ago. They will not do anything for getting a replacement RM-938, so any purchasers outside of the region that phone is intended for are completely out of luck. They will only replace it with an AT&T RM-940. I have two options: wait for Denim and hope it fixes something, or try to contact Nokia Latin America and attempt a warranty exchange with them. Neither are ideal but I'm at the end of the line for Nokia US support, I think.
    09-17-2014 04:13 PM
  9. jcsuarezm's Avatar
    I solved this problem in my Nokia Lumia 1520

    1. Do not remove the sim card and Connect the phone to charge wall
    2. Turn off the phone, not unplug the charger. The phone take a moments for turn off
    3. The phone start automatically without the problem

    Sorry for my english, this is not my maternal language.

    Please comment this solutions work for you
    11-10-2014 08:26 PM
  10. Mohammad Parsa's Avatar
    I solved this problem in my Nokia Lumia 1520

    1. Do not remove the sim card and Connect the phone to charge wall
    2. Turn off the phone, not unplug the charger. The phone take a moments for turn off
    3. The phone start automatically without the problem

    Sorry for my english, this is not my maternal language.

    Please comment this solutions work for you
    I've tried but it didn't work for me

    i downgrade to 8 and install 8.1 developer and its work fine !
    12-10-2014 01:41 PM
  11. Tho Vo's Avatar
    If the issue only available on WP8.1, WP8.0 is OK please try to replace USB cable (the cable have speaker, RF antenna, USB,...). I did it and it work fine.
    Here is my explain, i am not sure it is right or wrong. On the sub Board on USB cable have 2 component DFE1520 (Antenna tunel). for WP8.1 in during start up, Processor check RFFE (RF Front End). If any component on RFFE Bus fail (Short, open circuit, not response,...), the Phone will show airplane mode and you can not turn off.
    You can try to remove USB cable and power on the Phone, you can see
    12-15-2014 01:28 AM
  12. Mohammad Parsa's Avatar
    If the issue only available on WP8.1, WP8.0 is OK please try to replace USB cable (the cable have speaker, RF antenna, USB,...). I did it and it work fine.
    Here is my explain, i am not sure it is right or wrong. On the sub Board on USB cable have 2 component DFE1520 (Antenna tunel). for WP8.1 in during start up, Processor check RFFE (RF Front End). If any component on RFFE Bus fail (Short, open circuit, not response,...), the Phone will show airplane mode and you can not turn off.
    You can try to remove USB cable and power on the Phone, you can see
    i don't have problem with DP windows phone 8.1 ، this problem happen when i update to cyan.
    12-17-2014 10:14 AM
  13. Mohammad Parsa's Avatar
    unfortunately the denim update doesn't fix this problem.
    12-19-2014 11:12 PM
  14. weisman87's Avatar
    unfortunately the denim update doesn't fix this problem.
    Seriously? ****. This was my last hope. I talked to MS twice again about this and they have not gotten back to me like they assured. I think I finally might be at the end of the line with this phone.
    12-19-2014 11:20 PM
  15. Fayer Boll's Avatar
    i got try this sorted by replacing the board while still in warranty.
    12-21-2014 09:01 PM
  16. kwill's Avatar
    I solved this problem in my Nokia Lumia 1520

    1. Do not remove the sim card and Connect the phone to charge wall
    2. Turn off the phone, not unplug the charger. The phone take a moments for turn off
    3. The phone start automatically without the problem

    Sorry for my english, this is not my maternal language.

    Please comment this solutions work for you
    Man, I tried everything in this thread and even opened the phone up to check the signal antennas. THIS ACTUALLY WORKED!! As one poster mentioned, there's something going on with the daughterboard where the signals run into. Obviously plugging in the USB cable does something to the board that gets it working again. Needless to say, I'll be replacing that board anyways. Thanks so much!
    gpobernardo likes this.
    01-15-2015 10:00 PM
  17. Balkrushna Kadam's Avatar
    hey friends lumia 520 stuck in flight mode, is that a hardware issue because i tried every possible software recovery solutions so anyone fixed this please reply on this thread
    04-17-2015 04:07 AM
  18. sheen818's Avatar
    I am in the same situation too. Lumia 830 RM-983 trap in airplane model, no way to use it. Is there someone to help me get old 8.0 firmware? I get this phone with part condition and ex-owner did this upgrade. Someone can help me? Thanks.
    05-16-2015 12:48 PM
  19. Fayer Boll's Avatar
    Man, I tried everything in this thread and even opened the phone up to check the signal antennas. THIS ACTUALLY WORKED!! As one poster mentioned, there's something going on with the daughterboard where the signals run into. Obviously plugging in the USB cable does something to the board that gets it working again. Needless to say, I'll be replacing that board anyways. Thanks so much!
    I second to this. tried the workaround posted in #59, and it does worked. but only after the phone reboots and shows the blue windows logo I unplug the cable. the method is about the same. and im talking about the same 1520 phone which i replaced its board couple months back.

    maybe it does have something to do with usb thingy as explained in post #61 after all.
    05-22-2015 07:28 AM
  20. saagarvikas's Avatar
    Hi,

    It works for me. Now My Lumia 525 is working fine.

    Thanks!!!
    08-20-2015 01:14 AM
  21. Mmazeo's Avatar
    Incredibly frustrating. Nothing working with my 1520.
    08-20-2015 09:29 AM
  22. Brauch2's Avatar
    as expected, my phone has been returned in a non working state and Nokia are not much help when I called them either. Basically they are saying that there is damage to the pcb in the corner near the microsd card and that was caused by liquid.
    I solved this problem in my Nokia Lumia 1520

    1. Do not remove the sim card and Connect the phone to charge wall
    2. Turn off the phone, not unplug the charger. The phone take a moments for turn off
    3. The phone start automatically without the problem
    It's really some problem arround the microSD card. I noticed that my 520 came back to work after the microSD card was removed. I tried another one and the lumia stuck into airplane mode again. Now that it stoped working completly, even without the card, I tried what jcsuarezm wrote and it's working again, I think not for much long. Also, the volume buttons don't work, showing a empty grey bar on top, and if I lock the screen , it turns off after a while.
    Last edited by Brauch2; 08-21-2015 at 08:23 PM.
    08-21-2015 07:20 PM
  23. weisman87's Avatar
    Holy crap guys, I fixed it. I had given up completely on this but was going to try installing the Windows 10 Mobile Preview on this phone, because why not? I have ZERO other options. I can go over all of the steps I went through trying to fix this problem but the one thing I (inadvertently) did to fix it was letting the phone completely die where it shut off on it's own and won't turn on again. At this point, when you plug a charger in, the Windows logo blinks because it doesn't have enough power to boot the phone. I plugged in an old HP TouchPad charger I have (also the same as the one from the Palm Pre) and waited for the phone to boot. The big difference here is that this particular charger powers up phones much faster than typical wall chargers do. Once the phone booted up, the airplane mode problem was completely gone. I put my SIM card in and verified that the phone had an LTE connection. I even completely reset it and restored from a backup of my 930 and it's still working. I think something about letting the phone completely die in combination with the more powerful charger forced something to start working again. Maybe I would have had the same results if I had opened the phone up and disconnected the battery, who knows. Regardless, my 1520.3 is working again and that's something I never thought would happen.
    RumoredNow likes this.
    09-02-2015 08:29 PM
  24. RumoredNow's Avatar
    ^^^ Spec on that should be: "Output 5.3v, 2.0A" so it is slightly higher voltage... 2 amp being quite common.
    09-02-2015 09:43 PM
  25. weisman87's Avatar
    ^^^ Spec on that should be: "Output 5.3v, 2.0A" so it is slightly higher voltage... 2 amp being quite common.
    Yep you're right. Looked at the Nokia wall charger and it has 5V and 1.3A output. It's definitely beefier and has always charged phones quicker than any other wall chargers I've used. Now I just need to decide what to do with these phones. I've got 2 yellow 1520s (one a 1520.3, one a regular 1520 with WM10), a green 1520, and a black 930. I'm swimming in phones over here.
    09-02-2015 10:30 PM
98 1234

Similar Threads

  1. Sold 1520 switched to Nexus 5. Temporarily?
    By Ray Adams in forum Nokia Lumia 1520
    Replies: 5
    Last Post: 11-28-2014, 02:12 PM
  2. Replies: 32
    Last Post: 10-06-2014, 01:30 PM
  3. best 64gb card for nokia lumia 1520.
    By ketan2604 in forum Ask a Question
    Replies: 8
    Last Post: 08-08-2014, 02:22 PM
  4. Replies: 2
    Last Post: 07-30-2014, 08:32 AM
  5. WP8.1 and cyan installing NOW on 1520 for O2 UK
    By Paul Foulkes in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 07-30-2014, 06:19 AM
LINK TO POST COPIED TO CLIPBOARD