1. Timbre70's Avatar
    I am on W8.1

    Just noticed that my front facing cam isn't working when I toggle it in the menu, both on phone's cam and Nokia cam. The screen appears black momentarily, and then it revert to homescreen.

    What's the likely cause?

    I am not sure if it was this way when on W8.0 'cos I didn't test it then.

    So sad........
    08-11-2014 03:56 AM
  2. dKp1977's Avatar
    The first thing to try is a soft reset by pressing and holding volume down and the power button for a couple of seconds (10 or so) until the device reboots. If thatdoesn't fix the problem, you should perform a hard reset. The procedure is the same as mentioned above, but you need to hold down the camera button additionally. If that doesn't fix it either, it's most likely a hardware defect and you should get your device fixed or replaced.
    Timbre70 likes this.
    08-11-2014 04:05 AM
  3. Timbre70's Avatar
    The first thing to try is a soft reset by pressing and holding volume down and the power button for a couple of seconds (10 or so) until the device reboots. If thatdoesn't fix the problem, you should perform a hard reset. The procedure is the same as mentioned above, but you need to hold down the camera button additionally. If that doesn't fix it either, it's most likely a hardware defect and you should get your device fixed or replaced.
    Thanks for your advice. It does not work despite few times resetting it. Looks like I have a lemon unit.

    Just another question, I did the hard reset. However, noticed that my data are still intact. How do I remove or revert to factory state 'cos I will need to bring it to the service centre.
    08-11-2014 04:24 AM
  4. dKp1977's Avatar
    Thanks for your advice. It does not work despite few times resetting it. Looks like I have a lemon unit.

    Just another question, I did the hard reset. However, noticed that my data are still intact. How do I remove or revert to factory state 'cos I will need to bring it to the service centre.
    It looks like you didn't perform a hard reset, but another soft reset. :) Normally the hard reset is performed by pressing and holding volume down, camera button and power button. At least if I remember correctly. But you can also perform it by going into settings -> info. Scroll all the way down and tap on the button "factory reset" or similar (my device is German ;) ).
    Timbre70 likes this.
    08-11-2014 04:32 AM
  5. Timbre70's Avatar
    Update:

    Did numerous hard resets each time with different language zones, and it does not help. Also tried resetting through Nokia Recovery Software, does not help either.

    Strangely, my front camera came back to life after lunch as I was prepared to send it to Nokia Care Centre tomorrow after putting in my leave application. I did nothing at all! Am still perplexed by this mystery. Hope it continues to stay alive.
    08-12-2014 03:22 AM

Similar Threads

  1. WTS AT&T Lumia 1520 White 16 Gb
    By Scienceguy Labs in forum Marketplace Archive
    Replies: 5
    Last Post: 08-22-2014, 11:35 PM
  2. Apps not working after Update 1
    By incredibala in forum Update 1 for Windows Phone 8.1 (GDR1)
    Replies: 16
    Last Post: 08-17-2014, 08:34 PM
  3. Replies: 3
    Last Post: 08-16-2014, 03:46 AM
  4. Replies: 4
    Last Post: 08-13-2014, 01:43 PM
  5. Camera functions reduced since Cyan?
    By EndOfRope in forum Nokia Lumia 1520
    Replies: 5
    Last Post: 08-11-2014, 05:43 AM
LINK TO POST COPIED TO CLIPBOARD