1. ashyk36's Avatar
    Hi,

    bought a lumia 1520 off ebay a couple of weeks ago. I have been having a couple of problems. Im trying to decide if I need to send the phone back or not:

    1. Mobile signal is poor compared to my htc one. where i used to get full barson my htc i still get full bars on my lumia however in weaker areas the phone tends to be out of signal whereas my htc would at least have 1-2 bars.

    2. So a week ago I slept through my alarm. I then later found out that the alarm sound didn't and that the phone only vibrated, i restarted the phone and then the alarm sounded properly- i thought all fixed.

    Then today I had the same problem, while i was having the problem i got a call and text but again no audio-only vibration from the loudspeaker. This time I didn't restart the phone so i could take a video however magically in the next i got text 30 mins and the ringtone sounded so i wasn't able to get a video. while the alarms/ ringtones wasn't sounding I did play a track from my music and the loudspeaker played it ok.

    Can anyone advise me of what the problem is and how to resolve or if I should just return the phone

    Thanks.
    08-11-2014 07:47 AM
  2. David Ibarra2's Avatar
    I am having some of the same issues .
    Since I updated to Cyan , my phone does not give any sound when a call comes in
    08-11-2014 02:04 PM
  3. ashyk36's Avatar
    Is your alarms sounding? Or are they silent?
    08-11-2014 03:19 PM
  4. ashyk36's Avatar
    Can anyone advise?
    08-13-2014 10:51 AM
  5. hiya1987's Avatar
    I have had no problems with my Nokia Lumia 1520 have you tried factory resetting it and see if that fixes it?
    08-13-2014 01:41 PM
  6. shura899's Avatar
    Does anyone have an issue with sound quality? I've got connect Lumia 1520 and Iphone4s to car aux-in, and have lack of bass and high frequency on Lumia 1520, but iphone4s has not that issues.
    08-14-2014 01:28 AM
  7. HillyR's Avatar
    I have had the same issue. Lumia 1520 - updated to 8.1 and phone went on to silent mode and the going to the "ringtones + sounds" menu, I have lost the slide button to activate ringtone or switch pone to silent - really annouying as I am missing all the incoming calls!
    08-14-2014 08:48 AM
  8. ashyk36's Avatar
    The slider menu for me is still there. The phone is actually on loud but I cannot hear anything
    08-14-2014 10:53 AM
  9. rocwest's Avatar
    This might be a little late but I had the same problem. I noticed the ringtone had reset to the default ringtone so I reselected my choice and performed a soft reset. Voila...an audible ringtone and no problems since.
    08-17-2014 02:14 AM

Similar Threads

  1. Replies: 17
    Last Post: 08-17-2014, 04:58 AM
  2. Lumia 520 says 4G?
    By ToonU in forum Nokia Lumia 520
    Replies: 7
    Last Post: 08-12-2014, 04:47 PM
  3. My lumia 720 is not showing the contant from SD card
    By rohandibag in forum Ask a Question
    Replies: 7
    Last Post: 08-12-2014, 12:27 AM
  4. Replies: 2
    Last Post: 08-11-2014, 03:53 PM
  5. Headphone problem
    By Sanket Bajaj in forum Ask a Question
    Replies: 0
    Last Post: 08-11-2014, 06:32 AM
LINK TO POST COPIED TO CLIPBOARD