1. Jim HANDS's Avatar
    Hi all-

    First post here!

    My wife got a RM-937 unlock here in Canada; is on Bell network with their SIM. Seems to be working great with the exception of I don't seem to be able to update it; get the above message when trying to do so. It appears to be from Malaysia; here's all the relevant detail that I've gleaned from the Settings screens:

    Carrier: CV Malaysia
    Software: Windows phone 8.1
    OS version: 8.10.12397.895
    Firmware revision number: 1028.3562.1402.0010
    Hardware revision number: 5.0.0.0

    Running Nokia Lumia Black

    I've tried registering it as a DP phone too but that seems to make no difference when it comes to the issue of updating- anyone have any thoughts as to something I may try to get it to update (hopefully non- destructive); I've removed SIM and tried it, gone with LTE only, and still no joy.

    Thoughts?

    08-20-2014 04:05 PM

Similar Threads

  1. Camera not working after update to Windows Phone 8.1 and Lumia Cyan
    By carlodedonno in forum Windows Phone 8.1
    Replies: 10
    Last Post: 12-15-2014, 08:05 AM
  2. Replies: 3
    Last Post: 08-20-2014, 05:11 PM
  3. How to flash an AT&T lumia 920 with Canada firmware?
    By Ralph Casimir in forum Ask a Question
    Replies: 6
    Last Post: 08-20-2014, 04:28 PM
  4. HTC One M8 for Windows borrows double-tap to wake feature from Nokia
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-20-2014, 03:11 PM
  5. I can't download music and videos to my lumia 520
    By jbenantim in forum Ask a Question
    Replies: 3
    Last Post: 08-20-2014, 02:46 PM
LINK TO POST COPIED TO CLIPBOARD