1. slavrenz's Avatar
    I seem to be having trouble charging my Nokia Lumia 1520 through the front USB port on my JVC head unit (KWR800BT). Other devices will charge just fine, and the Lumia 1520 will charge when plugged into other sources, but for some reason nothing happens when I plug it into the JVC head unit. Does this indicate a potential problem with the head unit - where should I begin troubleshooting this?
    08-25-2014 02:20 AM
  2. slavrenz's Avatar
    Hmm...not exactly the most forthcoming bunch...
    08-26-2014 03:38 AM
  3. Lackooo's Avatar
    Cover data pins (pin 2+3) on your USB cable plug, then it will charge your WP with no problem. My JVC KD-X220 now charging my Lumia 820.

    wp_20151029_11_52_16_pro.jpg
    RumoredNow likes this.
    10-29-2015 06:49 AM
  4. RumoredNow's Avatar
    Hmm...not exactly the most forthcoming bunch...
    To be fair it is a bit of a specialized problem.

    Glad someone stepped up though.
    10-29-2015 11:53 AM

Similar Threads

  1. I'm losing patience with Windows Phone!
    By big dooze in forum Phone Wars
    Replies: 59
    Last Post: 10-11-2014, 03:10 PM
  2. disk space (surface 2 with LTE)
    By exkerZ in forum Microsoft Surface 2
    Replies: 10
    Last Post: 08-30-2014, 10:48 PM
  3. Replies: 5
    Last Post: 08-25-2014, 11:47 PM
  4. Having issues with my speakers Lumia 1020
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-25-2014, 01:13 AM
  5. Who the heck is in charge of advertising?
    By Durishin in forum Microsoft News & Rumors
    Replies: 3
    Last Post: 08-24-2014, 04:19 PM
LINK TO POST COPIED TO CLIPBOARD