1. ahmad12's Avatar
    OK this is the deal I had an at&t 1520 unlocked and used on T-Mobile I always had a daily issue with losing signal so I bought the RM-938 1520.3 but I still have the same issue I lose signal I thought having this phone would have resolved this.
    Any ideas can anyone help please?
    Last edited by Ahmad Ayesh; 10-08-2014 at 03:15 PM.
    10-08-2014 02:53 PM
  2. TheBadGuy_88's Avatar
    you live in a area with No Service! or you're putting your phone somewhere that interferes with service. check your lifestyle habits.
    10-08-2014 04:10 PM
  3. ahmad12's Avatar
    All T-Mobile phones in the house have good signal and when I used the 925 for couple of days I have no issues
    10-08-2014 04:24 PM
  4. HoosierDaddy's Avatar
    All T-Mobile phones in the house have good signal and when I used the 925 for couple of days I have no issues
    FWIW both my 1520.3s have roughly 1 bar less signal than my wife's 925 side by side, both on T-Mobile. Didn't know if the 925 was above average or the 1520 below.
    10-08-2014 07:34 PM
  5. ahmad12's Avatar
    Mine has only 1 bar and goes to zero every few sec I dont understand why since it has the 1700 freq
    10-08-2014 07:56 PM
  6. jmcvey75@yahoo.com's Avatar
    I just switched from a m8 and definitely am getting less bars with the 1520.3. Seems like the 1520.3 doesn't like to switch to lte as often as my m8 did, too. Too bad the ussd codes don't work on this phone so I could pick lte only
    10-08-2014 10:01 PM
  7. ahmad12's Avatar
    So no matter which 1520 I have I will have the same problem I only had such problems with Nokia phones.
    10-08-2014 10:16 PM
  8. jmcvey75@yahoo.com's Avatar
    Just finished my first voice call with this phone and it was horrible compared to my m8. The call was breaking up a lot and even dropped once whereas my m8 would be crystal clear. My m8 is T-Mobile branded and has T-Mobile specific radio software so maybe that's the difference, but there is definitely a difference.
    10-08-2014 11:16 PM
  9. ahmad12's Avatar
    There has to be some kind of fix to this or not?!
    10-08-2014 11:23 PM
  10. Mavee Shah's Avatar
    this happens to me on my Lumia 720 too... It's too embarrassing
    10-08-2014 11:48 PM
  11. ahmad12's Avatar
    this happens to me on my Lumia 720 too... It's too embarrassing
    Is that on T-Mobile or at&t?
    10-09-2014 12:00 AM
  12. HoosierDaddy's Avatar
    So no matter which 1520 I have I will have the same problem I only had such problems with Nokia phones.
    Which problem? Less bars or less LTE. My 1520s had about one less bar than the 925 but it still seems to be constantly on LTE and I have never had a problem with call quality although in theory I would if I was somewhere that the 925 was barely working. I still haven't seen or heard anything but anecdotal that says the 1520 is sub par as opposed to the 925 being above par.
    10-09-2014 06:29 AM
  13. ahmad12's Avatar
    Which problem? Less bars or less LTE. My 1520s had about one less bar than the 925 but it still seems to be constantly on LTE and I have never had a problem with call quality although in theory I would if I was somewhere that the 925 was barely working. I still haven't seen or heard anything but anecdotal that says the 1520 is sub par as opposed to the 925 being above par.
    Less bars but switches between 3g and lte
    And frequently I loss signal completely
    Last edited by Ahmad Ayesh; 10-09-2014 at 12:32 PM.
    10-09-2014 11:11 AM
  14. Carioca Porto's Avatar
    if youre stuck in 2G in an LTE area try to dial any number and cancel it, the fone will switch again to LTE.
    10-09-2014 03:46 PM
  15. ahmad12's Avatar
    Still trying to resolve this so today I switched my setting to 2g and that increased my signal to almost full bars without a drop in signal.
    10-09-2014 09:39 PM
  16. Mavee Shah's Avatar
    Is that on T-Mobile or at&t?
    I'm not from us but i solved the problem by buying a SIM card of another network it works pretty good
    10-17-2014 10:45 PM
  17. ahmad12's Avatar
    I'm not from us but i solved the problem by buying a SIM card of another network it works pretty good
    What do you mean?
    10-20-2014 02:25 PM
  18. Donny James's Avatar
    I unlocked my ATT 1520 RM-940 CYAN update and now use it on T-Mobile. Before I had the L521 on T-Mobile and for both the signal is always fluctuating. So I thought this was normal. I do get LTE on my 1520 and it's mostly on LTE. It fluctuates from LTE to 4G to EDGE to no signal and back when I'm at work and I'm not moving. I'm in Houston TX btw.
    10-21-2014 10:58 AM

Similar Threads

  1. Nokia Lumia 1520-Relevance
    By Zachary Boddy in forum Nokia Lumia 1520
    Replies: 21
    Last Post: 10-10-2014, 11:54 PM
  2. Replies: 4
    Last Post: 10-09-2014, 11:45 AM
  3. Does anyone have an issue with Cortana Live Tile not appearing?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-09-2014, 06:10 AM
  4. I have no signal on my Nokia 520. How do I fix it?
    By WPCentral Question in forum Ask a Question
    Replies: 4
    Last Post: 10-09-2014, 06:02 AM
  5. Can you push in your Lumia 1520 display?
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 10-09-2014, 05:55 AM
LINK TO POST COPIED TO CLIPBOARD