1. Win Luck's Avatar
    I received a Nokia 1520.3 that was swapped by Nokia service center yesterday. My old model was Nokia RM-938_Ita_Ita_905 which work fine expect white dots; the new model is Nokia RM-938_nam_canada_104.

    The first thing I notice is that my new phone doesn't recognize the T-Mobile LTE, in the Setting, the maximum connection speed is only 3G which I used getting LTE. I also exchanged the SIM card in the T-Mobile store, still the same.

    Another thing is, cannot update to Windows phone 8.1. I tried Hard reset, soft reset, use the Nokia Recovery Tool... still cannot get windows phone 8.1 update.

    Please let me know your suggestions.

    Thank you.
    10-16-2014 04:50 PM
  2. plot_almighty's Avatar
    Don't know what to tell you about the data settings except to look up APNs. As far as getting 8.1, I suggest getting a free App Studio account with your primary email and signing up for Preview for Developers. You get the same OS updates OEMs do with none of the carrier BS.

    The Preview is an app you can download and is Microsoft's way of getting direct OTA updates to your phone.
    Win Luck likes this.
    10-16-2014 04:55 PM
  3. metalchick719's Avatar
    Hmm... Access Point should set everything up for you. I assume you're on T-Mobile US since you have a 1520.3? I don't get it. If it's a Canadian (Rogers?) version, it should easily connect to T-Mobile's LTE. Hope you're able to get it all sorted out soon.
    Win Luck likes this.
    10-16-2014 04:57 PM
  4. Kez0's Avatar
    Change the rom, your rom has 4g (LTE) connection disabled. About the 8.1 is because your rom is for an mobile operator that not has enabled the update for update via OTA.
    Win Luck likes this.
    10-16-2014 05:05 PM
  5. theefman's Avatar
    Looks like they somehow loaded the wrong rom on the phone as there was never a Canadian 1520 released. This post mentions the firmware was available so maybe they put in on by mistake and since it was never released it may have some missing drivers for the radio. http://forums.windowscentral.com/nok...tm#post2440009.
    Win Luck likes this.
    10-16-2014 05:19 PM
  6. Win Luck's Avatar
    I use T-Mobile US, when I turn on this phone I need to choose either T-Mobile or MetroPCS at very beginning which I never experienced in previous phone.
    10-16-2014 10:44 PM
  7. Win Luck's Avatar
    Hi Kez0, I did some research after read your post. It seems like someone changed the ROM and messed up the system then send the phone back to Nokia service center for repair, and Nokia just send this to me. According to some posts said if change different ROM with different code that will mess the LTE and cannot restore the LTE even flash back the original ROM. That make sense.

    However, I still cannot find any answer about the "Update to 8.1" issue. I will try to install the preview as you suggest. Hope I can install the preview.
    Last edited by Win Luck; 10-16-2014 at 11:11 PM.
    10-16-2014 10:50 PM
  8. Win Luck's Avatar
    Hey Kez0, according your answer, I should just switch the ROM to the 1520.3 Latin America version, right?
    10-16-2014 10:55 PM
  9. Win Luck's Avatar
    Thanks theefman.
    10-16-2014 10:56 PM
  10. theefman's Avatar
    Hey Kez0, according your answer, I should just switch the ROM to the 1520.3 Latin America version, right?
    Thanks theefman.
    You're on the right track but you have to be careful with flashing roms as there's always a risk. The Xda forums would be a good place to start, try here [Tutorial] Unbrand (flash) Nokia Windows Pho… | Windows Phone 8 Development and Hacking | XDA Forums

    And this is the main forum Windows Phone 8 General - XDA Forums. Its a good idea to search and also ask questions if you're unsure about anything. Hope it works out ok.
    10-17-2014 10:02 AM

Similar Threads

  1. Four column live tiles for 1520
    By iamakii in forum Nokia Lumia 1520
    Replies: 6
    Last Post: 10-24-2014, 05:35 AM
  2. Here is what is coming in the next WhatsApp update for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 2
    Last Post: 10-20-2014, 11:02 PM
  3. Why battery is draining so fast on my 1520?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-17-2014, 10:23 AM
  4. Replies: 3
    Last Post: 10-16-2014, 05:47 PM
  5. Where did my app disappear to on my Windows Nokia Lumia 521?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-16-2014, 04:46 PM
LINK TO POST COPIED TO CLIPBOARD