1. monstervinvin's Avatar
    I dunno why but my 1520's hard controls (back home search) light normally turns off when battery saver kicks in o.O
    10-17-2014 05:20 AM
  2. ieiejdbx's Avatar
    happen to me too with 1520 HK variant
    10-20-2014 06:49 PM
  3. RelTech's Avatar
    have the same problem 1520 HK variant Red. Tried to hard reset but problem came back an hour later. Only happens on Lumia Cyan
    10-24-2014 07:42 AM
  4. furkanavshar's Avatar
    Hi guys, this is related to Device Hub. Yes, exactly!

    So, -the only one- solution is:

    1) Reset your phone (required)
    2) When resetting is completed, complete your installation steps
    3) When the phone is ready to use, quickly go to Settings > Date+Time
    4) Set the year like 2150 or more
    5) Go to Settings, tap the Device Hub
    6) Uninstall it
    7) Set the date as auto again

    Problem will be solved.

    Never open Device Hub even once! Uninstall it and don't install again.

    p.s. If you open Device Hub even once, battery saver crashes and your issue comes over again. Then you must reset your phone to solve it.
    If you open Device Hub once, uninstalling it will not solve this issue. You will have to reset your phones...
    11-11-2014 10:43 PM

Similar Threads

  1. Replies: 7
    Last Post: 01-27-2015, 10:23 AM
  2. Push Notifications problems on Twitter ?
    By GrandGerminator in forum Ask a Question
    Replies: 2
    Last Post: 12-10-2014, 08:31 AM
  3. How do I fix videos not displaying on Lumia 520?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-17-2014, 03:27 AM
  4. Nokia 521 And PC Glitch My Phone Shuts Off My Computer.
    By IceBrgs in forum Nokia Lumia 520
    Replies: 0
    Last Post: 10-17-2014, 03:17 AM
  5. How do I fix duplicate camera roll images on Nokia Lumia 520?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-17-2014, 01:46 AM
LINK TO POST COPIED TO CLIPBOARD