1. Lundon44's Avatar
    This is extremely odd.

    As of today I'm having issues with connectivity. I have perfectly fine data signal (according to my phone anyway) yet various apps are taking longer than normal to open (that require data) or needed to be closed and re-opened.. Videos will stream fine one moment but then seconds later fail or timeout out from taking too long to stream. It seems to be working and dropping randomly.

    Funny part is my phone is showing full bars for LTE while this is occurring. So this makes no sense to me. I had an issue last week where I had a vmail notification that wouldn't go away when I actually had already cleared my vmail a few days before. Not sure if any of this could be SIM card related or not.

    Any guesses anyone?
    Last edited by Lundon44; 11-27-2014 at 12:21 PM.
    11-27-2014 11:54 AM
  2. rferrara90's Avatar
    What phone do you have?
    11-27-2014 12:40 PM
  3. Lundon44's Avatar
    Lumia 1520. Everything has been working fine up until today.
    11-27-2014 12:43 PM

Similar Threads

  1. Bluetooth Issues
    By kepner198 in forum Nokia Lumia 830
    Replies: 9
    Last Post: 12-03-2014, 09:16 PM
  2. Nokia Lumia 930 Overheating Issue and atrocious service
    By chrisouth in forum Nokia Lumia 930
    Replies: 9
    Last Post: 12-03-2014, 01:04 AM
  3. Can't connect to app store
    By wrbird in forum Windows Phone 8.1
    Replies: 0
    Last Post: 11-27-2014, 10:15 AM
  4. Get apps, movies and more for free via Verizon's Connection Day promotion
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-26-2014, 07:11 AM
LINK TO POST COPIED TO CLIPBOARD