1. Matthew Blair's Avatar
    I've read alot online about the supposed fixes that were made to correct the problem (touching with no response and delayed scrolling for me) but haven't really figured out where we're at in the process of getting this worked out. I just got my 1520 three days ago (had a 920...bless its soul. Had to be replaced 4 times until I finally chewed them out and they sent me a new red 1520 for $75) and im noticing that lag at times.

    Where we at?
    01-02-2015 10:37 PM
  2. Matthew Blair's Avatar
    I've adjusted the sensitivity to normal. Also running dev preview with Cyan.
    zain1986 likes this.
    01-02-2015 10:48 PM
  3. jodeltje's Avatar
    I think you're confusing the tap/swipe issue due to loose contacts, with whatever you're experiencing.

    I never experienced NO reaction to touch.
    I have heard of lag due to enrolling in de DP, so, don't run beta software if you want a smooth experience.
    Matthew Blair likes this.
    01-03-2015 08:50 AM
  4. aximtreo's Avatar
    It's been announced that the rest of Denim updates will be coming early 2015; whatever that means. I have also read that the people that flashed the Finnish Denim rom have noticed a real improvement in the lag and sensitivity.

    I would say the we should hear more about the update in the next few days.
    raydwatts and Matthew Blair like this.
    01-03-2015 11:16 AM
  5. Ed Boland's Avatar
    I just had my 1520 replaced under warranty a few days ago for radio/connectivity reasons. Didn't have any touch/tap/swipe issues with it, nor do I have any issues with this new one. I have the latest PFD installed and no lag issues either.... It's amazingly fast!
    01-04-2015 07:59 AM
  6. oldpueblo's Avatar
    I just got a 1520 and I'm on the latest DP. I upgraded straight to it so I don't know if I had an issue before or not, but basically I have pretty regularly where I go to swipe/scroll and it does a tap instead, so that I have to go back and swipe/scroll. It never repeats it a second time, just every once in awhile a swipe is a tap no matter the pressure I use.
    01-04-2015 10:46 PM
  7. bL33d's Avatar
    I just got a 1520 and I'm on the latest DP. I upgraded straight to it so I don't know if I had an issue before or not, but basically I have pretty regularly where I go to swipe/scroll and it does a tap instead, so that I have to go back and swipe/scroll. It never repeats it a second time, just every once in awhile a swipe is a tap no matter the pressure I use.
    Same for me can get annoying.
    01-05-2015 09:29 PM
  8. bikermunda's Avatar
    Same for me can get annoying.
    This is the reason i might end up getting rid of the phone
    01-06-2015 06:50 PM
  9. anon9169769's Avatar
    As crazy as it sounds.... Clean the screen with a baby wipe and run a paper kitchen towel after.... It makes all the difference. Haven't had an issue for weeks as I do that every day and make sure my hands are always grease free like washing my hands after a sandwich and not picking the phone up till then
    Ed Boland likes this.
    01-06-2015 07:32 PM
  10. chmun77's Avatar
    Annoying with my 1520 as well. The scroll-lift-finger gesture is always interpreted as a tap action. Frustrating especially when using Facebook app where there are lots of links and photos. I have not such issue on 1020, even with a screen with finger prints. Not sure if Denim can actually fix it.
    01-06-2015 08:12 PM
  11. SlitheryImp's Avatar
    Not sure if Denim can actually fix it.
    Don't hold your breath , Denim didn't fix it for me...
    01-07-2015 03:55 AM
  12. oldpueblo's Avatar
    As crazy as it sounds.... Clean the screen with a baby wipe and run a paper kitchen towel after.... It makes all the difference. Haven't had an issue for weeks as I do that every day and make sure my hands are always grease free like washing my hands after a sandwich and not picking the phone up till then
    Mine did it from day one with a brand new phone though. I could see that over time, but not brand new. It definitely seems to be some kind of sensitivity setting.
    01-08-2015 12:52 AM
  13. Loco5150's Avatar
    Static electricity and as pointed out this could be caused by faulty grounding.

    This would be why cleaning helps.
    01-08-2015 01:01 AM

Similar Threads

  1. Anyone know what happened to the Urbanspoon app?
    By jwinch2 in forum Windows Phone Apps
    Replies: 4
    Last Post: 01-18-2015, 02:41 PM
  2. Costco App - start bugging them!
    By vEEP pEEP in forum Windows Phone Apps
    Replies: 12
    Last Post: 01-05-2015, 04:44 PM
  3. Where does "Contacts" trasferred through blue tooth will be stored?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-03-2015, 04:25 AM
  4. How do I install KIS on my Lumia 1520?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-02-2015, 10:09 PM
  5. Help with Sprint iPhone5 unlock
    By mjoshi123 in forum iPhone
    Replies: 0
    Last Post: 01-02-2015, 08:02 PM
LINK TO POST COPIED TO CLIPBOARD