1. jlzimmerman's Avatar
    So I picked up a 1520 and moved to AT&T but I'm having a connection problem which I initially posted HERE. My phone in most cases will not connect to cellular data after leaving a Wi-Fi connected area. The AT&T rep I just spoke to said that is because I'm not toggling off my Wi-Fi when I leave. I told him I never had to do this on my last carrier. He said that is how the service works and he even has to do it on his phone. I disagreed with him but he persisted. Is this a feature with AT&T service or did this guy just blow smoke up my ***?
    02-06-2015 09:12 AM
  2. Microsoftjunkie's Avatar
    That's weird, I had a 1520 ATT model and never had that problem. I always use wifi at home and never once cut it off when I leave. Is your 1520 up to date? Do you have system settings installed? Don't know if those could be the problem, but could be.
    02-06-2015 09:22 AM
  3. Likwidz's Avatar
    1520 on ATT also and don't have that issue either
    02-06-2015 09:32 AM
  4. theolympusguy's Avatar
    I also have an awesome 1520 from ATT and have no issues. I did have a faulty phone and had to exchange for another but no other issues.
    02-06-2015 09:40 AM
  5. RumoredNow's Avatar
    This definitely should not be...

    I'm curious though; is it all WiFi or is AT&T hotspots causing this?

    Could you go to Settings > WiFi > WiFi Sense and post your settings?
    Also Settings > WiFi > Manage and post your settings?

    There may be something in there to tweak and change the behavior. It sounds very disruptive and annoying.

    Also double check Settings > cellular + SIM > make sure data connection is toggled "On," roaming enabled and use cellular data is selected for limited WiFi connectivity.

    It probably would not hurt to ensure you have the proper APN set up in Settings > cellular + SIM > SIM settings > edit internet APN

    If we can't find anything in the settings, go to a local AT&T store and get a new SIM.
    02-06-2015 09:54 AM
  6. jlzimmerman's Avatar
    Yeah, I thought that guy was talking out the side of his neck. Thanks for the input.


    That's weird, I had a 1520 ATT model and never had that problem. I always use wifi at home and never once cut it off when I leave. Is your 1520 up to date? Do you have system settings installed? Don't know if those could be the problem, but could be.
    Yeah, The firmware and OS versions are current. It appears I just bought a glitchy 1520.
    02-06-2015 09:58 AM
  7. Maaz Mansori's Avatar
    AT&T 1520 here as well. The only time I need to toggle WiFi off is when I have a bad connection that it is still picking up, for example outside of my house. As soon as I leave a WiFi area completely, it switches to LTE no problem.
    02-06-2015 10:01 AM
  8. jlzimmerman's Avatar
    This definitely should not be...

    I'm curious though; is it all WiFi or is AT&T hotspots causing this?
    All Wifi connections.

    Could you go to Settings > WiFi > WiFi Sense and post your settings?
    Also Settings > WiFi > Manage and post your settings?

    There may be something in there to tweak and change the behavior. It sounds very disruptive and annoying.
    Both Wifi Sense settings are turned off, as I want. WiFi Manage setting is on.

    Also double check Settings > cellular + SIM > make sure data connection is toggled "On," roaming enabled and use cellular data is selected for limited WiFi connectivity.
    Yep.

    It probably would not hurt to ensure you have the proper APN set up in Settings > cellular + SIM > SIM settings > edit internet APN
    I've had 4 Windows phones and never had to do this. Why? I added "pta" as the APN. Everything else I left blank.

    If we can't find anything in the settings, go to a local AT&T store and get a new SIM.
    Getting a new SIM may be something I do, but I more or less am thinking I bought a glitchy phone on eBay.
    02-06-2015 10:28 AM
  9. RumoredNow's Avatar
    I'm just trying to see if there is any configuration on the phone that can be altered to solve the issue... APNs get changed by carriers from time to time. You do have a new (to you) SIM as you just signed up and everything should be good APN-wise. However, an old SIM may have been given to you by mistake. I don't think it hurts to double check as the APN is what gets you the cellular data that is lagging after you exit a WiFi connected environment.

    Check your SIM compatibility as per this link: Programming non-AT&T devices with the correct APN and MMS data settings - AT&T Support

    Also, I'm not sure where "pta" came from? All the research I can find suggests APN should equal "phone" as per the tables in the first link and the Accepted Answer here for a Lumia specific inquiry: Re: INTERNET APN & MMS APN SETTINGS - AT&T Community
    ElronTheElder and jlzimmerman like this.
    02-06-2015 10:46 AM
  10. RumoredNow's Avatar
    OK... so it looks like, after further research, the "pta" APN is somewhat older (2011-2012) and it may be outdated.
    aximtreo and jlzimmerman like this.
    02-06-2015 10:50 AM
  11. jlzimmerman's Avatar
    I'm just trying to see if there is any configuration on the phone that can be altered to solve the issue... APNs get changed by carriers from time to time. You do have a new (to you) SIM as you just signed up and everything should be good APN-wise. However, an old SIM may have been given to you by mistake. I don't think it hurts to double check as the APN is what gets you the cellular data that is lagging after you exit a WiFi connected environment.

    Check your SIM compatibility as per this link: Programming non-AT&T devices with the correct APN and MMS data settings - AT&T Support

    Also, I'm not sure where "pta" came from? All the research I can find suggests APN should equal "phone" as per the tables in the first link and the Accepted Answer here for a Lumia specific inquiry: Re: INTERNET APN & MMS APN SETTINGS - AT&T Community
    I'll see how it goes based on the setting provided in the link, however AT&T provided me my nano-SIM at their store. I shouldn't have to do any changes to these settings so I will call them to evaluate.
    RumoredNow likes this.
    02-06-2015 11:17 AM
  12. ElronTheElder's Avatar
    If configured for LTE service on AT&T's backend then APN settings are the most likely problem.
    On Android with an AT&T mvno; data only with Wi-Fi was a sure sign you were not configured on the carriers backend as being LTE capable.
    That is what I suspect here.
    02-06-2015 11:47 AM
  13. captblaze's Avatar
    Has the device IMEI been registered to your account, or did they just provision a SIM and pop it in your phone.? Data will not function properly without IMEI on account even though you have a working SIM
    02-06-2015 11:48 AM
  14. jlzimmerman's Avatar
    Has the device IMEI been registered to your account, or did they just provision a SIM and pop it in your phone.? Data will not function properly without IMEI on account even though you have a working SIM
    The phone and its IMEI have been linked to my account. Thanks for asking.
    02-06-2015 12:22 PM
  15. Just_Me's Avatar
    My neighbor had the same problem. He solved it by going to the ATT store and got the sim replaced with a secure sim. He needed it anyway to use softcard NFC pay.
    02-11-2015 07:49 PM

Similar Threads

  1. Replies: 3
    Last Post: 06-15-2016, 07:11 PM
  2. Replies: 6
    Last Post: 02-10-2015, 02:49 AM
  3. What is the difference between the normal Lumia 920 & AT&T Lumia 920?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 02-06-2015, 12:39 PM
  4. Let me Translate Some leaked picture of WP10 from ITHOME
    By 469377116z3 in forum Windows 10 Mobile Insider Preview
    Replies: 4
    Last Post: 02-06-2015, 08:30 AM
  5. Cycloramic review - an easy way to create panoramic images from your Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-06-2015, 07:30 AM
LINK TO POST COPIED TO CLIPBOARD