1. PBlessing's Avatar
    As of this morning I have not been able to connect my AT&T 1520 Lumia to my wireless network. Last night I did the Denim upgrade via the same network. Android tablets and iphones having no issues connecting. Have restarted the router, verified MAC Address. Deleted MAC from access control. Disabled all security (made it an open network) and it still will not connect.

    Any suggestions?
    02-27-2015 12:22 PM
  2. Mark863's Avatar
    Use the Lumia System Recovery Tool to reinstall Denim or Hard reset.
    02-27-2015 12:26 PM
  3. HeyCori's Avatar
    Have you tried forgetting the network and re-entering the password?

    I assume you tried a soft reset of your phone alreadyl
    02-27-2015 12:44 PM
  4. PBlessing's Avatar
    I have tried forgetting the network and rentering the password. I even removed the need for the password all together. I am hesitant to do a hard reset or lumia recovery software as I have seen a few other instances of this cropping up and neither has been successful in resolving the issue.
    02-27-2015 12:58 PM
  5. PBlessing's Avatar
    Well not sure why but can now connect to wireless again with no resetting or changes. So this thread can be closed.
    HeyCori and Captain_Eric like this.
    02-27-2015 02:31 PM
  6. JW888's Avatar
    Well not sure why but can now connect to wireless again with no resetting or changes. So this thread can be closed.
    Nice to hear that.
    02-28-2015 11:41 AM
  7. tropolite's Avatar
    Hi guys... since my Denim update (using Nokia Retail Tool) flashed the whole thing. Since then though my 1520's WiFi has not been the best. I've had to turn off my 1520 to reset otherwise it just won't connect dynamically to already known spots and locations.

    If someone has a solution to this is would be helpful otherwise I may have to wait for Windows 10 TP to come on the 1520...
    Roumen Dontchev likes this.
    03-05-2015 03:37 AM
  8. Roumen Dontchev's Avatar
    Same issue with me as tropolite. I've installed Denim by Recovery Tool and WiFi started loose signal, connection is very slow. When I go to WiFi settings it starts searching signal as if it has been lost. Very strange behaviour in fact...
    03-07-2015 04:23 AM
  9. Wevenhuis's Avatar
    Oh, dear, what I understood was that denim should have solved wifi isssues with the 1520. Could it perhaps be a hardware issue?
    03-07-2015 09:43 AM
  10. Roumen Dontchev's Avatar
    I've solved this problem with Recovery Tool - recovered the Denim several times and now the WiFi works fine.
    03-08-2015 07:11 AM
  11. James Jennett's Avatar
    Well, I got a new wifi hotspot today and before I did anything with it, I changed the default SSID, join password and admin passwords.

    Could NOT get my 1520 to connect to it.

    Made sure WIFI password matched perfectly.

    Found the posts above, just restarted my 1520. Now works fine.

    I love consistency.
    03-24-2015 07:21 AM
  12. joeonsunset's Avatar
    I'm in the same boat. My 1520 stopped connecting reliably to almost any wifi AP recently, post Denim-update. Really frustrating, but, I guess I will have to go down the hard reset rabbit hole. Which really sucks--I JUST got my start screen the way I wanted it. (If only there was a way of backing that up!)
    03-27-2015 07:43 PM
  13. joeonsunset's Avatar
    What's this? My Start Screen got backed up? lol. There's a year-old piece of news I had missed. What a relief. And it looks like a Recovery Tool flash fixed the wi-fi problem for me as well (for now.)
    03-28-2015 12:43 AM
  14. aleunge's Avatar
    Wow. Does the recovery flash really fix wifi issues on the 1520? I have two (different rm) and there were always issues with reconnecting to known networks (restart would temporarily help) but the frequency really increased with the denim update... Would be nice to know although a flash/reset isn't quite ideal....
    03-30-2015 03:35 AM
  15. Avro504's Avatar
    Had to do a reset to get my 1520 to connect to wifi after Denim update, since then has occasionally needed a reboot to connect, very annoying as it was very reliiable on black and cyan.
    03-31-2015 04:27 PM
  16. aleunge's Avatar
    Recently updated to 8.1 GDR2 (with Insider hack) and WiFi issues seem to have reduced. So far so good but will report later since I have two and just updated to GDR2 on that other one as well.
    HeyCori likes this.
    04-23-2015 05:18 PM
  17. phelme's Avatar
    I've been having WiFi issues as well since installing Denim on my 1520.3.

    For me, the troubles seem to be related to which access point I connected to last. There is a particular AP at my fitness club that has reliability issues, but once I do successfully connect to it, whenever I get home I almost never can connect to my home AP's, any of them (and there are 4 in the network). I have to power cycle to get the 1520 to work. This wasn't the case before installing Denim.

    I'm on GDR2 now (thanks to Windows Insider) and it hasn't made any difference.
    06-06-2015 01:11 PM

Similar Threads

  1. Lumia Cyan/Denim Crisis
    By Suwadith in forum Nokia Lumia 925
    Replies: 10
    Last Post: 04-08-2015, 09:10 AM
  2. Why i am not able to play green farm 3 on my lumia 630?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-27-2015, 12:06 PM
  3. Lenovo promises to sell 'cleaner, safer PCs'
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-27-2015, 11:20 AM
  4. NOAA Hi-Def Radar for Windows and Windows Phone updated with new Live Tile settings
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-27-2015, 10:42 AM
  5. Microsoft to launch official Xbox One support via Reddit on March 2
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-27-2015, 10:42 AM
LINK TO POST COPIED TO CLIPBOARD