1. magicdesign's Avatar
    Hi. I am hoping someone can help. I have just moved and in my new location, I have a weak 3g signal and a stronger 2g signal. Problem is the lumia is selecting only the 2g network.

    I can put the sim into a blackberry and also an xperia z and they both prioritise the 3g network.

    Is there any way I can tell the lumia to select only the 3g network?
    03-15-2015 12:44 PM
  2. Kaushik Banerjee's Avatar
    Hi. I am hoping someone can help. I have just moved and in my new location, I have a weak 3g signal and a stronger 2g signal. Problem is the lumia is selecting only the 2g network.

    I can put the sim into a blackberry and also an xperia z and they both prioritise the 3g network.

    Is there any way I can tell the lumia to select only the 3g network?
    Settings - mobile+sim - Highest connection speed > set to 3g
    03-15-2015 12:47 PM
  3. chandu95's Avatar
    Hi. I am hoping someone can help. I have just moved and in my new location, I have a weak 3g signal and a stronger 2g signal. Problem is the lumia is selecting only the 2g network.

    I can put the sim into a blackberry and also an xperia z and they both prioritise the 3g network.

    Is there any way I can tell the lumia to select only the 3g network?
    Options like that to force 3g only isn't available. I faced the same problem before and switched my network. Here is the user suggesion link for it http://lumia.ms/1xc1W8v
    03-15-2015 12:54 PM
  4. RumoredNow's Avatar
    It really depends... You don't say what phone you have. We assume it is a 1520 because of the forum you posted in, but also there are 4 versions of 1520.

    Have you ever tried to get into the Field Test Menu?

    Dial ##3282# if you are locked out of Field Test you can not proceed.

    If you can get into Field Test > Accept the notification > WCDMA > settings > In Network Type select for "3G only"

    Now your phone will ignore the stronger 2G and use only 3G. If you leave a 3G area you will have no data connection until you go back in and select "automatic" for Network Type.
    03-15-2015 05:32 PM
  5. chandu95's Avatar
    Field test mode used to work in win8, I think they removed It in 8.1
    03-15-2015 09:39 PM
  6. RumoredNow's Avatar
    It's still working on ATT 1520 even with the latest 8.1 update + Denim...

    That's why I advise the OP to try since they don't state what phone they have. Most phones now it is disabled, but there are a rare few still reporting they can access Field Menu.
    chandu95 likes this.
    03-15-2015 10:58 PM
  7. magicdesign's Avatar
    tried the shortcut but it returns an error so i assume the field test menu is not available on my device.
    RumoredNow likes this.
    03-16-2015 07:58 AM

Similar Threads

  1. Why does my phone only show the Nokia icon on a red screen?
    By Windows Central Question in forum Ask a Question
    Replies: 20
    Last Post: 04-12-2015, 08:53 PM
  2. Replies: 7
    Last Post: 03-16-2015, 01:26 AM
  3. Replies: 1
    Last Post: 03-15-2015, 10:08 AM
  4. Why do my incoming texts only show the day and time and not the date?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-14-2015, 04:44 PM
  5. What do I do if it is showing only the Nokia icon and nothing else?
    By Windows Central Question in forum Nokia Lumia 525
    Replies: 2
    Last Post: 03-14-2015, 11:12 AM
LINK TO POST COPIED TO CLIPBOARD