1. trevywankenobi's Avatar
    I bought a Lumia 1520.3 from B&H and I cut my sim card down from a micro sim to a nano sim. I know it still works because I put it back in my 920. It says on my 1520.3 says no service in the live tile.
    03-28-2015 11:59 AM
  2. several potatos's Avatar
    If you swapped the SIM in or out of the 1520 while it was on, that may be your issue. That, and cut SIM cards don't work well in general. The adapter you're using to put it in the 920 may be why it works in it. Try getting a real nano
    03-28-2015 12:27 PM
  3. r970617's Avatar
    Did the nano sim resolve the issue? I just got a 1520 that can't connect to a network. I have a nano sim and I checked it in another phone and it is working.
    12-13-2016 08:45 PM
  4. NookHD's Avatar
    Last time something like this happened to me. My carrier was T-Mobile. I took it in; they did nothing special just switched the SIM card, and they fixed the problem.
    12-14-2016 03:32 AM

Similar Threads

  1. Lumia Camera 5 (Denim) color problem
    By teohabunal in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 04-22-2015, 11:28 PM
  2. Replies: 4
    Last Post: 03-29-2015, 05:38 AM
  3. No Keyboard in iPhone?
    By FiveFngrsOfDef in forum Microsoft Band & Band 2
    Replies: 3
    Last Post: 03-28-2015, 02:28 PM
  4. Photos taken with Lumia 930 beat iPhone 6 Plus and Galaxy Note 4 in blind test
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-28-2015, 11:11 AM
  5. Is there a virus guard for the Microsoft Lumia 535?
    By WPCentral Question in forum Microsoft Lumia 535
    Replies: 5
    Last Post: 03-28-2015, 11:05 AM
LINK TO POST COPIED TO CLIPBOARD