1. hurkanasmaci's Avatar
    Hello guys,

    I have been using my 1520 for over a year now, the battery life has been incredible. I absolutely love this phone. But I have been having some problems with my battery life for the last 2-3 days. It drains really fast, %25-45 per hour, and when I charge it, it stays at the same percentage, but the battery icon shows the lightning thingy, so I know that it's charging. For example, today I plugged it in to charge at 8pm with %21 remaining, when I checked it at midnight, it was still %21. I'm writing this as my phone is still plugged in, and now it's %11 and it keeps dropping even though it's being charged. There is a little heat on the upperside of the screen but it usually is there when I use my phone, it never affects me or my usage. I've tried soft reset, couple of times. The only new app I've installed is telegram messenger beta, and I've tried deleting it, it doesn't work. Does anyone have the same complaints or any suggestions? I'm pretty sure that it's draining as it charges, I have %9 battery now. I'm not sure whether it is a hardware or a software problem.
    06-02-2015 04:07 PM
  2. zkyevolved's Avatar
    Could be a software bug. Restart it. It could be a more permanent software issue. Reset it. It could be a bad installation. Plug it into the PC to re-download the OS as a fresh install. Don't restore from and backups.

    Sorry. I know you weren't looking for any deleting or anything like that... But, sorry... If the first doesn't work, that's all you'll have left. 😧

    Sent from my Note 4 using Tapatalk
    hurkanasmaci likes this.
    06-02-2015 04:47 PM
  3. jsooney's Avatar
    My battery time is pretty much worthless at this point, with even light usage resulting in the phone shutting down. The other day I checked my email, browsed the web for 10 minutes, had a 30 second conversation and that was it. Another time I took four photos and it died.

    Like you it was good for a year or so, but then deteriorated badly. It seemed to coincide with the Denim update, but I'm not sure it that was a factor. I have done hard resets and all that but it didn't help. I saw a post where someone said they got their battery replaced and that helped, but I'm not going to fool with sending it off somewhere for three weeks. I think I'll just drive over it a few times and get something else soon.
    hurkanasmaci likes this.
    06-02-2015 05:27 PM
  4. ScrubbyXD's Avatar
    Yes you probably need a new battery.
    RumoredNow and hurkanasmaci like this.
    06-02-2015 06:17 PM
  5. hurkanasmaci's Avatar
    Thanks you guys for the suggestions. I don't it's a hardware problem because it happened so suddenly. I haven't seen any drop in battery life for over a year, like I said, this just started to happen 2-3 days ago. I will try to hard reset it, if it doesn't solve it I will try to install the os again.
    06-03-2015 01:53 AM

Similar Threads

  1. BATTERY SAVER usage settings
    By nesetceri in forum Windows Phone 8.1
    Replies: 1
    Last Post: 06-02-2015, 04:51 PM
  2. Lumia 1520 Battery Problems
    By hurkanasmaci in forum Ask a Question
    Replies: 1
    Last Post: 06-02-2015, 04:39 PM
  3. Problem with notes traveler
    By jonesdust in forum Applications
    Replies: 0
    Last Post: 06-02-2015, 09:26 AM
  4. ATIV Odyssey Connection problem to Desktop PC
    By russwalden in forum Samsung ATIV Odyssey
    Replies: 0
    Last Post: 06-02-2015, 09:21 AM
  5. Replies: 1
    Last Post: 06-02-2015, 03:31 AM
LINK TO POST COPIED TO CLIPBOARD