1. A2014's Avatar
    I am having a problem with the keyboard is that whenever I plugging the tablet with the keyboard, the screen get blank and nothing responding both the keyboard & tablet. I checked the system firmware update history and the latest installed on 11/02/2014.

    Can anybody has this problem or give me a solution. Otherwise I am thinking to return the keyboard for fault.
    02-22-2014 03:14 PM
  2. JimmyRandall's Avatar
    Try powering down the 2520, connect it to the keyboard then power the 2520 back on.

    Does the caps lock blue light come on when they are both connected and on?
    02-22-2014 04:16 PM
  3. A2014's Avatar
    I have just tried switching off the tablet, connect it to the keyboard and try to switch on the tablet again. But the tablet is not powering up and the keyboard caps lock blue light is not on. I can smell some plastic burning smell near the connector of the tablet (now not sure whether the problem with the connector of the tablet or keyboard). Tablet alone is powering up normally. I bought the tablet in early jan2014 & the keyboard in early feb2014.
    02-22-2014 05:27 PM
  4. JimmyRandall's Avatar
    Think you should have started this thread with the "burning smell" problem, take it back it shouldn't be smelling of any kind.
    02-23-2014 12:22 PM

Similar Threads

  1. Replies: 3
    Last Post: 04-17-2014, 11:35 PM
  2. Forums TOOOOOOOOOOO slow on lumia 520
    By Saksham Sharma in forum Windows Central for Windows Phone - App Support
    Replies: 16
    Last Post: 03-02-2014, 04:41 AM
  3. Office/Skydrive upload problem
    By gedzum in forum Microsoft Office
    Replies: 2
    Last Post: 02-26-2014, 02:41 PM
  4. Insider showing 1gb of ram in lumia 1520.
    By stylo388 in forum Nokia Lumia 1520
    Replies: 6
    Last Post: 02-23-2014, 04:41 PM
  5. Lumia 1020 locked to EE, but won't recognise T-Mobile SIM
    By deer_dodger in forum Carrier Discussion Lounge
    Replies: 2
    Last Post: 02-23-2014, 03:21 AM
LINK TO POST COPIED TO CLIPBOARD